summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-01-18 18:12:23 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-01-18 18:12:23 +0000
commit0ad5cedc20dae7bd2bf2a9668e8f279ca27e8b05 (patch)
treefa237853588d0e41d9c0d525e6723cc372002169
parentStable on sparc (diff)
downloadgentoo-2-0ad5cedc20dae7bd2bf2a9668e8f279ca27e8b05.tar.gz
gentoo-2-0ad5cedc20dae7bd2bf2a9668e8f279ca27e8b05.tar.bz2
gentoo-2-0ad5cedc20dae7bd2bf2a9668e8f279ca27e8b05.zip
build fixes for nptl and pyuno problems
(Portage version: 2.0.51-r13)
-rw-r--r--app-office/openoffice-ximian/ChangeLog8
-rw-r--r--app-office/openoffice-ximian/files/1.1.3/nptl.patch (renamed from app-office/openoffice-ximian/files/1.1.3/gcc34-nptl-fix.patch)15
-rw-r--r--app-office/openoffice-ximian/files/1.1.3/pyunolink-fix.patch14
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild7
4 files changed, 40 insertions, 4 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index a8671d54b89d..1d0a99c3ff54 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.96 2005/01/17 20:43:25 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.97 2005/01/18 18:12:22 suka Exp $
+
+ 18 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
+ -files/1.1.3/gcc34-nptl-fix.patch, +files/1.1.3/nptl.patch,
+ +files/1.1.3/pyunolink-fix.patch, openoffice-ximian-1.3.7.ebuild:
+ Fixes for nptl and pyuno build breakage, should close quite some bugs, if
+ this works out
17 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
+files/1.1.3/gcc-instlib.patch, openoffice-ximian-1.3.7.ebuild:
diff --git a/app-office/openoffice-ximian/files/1.1.3/gcc34-nptl-fix.patch b/app-office/openoffice-ximian/files/1.1.3/nptl.patch
index 3e3360b2f422..996a7ceec67d 100644
--- a/app-office/openoffice-ximian/files/1.1.3/gcc34-nptl-fix.patch
+++ b/app-office/openoffice-ximian/files/1.1.3/nptl.patch
@@ -1,5 +1,16 @@
---- ./sal/osl/unx/process.c.orig 2003-07-02 15:34:17.000000000 +0200
-+++ ./sal/osl/unx/process.c 2004-11-01 15:16:40.976815960 +0100
+--- tools/source/solar/solar.c.orig
++++ tools/source/solar/solar.c
+@@ -577,7 +577,7 @@
+
+ {
+ char* p = NULL;
+- InfoMemoryAccess( p );
++ /*InfoMemoryAccess( p );*/
+ p = (char*)&p;
+ InfoMemoryAccess( p );
+ InfoMemoryTypeAccess( t_short );
+*** sal/osl/unx/process.c.orig
+--- sal/osl/unx/process.c
@@ -1017,11 +1017,6 @@
for (i = 0; data.m_pszEnv[i] != NULL; i++)
putenv(data.m_pszEnv[i]);
diff --git a/app-office/openoffice-ximian/files/1.1.3/pyunolink-fix.patch b/app-office/openoffice-ximian/files/1.1.3/pyunolink-fix.patch
new file mode 100644
index 000000000000..6d8ce6323868
--- /dev/null
+++ b/app-office/openoffice-ximian/files/1.1.3/pyunolink-fix.patch
@@ -0,0 +1,14 @@
+--- pyuno.orig/source/module/makefile.mk 2005-01-18 11:59:23.462336464 +0100
++++ pyuno/source/module/makefile.mk 2005-01-18 11:59:42.289474304 +0100
+@@ -82,9 +82,9 @@
+ # so this library cannot be checked
+ SHL1NOCHECK=yes
+ PYUNORC=pyunorc
+-.IF "$(OS)"=="SOLARIS" || "$(OS)"=="MACOSX"
++#.IF "$(OS)"=="SOLARIS" || "$(OS)"=="MACOSX"
+ PYTHONLIB=-lpython
+-.ENDIF
++#.ENDIF
+ .ELSE
+ # on windows, the python executable also uses the shared library,
+ # so we link pyuno directly to it
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild
index 8708de1b647a..0db6289da716 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild,v 1.9 2005/01/17 21:26:17 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.7.ebuild,v 1.10 2005/01/18 18:12:22 suka Exp $
# Notes:
#
@@ -391,6 +391,11 @@ src_compile() {
# Build as minimal as possible
export BUILD_MINIMAL="${LANGNO}"
+ # Embedded python dies without Home set
+ if test "z${HOME}" = "z"; then
+ export HOME=""
+ fi
+
#Get info for parallel build
export JOBS=`echo "${MAKEOPTS}" | sed -e "s/.*-j\([0-9]\+\).*/\1/"`