summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-10-19 19:48:47 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-10-19 19:48:47 +0000
commit0971a1434a272e1c50b9499710545c6252eddcd1 (patch)
tree620bd5e6274c45640cf6c2481c62c45461616878
parent[bump] dev-perl/Net-SSLeay-1.420.0 (diff)
downloadgentoo-2-0971a1434a272e1c50b9499710545c6252eddcd1.tar.gz
gentoo-2-0971a1434a272e1c50b9499710545c6252eddcd1.tar.bz2
gentoo-2-0971a1434a272e1c50b9499710545c6252eddcd1.zip
dev-java/eclipse-ecj: added version 3.7
(Portage version: 2.1.10.29/cvs/Linux x86_64)
-rw-r--r--dev-java/eclipse-ecj/ChangeLog8
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-3.7.1.ebuild103
2 files changed, 110 insertions, 1 deletions
diff --git a/dev-java/eclipse-ecj/ChangeLog b/dev-java/eclipse-ecj/ChangeLog
index ebd4d1ac2985..abafdbc70cce 100644
--- a/dev-java/eclipse-ecj/ChangeLog
+++ b/dev-java/eclipse-ecj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/eclipse-ecj
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/ChangeLog,v 1.72 2011/10/19 15:44:02 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/ChangeLog,v 1.73 2011/10/19 19:48:47 fordfrog Exp $
+
+*eclipse-ecj-3.7.1 (19 Oct 2011)
+
+ 19 Oct 2011; Miroslav Šulc <fordfrog@gentoo.org> +eclipse-ecj-3.7.1.ebuild:
+ Added version 3.7 (bug #380165, thanks William L. Thomson Jr.
+ <wlt@obsidian-studios.com> for the ebuild)
19 Oct 2011; Miroslav Šulc <fordfrog@gentoo.org> -eclipse-ecj-3.5.1.ebuild,
eclipse-ecj-3.5.2.ebuild, eclipse-ecj-3.6.ebuild:
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-3.7.1.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-3.7.1.ebuild
new file mode 100644
index 000000000000..fedbde97228d
--- /dev/null
+++ b/dev-java/eclipse-ecj/eclipse-ecj-3.7.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/eclipse-ecj-3.7.1.ebuild,v 1.1 2011/10/19 19:48:47 fordfrog Exp $
+
+EAPI="4"
+
+inherit java-pkg-2
+
+MY_PN="ecj"
+DMF="R-${PV}-201109091335"
+S="${WORKDIR}"
+
+DESCRIPTION="Eclipse Compiler for Java"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF}/${MY_PN}src-${PV}.jar"
+
+IUSE="+ant userland_GNU"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="3.7"
+
+CDEPEND=">=app-admin/eselect-ecj-0.3"
+
+JAVA_PKG_WANT_SOURCE=1.4
+JAVA_PKG_WANT_TARGET=1.4
+
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.6
+ userland_GNU? ( sys-apps/findutils )"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.4"
+PDEPEND="ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # These have their own package.
+ rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -fr org/eclipse/jdt/internal/antadapter || die
+
+ # upstream build.xml excludes this
+ rm META-INF/eclipse.inf
+}
+
+src_compile() {
+ local javac_opts javac java jar
+
+ javac_opts="$(java-pkg_javac-args) -encoding ISO-8859-1"
+ javac="$(java-config -c)"
+ java="$(java-config -J)"
+ jar="$(java-config -j)"
+
+ find org/ -path org/eclipse/jdt/internal/compiler/apt -prune -o \
+ -path org/eclipse/jdt/internal/compiler/tool -prune -o -name '*.java' \
+ -print > sources-1.4
+ find org/eclipse/jdt/internal/compiler/{apt,tool} -name '*.java' > sources-1.6
+
+ mkdir -p bootstrap || die
+ cp -pPR org bootstrap || die
+ cd "${S}/bootstrap" || die
+
+ einfo "bootstrapping ${MY_PN} with ${javac} ..."
+ ${javac} ${javac_opts} @../sources-1.4 || die
+ ${javac} -encoding ISO-8859-1 -source 1.6 -target 1.6 @../sources-1.6 || die
+
+ find org/ -name '*.class' -o -name '*.properties' -o -name '*.rsc' \
+ | xargs ${jar} cf ${MY_PN}.jar
+
+ cd "${S}" || die
+ einfo "building ${MY_PN} with bootstrapped ${MY_PN} ..."
+ ${java} -classpath bootstrap/${MY_PN}.jar \
+ org.eclipse.jdt.internal.compiler.batch.Main \
+ ${javac_opts} -nowarn @sources-1.4 || die
+ ${java} -classpath bootstrap/${MY_PN}.jar \
+ org.eclipse.jdt.internal.compiler.batch.Main \
+ -encoding ISO-8859-1 -source 1.6 -target 1.6 -nowarn @sources-1.6 || die
+
+ find org/ -name '*.class' -o -name '*.properties' -o -name '*.rsc' \
+ | xargs ${jar} cf ${MY_PN}.jar
+}
+
+src_install() {
+ java-pkg_dolauncher ${MY_PN}-${SLOT} --main \
+ org.eclipse.jdt.internal.compiler.batch.Main
+
+ # disable the class version verify, this has intentionally
+ # some classes with 1.6, but most is 1.4
+ JAVA_PKG_STRICT="" java-pkg_dojar ${MY_PN}.jar
+}
+
+pkg_postinst() {
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ecj-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}