summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-25 10:58:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-25 10:58:41 +0000
commit090be9fe735b7c763ce01b22cc8d2a5bb33b22d9 (patch)
tree43f67675a429e2acdb8d6b9fef17ebacb2239071
parentStable ppc/ppc64, bug #418495 (diff)
downloadgentoo-2-090be9fe735b7c763ce01b22cc8d2a5bb33b22d9.tar.gz
gentoo-2-090be9fe735b7c763ce01b22cc8d2a5bb33b22d9.tar.bz2
gentoo-2-090be9fe735b7c763ce01b22cc8d2a5bb33b22d9.zip
Move patches in FILESDIR to the patch tarball, fix audiofile detection (bug #415981), fix build with gcc 4.7 (bug #425280), fix some autoreconf warnings.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--media-sound/rezound/ChangeLog9
-rw-r--r--media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch12
-rw-r--r--media-sound/rezound/files/rezound-0.12.3_beta-gentoo_bug_334797.patch63
-rw-r--r--media-sound/rezound/files/rezound-0.12.3_beta-m4.patch21
-rw-r--r--media-sound/rezound/rezound-0.12.3_beta-r2.ebuild7
5 files changed, 10 insertions, 102 deletions
diff --git a/media-sound/rezound/ChangeLog b/media-sound/rezound/ChangeLog
index be88c5c57f6f..bb4391b0895d 100644
--- a/media-sound/rezound/ChangeLog
+++ b/media-sound/rezound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/rezound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.62 2012/06/08 13:25:19 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.63 2012/07/25 10:58:41 aballier Exp $
+
+ 25 Jul 2012; Alexis Ballier <aballier@gentoo.org>
+ rezound-0.12.3_beta-r2.ebuild, -files/rezound-0.12.3_beta-gcc44.patch,
+ -files/rezound-0.12.3_beta-gentoo_bug_334797.patch,
+ -files/rezound-0.12.3_beta-m4.patch:
+ Move patches in FILESDIR to the patch tarball, fix audiofile detection (bug
+ #415981), fix build with gcc 4.7 (bug #425280), fix some autoreconf warnings.
21 May 2012; Lars Wendler <polynomial-c@gentoo.org>
rezound-0.12.3_beta-r2.ebuild,
diff --git a/media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch b/media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch
deleted file mode 100644
index 1aef0943b667..000000000000
--- a/media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur rezound-0.12.3beta.orig/src/backend/Remaster/CAdaptiveNormalizeAction.cpp rezound-0.12.3beta/src/backend/Remaster/CAdaptiveNormalizeAction.cpp
---- rezound-0.12.3beta.orig/src/backend/Remaster/CAdaptiveNormalizeAction.cpp 2005-02-15 04:54:44.000000000 +0200
-+++ rezound-0.12.3beta/src/backend/Remaster/CAdaptiveNormalizeAction.cpp 2009-07-12 21:51:43.000000000 +0300
-@@ -18,6 +18,8 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-+#include <cstdio>
-+
- #include "CAdaptiveNormalizeAction.h"
-
- #include <utility>
diff --git a/media-sound/rezound/files/rezound-0.12.3_beta-gentoo_bug_334797.patch b/media-sound/rezound/files/rezound-0.12.3_beta-gentoo_bug_334797.patch
deleted file mode 100644
index e986bb8fc864..000000000000
--- a/media-sound/rezound/files/rezound-0.12.3_beta-gentoo_bug_334797.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Let gcc handle template instantiation of TPoolFile.
-
-http://bugs.gentoo.org/334797
-
-2012-05-22 Martin von Gagern <Martin.vGagern@gmx.net>
-
-Index: rezound-0.12.3beta/src/PoolFile/TPoolFile.h
-===================================================================
---- rezound-0.12.3beta.orig/src/PoolFile/TPoolFile.h
-+++ rezound-0.12.3beta/src/PoolFile/TPoolFile.h
-@@ -403,10 +403,8 @@ private:
-
- };
-
--/* this would be needed if I were utilizing gcc's implicit instantiation for TPoolFile
- #define __TPoolFile_H__CPP
- #include "TPoolFile.cpp"
- #undef __TPoolFile_H__CPP
--*/
-
- #endif
-Index: rezound-0.12.3beta/src/PoolFile/TPoolFile.cpp
-===================================================================
---- rezound-0.12.3beta.orig/src/PoolFile/TPoolFile.cpp
-+++ rezound-0.12.3beta/src/PoolFile/TPoolFile.cpp
-@@ -20,11 +20,9 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
--/* this would be needed if I were utilizing gcc's implicit instantiation for TPoolFile
- #ifndef __TPoolFile_H__CPP
- #error this file must be included through TPoolFile.h NOT compiled on its own
- #endif
--*/
-
- /* ???
- * There are places that I have to do: container.erase(container.begin+index);
-Index: rezound-0.12.3beta/src/backend/CSound.cpp
-===================================================================
---- rezound-0.12.3beta.orig/src/backend/CSound.cpp
-+++ rezound-0.12.3beta/src/backend/CSound.cpp
-@@ -2286,7 +2286,7 @@ void CSound::setUserNotes(const string &
-
-
- // this is the explicit instantiation of the TPoolFile for CSound's purposes
--#include <TPoolFile.cpp>
-+// #include <TPoolFile.cpp>
- template class TPoolFile<sample_pos_t,uint64_t>;
-
- // Some explicit template method instantiations (not sure why some are necessary and some aren't)
-Index: rezound-0.12.3beta/src/backend/CrezSoundTranslator.cpp
-===================================================================
---- rezound-0.12.3beta.orig/src/backend/CrezSoundTranslator.cpp
-+++ rezound-0.12.3beta/src/backend/CrezSoundTranslator.cpp
-@@ -43,7 +43,7 @@ CrezSoundTranslator::~CrezSoundTranslato
-
- // need to include this I use some of the template *methods* for types that are no where else
- // so the explicit instantation at the bottom of CSound.cpp doesn't instantiate everything
--#include <TPoolFile.cpp>
-+// #include <TPoolFile.cpp>
-
- struct RFormatInfo1
- {
diff --git a/media-sound/rezound/files/rezound-0.12.3_beta-m4.patch b/media-sound/rezound/files/rezound-0.12.3_beta-m4.patch
deleted file mode 100644
index e2381e23db17..000000000000
--- a/media-sound/rezound/files/rezound-0.12.3_beta-m4.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-ajv_CXX_FLAG macro is broken and causes m4 to loop forever, let's just assume g++ supports
-these flags, see http://bugs.gentoo.org/305305
-
---- configure.ac
-+++ configure.ac
-@@ -81,13 +81,9 @@
-
-
- ############################################################################
--# Set some compilter flags if they're available #
-+# Set some compilter flags #
- ############################################################################
--ajv_CXX_FLAG(-g)
--ajv_CXX_FLAG(-Wall)
--ajv_CXX_FLAG(-Wno-unused-function)
--ajv_CXX_FLAG(-Wno-unused-variable)
--ajv_CXX_FLAG(-Wno-unused)
-+CXXFLAGS="$CXXFLAGS -g -Wall -Wno-unused-function -Wno-unused-variable -Wno-unused"
-
-
-
diff --git a/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
index ce1c553862b3..1cc128ea1ec7 100644
--- a/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
+++ b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild,v 1.7 2012/06/08 13:25:19 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild,v 1.8 2012/07/25 10:58:41 aballier Exp $
EAPI=4
MY_P=${P/_/}
-PATCHLEVEL=5
+PATCHLEVEL=6
inherit autotools eutils flag-o-matic
@@ -39,9 +39,6 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
- epatch "${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-m4.patch \
- "${FILESDIR}"/${P}-gentoo_bug_334797.patch
AT_M4DIR="config/m4" eautoreconf
}