summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-08-13 02:53:03 +0000
committerMichael Weber <xmw@gentoo.org>2011-08-13 02:53:03 +0000
commit08eebfe09b58a924b3d42af902fa52d58b97471e (patch)
treeb3504b0395f4083429acbed5eff75ba4d374bdac
parentVersion bump (diff)
downloadgentoo-2-08eebfe09b58a924b3d42af902fa52d58b97471e.tar.gz
gentoo-2-08eebfe09b58a924b3d42af902fa52d58b97471e.tar.bz2
gentoo-2-08eebfe09b58a924b3d42af902fa52d58b97471e.zip
Update to newer patchset
(Portage version: 2.1.10.3/cvs/Linux x86_64)
-rw-r--r--app-text/mupdf/ChangeLog5
-rw-r--r--app-text/mupdf/mupdf-9999.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index 3bc51e79cfb2..6f3e5c712daa 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.17 2011/08/10 16:48:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.18 2011/08/13 02:53:03 xmw Exp $
+
+ 13 Aug 2011; Michael Weber <xmw@gentoo.org> mupdf-9999.ebuild:
+ Update to newer patchset, thanks to Jan Psota for the hint (bug 378983)
10 Aug 2011; Markos Chandras <hwoarang@gentoo.org> mupdf-0.8.165.ebuild:
Stable on amd64 wrt bug #378427
diff --git a/app-text/mupdf/mupdf-9999.ebuild b/app-text/mupdf/mupdf-9999.ebuild
index 03f2ba688985..cd052a4bd096 100644
--- a/app-text/mupdf/mupdf-9999.ebuild
+++ b/app-text/mupdf/mupdf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.3 2011/03/29 14:13:56 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.4 2011/08/13 02:53:03 xmw Exp $
EAPI=2
@@ -27,21 +27,22 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.8.15-buildsystem.patch
+ epatch "${FILESDIR}"/${PN}-0.8.165-buildsystem.patch
- use vanilla || epatch "${FILESDIR}"/${PN}-0.8.15-zoom.patch
+ use vanilla || epatch "${FILESDIR}"/${PN}-0.8.165-zoom.patch
}
src_compile() {
- local my_pdfexe=
- use X || my_pdfexe="PDFVIEW_EXE="
+ local my_nox11=
+ use X || my_nox11="NOX11=yes MUPDF= "
- emake build=debug ${my_pdfexe} CC="$(tc-getCC)" verbose=true -j1 || die
+ emake CC="$(tc-getCC)" \
+ build=debug verbose=true ${my_nox11} -j1 || die
}
src_install() {
- emake build=debug ${my_pdfexe} prefix="${D}usr" \
- LIBDIR="${D}usr/$(get_libdir)" verbose=true install || die
+ emake prefix="${D}usr" LIBDIR="${D}usr/$(get_libdir)" \
+ build=debug verbose=true ${my_nox11} install || die
insinto /usr/$(get_libdir)/pkgconfig
doins debian/mupdf.pc || die