summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-01-12 16:05:16 +0000
committerHanno Böck <hanno@gentoo.org>2005-01-12 16:05:16 +0000
commit089dca2e4ad4160fea2a1a436a5e57ddf26b84d1 (patch)
treed1137ec46399f624135a93c122196c3a698dff9f
parentadded ~amd64 to KEYWORDS. fixes bug #67323. (Manifest recommit) (diff)
downloadgentoo-2-089dca2e4ad4160fea2a1a436a5e57ddf26b84d1.tar.gz
gentoo-2-089dca2e4ad4160fea2a1a436a5e57ddf26b84d1.tar.bz2
gentoo-2-089dca2e4ad4160fea2a1a436a5e57ddf26b84d1.zip
fte version bump
-rw-r--r--app-editors/fte/ChangeLog8
-rw-r--r--app-editors/fte/files/digest-fte-200501082
-rw-r--r--app-editors/fte/files/fte-gcc3438
-rw-r--r--app-editors/fte/fte-20050108.ebuild84
4 files changed, 131 insertions, 1 deletions
diff --git a/app-editors/fte/ChangeLog b/app-editors/fte/ChangeLog
index cab0fafc8bca..feba5d8e7830 100644
--- a/app-editors/fte/ChangeLog
+++ b/app-editors/fte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/fte
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.24 2005/01/01 13:24:52 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.25 2005/01/12 16:05:16 hanno Exp $
+
+*fte-20050108 (12 Jan 2005)
+
+ 12 Jan 2005; Hanno Boeck <hanno@gentoo.org> +files/fte-gcc34,
+ +fte-20050108.ebuild:
+ Version bump and gcc 3.4-fix.
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
fte-20020324-r1.ebuild, fte-20020324-r2.ebuild:
diff --git a/app-editors/fte/files/digest-fte-20050108 b/app-editors/fte/files/digest-fte-20050108
new file mode 100644
index 000000000000..9bd190d0e669
--- /dev/null
+++ b/app-editors/fte/files/digest-fte-20050108
@@ -0,0 +1,2 @@
+MD5 910ef0041d5d56ede596fc6eb90c1f11 fte-20050108-src.zip 545246
+MD5 200d22e821e550148c0494b54d7dfd25 fte-20050108-common.zip 186252
diff --git a/app-editors/fte/files/fte-gcc34 b/app-editors/fte/files/fte-gcc34
new file mode 100644
index 000000000000..51940e650657
--- /dev/null
+++ b/app-editors/fte/files/fte-gcc34
@@ -0,0 +1,38 @@
+--- fte/src/con_slang.cpp 2003-02-16 19:23:58.000000000 +0100
++++ fte-gcc34/src/con_slang.cpp 2005-01-12 16:57:38.050369064 +0100
+@@ -246,7 +246,7 @@
+ SLsmg_write_nchars(slang_dchs, sizeof(slang_dchs));
+
+ SLsmg_gotorc(0, 0);
+- SLsmg_read_raw(linebuf, sizeof(slang_dchs));
++ SLsmg_read_raw((SLsmg_Char_Type*)linebuf, sizeof(slang_dchs));
+ for (i = 0; i < sizeof(slang_dchs); i++)
+ raw_dchs[i] = (linebuf[i]) & 0xff;
+
+@@ -368,7 +368,7 @@
+ ConQueryCursorPos(&CurX, &CurY);
+ while (H > 0) {
+ SLsmg_gotorc(Y++, X);
+- SLsmg_write_raw(box, W);
++ SLsmg_write_raw((SLsmg_Char_Type*)box, W);
+ box += W;
+ H--;
+ }
+@@ -386,7 +386,7 @@
+ ConQueryCursorPos(&CurX, &CurY);
+ while (H > 0) {
+ SLsmg_gotorc(Y++, X);
+- SLsmg_read_raw(Cell, W);
++ SLsmg_read_raw((SLsmg_Char_Type*)Cell, W);
+ for (i = 0; i < W; i++)
+ if (Cell[i] & 0x8000) {
+ ch = Cell[i] & 0xff;
+@@ -409,7 +409,7 @@
+ ConQueryCursorPos(&CurX, &CurY);
+ while (H > 0) {
+ SLsmg_gotorc(Y++, X);
+- SLsmg_read_raw(box, W);
++ SLsmg_read_raw((SLsmg_Char_Type*)box, W);
+ box += W;
+ H--;
+ }
diff --git a/app-editors/fte/fte-20050108.ebuild b/app-editors/fte/fte-20050108.ebuild
new file mode 100644
index 000000000000..d1d55971c1c1
--- /dev/null
+++ b/app-editors/fte/fte-20050108.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20050108.ebuild,v 1.1 2005/01/12 16:05:16 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="Lightweight text-mode editor"
+HOMEPAGE="http://fte.sourceforge.net"
+SRC_URI="mirror://sourceforge/fte/${P}-src.zip
+ mirror://sourceforge/fte/${P}-common.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="gpm slang X"
+S=${WORKDIR}/${PN}
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.20 )"
+DEPEND="${RDEPEND}
+ slang? ( sys-libs/slang )
+ app-arch/unzip
+ X? ( virtual/x11 )"
+
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="$TARGETS sfte"
+ use X && TARGETS="$TARGETS xfte"
+ use gpm && TARGETS="$TARGETS vfte"
+}
+
+src_unpack() {
+ unpack ${P}-src.zip
+ unpack ${P}-common.zip
+
+ cd ${S}
+
+ epatch ${FILESDIR}/fte-gcc34
+
+ set_targets
+ sed \
+ -e "s:@targets@:${TARGETS}:" \
+ -e "s:@cflags@:${CFLAGS}:" \
+ -i src/fte-unix.mak
+}
+
+src_compile() {
+ DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
+ DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
+
+ set_targets
+ emake $DEFFLAGS TARGETS="$TARGETS" all || die
+}
+
+src_install() {
+ local files
+ into /usr
+
+ set_targets
+ files="${TARGETS} cfte compkeys"
+
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
+
+ dobin ${FILESDIR}/fte
+
+ dodoc Artistic CHANGES BUGS HISTORY README TODO
+
+ keepdir etc/fte
+
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
+}
+
+pkg_postinst() {
+ einfo "Compiling configuration..."
+ cd /usr/share/fte
+ /usr/bin/cfte main.fte /etc/fte/system.fterc
+}