summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-06 21:14:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-06 21:14:02 +0000
commit0848af09b0a3d4154b5346250451cff565761f93 (patch)
tree2d1b222becfad544d183fefa563ff085df9d5952
parentVersion bump. (diff)
downloadgentoo-2-0848af09b0a3d4154b5346250451cff565761f93.tar.gz
gentoo-2-0848af09b0a3d4154b5346250451cff565761f93.tar.bz2
gentoo-2-0848af09b0a3d4154b5346250451cff565761f93.zip
Fix building with -Wl,--as-needed wrt #248586 by Kacper Kowalik.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
-rw-r--r--x11-misc/xrmap/ChangeLog8
-rw-r--r--x11-misc/xrmap/files/xrmap-2.32-asneeded.patch11
-rw-r--r--x11-misc/xrmap/xrmap-2.32.ebuild7
3 files changed, 21 insertions, 5 deletions
diff --git a/x11-misc/xrmap/ChangeLog b/x11-misc/xrmap/ChangeLog
index a26cc8216559..cfb84b1b74cb 100644
--- a/x11-misc/xrmap/ChangeLog
+++ b/x11-misc/xrmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xrmap
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/ChangeLog,v 1.15 2007/03/09 07:57:25 drac Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/ChangeLog,v 1.16 2010/02/06 21:14:02 ssuominen Exp $
+
+ 06 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> xrmap-2.32.ebuild,
+ +files/xrmap-2.32-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #248586 by Kacper Kowalik.
09 Mar 2007; Samuli Suominen <drac@gentoo.org> xrmap-2.29.ebuild,
xrmap-2.32.ebuild:
diff --git a/x11-misc/xrmap/files/xrmap-2.32-asneeded.patch b/x11-misc/xrmap/files/xrmap-2.32-asneeded.patch
new file mode 100644
index 000000000000..6675be293d16
--- /dev/null
+++ b/x11-misc/xrmap/files/xrmap-2.32-asneeded.patch
@@ -0,0 +1,11 @@
+--- Makefile.noimake
++++ Makefile.noimake
+@@ -19,7 +19,7 @@
+ ## LDOPTIONS=-O6 -g -Wall libxpm/libXpm.a -lX11 -lz -lm -L/usr/X11R6/lib
+
+ all: explorer.o xrmap.o
+- gcc $(LDOPTIONS) -o xrmap explorer.o xrmap.o
++ gcc -o xrmap explorer.o xrmap.o $(LDOPTIONS)
+ cd editkit ; make -f Makefile.kit DESTDIR=$(DESTDIR)
+ cd earthview ; make DESTDIR=$(DESTDIR)
+ @cat EXTRADATA
diff --git a/x11-misc/xrmap/xrmap-2.32.ebuild b/x11-misc/xrmap/xrmap-2.32.ebuild
index ba2e0f57823c..c92720aaace0 100644
--- a/x11-misc/xrmap/xrmap-2.32.ebuild
+++ b/x11-misc/xrmap/xrmap-2.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.32.ebuild,v 1.5 2009/05/05 18:04:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.32.ebuild,v 1.6 2010/02/06 21:14:02 ssuominen Exp $
inherit eutils
@@ -32,7 +32,8 @@ src_unpack() {
rm -rf "${S}"
mv "${WORKDIR}"/${PN}-${FULL_DIST} "${S}"
unpack ${A}
- epatch "${FILESDIR}/${P}-Makefile.kit.patch"
+ epatch "${FILESDIR}"/${P}-Makefile.kit.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
cd "${S}"/editkit && xmkmf || die
}