summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-28 22:12:37 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-28 22:12:37 +0000
commit07b8b0530593ff60eafc1b8d3fb8dceeb1769127 (patch)
tree627267ec399ac89aa40c863111a2dbb52c5671cc
parentppc64 (diff)
downloadgentoo-2-07b8b0530593ff60eafc1b8d3fb8dceeb1769127.tar.gz
gentoo-2-07b8b0530593ff60eafc1b8d3fb8dceeb1769127.tar.bz2
gentoo-2-07b8b0530593ff60eafc1b8d3fb8dceeb1769127.zip
*** empty log message ***
-rw-r--r--dev-lisp/cmucl/ChangeLog12
-rw-r--r--dev-lisp/cmucl/Manifest3
-rw-r--r--dev-lisp/cmucl/cmucl-18e-r2.ebuild119
-rw-r--r--dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch14
-rw-r--r--dev-lisp/cmucl/files/18e/install-clc.lisp-gentoo.patch35
-rw-r--r--dev-lisp/cmucl/files/18e/site-init.lisp.in72
-rw-r--r--dev-lisp/cmucl/files/digest-cmucl-18e-r22
7 files changed, 190 insertions, 67 deletions
diff --git a/dev-lisp/cmucl/ChangeLog b/dev-lisp/cmucl/ChangeLog
index 135c9fcc75b9..fc49d85e2454 100644
--- a/dev-lisp/cmucl/ChangeLog
+++ b/dev-lisp/cmucl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lisp/cmucl
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.3 2003/11/25 17:40:20 mkennedy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.4 2004/01/28 22:12:37 mkennedy Exp $
+
+*cmucl-18e-r2 (28 Jan 2004)
+
+ 28 Jan 2004; <mkennedy@gentoo.org> cmucl-18e-r2.ebuild,
+ files/18e/herald-save.lisp-gentoo.patch,
+ files/18e/install-clc.lisp-gentoo.patch, files/18e/site-init.lisp.in:
+ inherit common-lisp-common; use register-common-lisp-implementation and not
+ /usr/sbin/register-common-lisp-implementation; controller clean up
25 Nov 2003; <mkennedy@gentoo.org> cmucl-18e-r1.ebuild:
marking stable for x86
diff --git a/dev-lisp/cmucl/Manifest b/dev-lisp/cmucl/Manifest
index 7ceba4f7488d..356c9b5fce0a 100644
--- a/dev-lisp/cmucl/Manifest
+++ b/dev-lisp/cmucl/Manifest
@@ -2,8 +2,11 @@ MD5 a20857b1215e7c69f336c62af6eb94b8 ChangeLog 668
MD5 99ca05f54412d3c9b9cdf9b6b65048e5 cmucl-18e.ebuild 2663
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 6221f2081f9b1df454e0ade00e9c096b cmucl-18e-r1.ebuild 3321
+MD5 56a8912335e965cd076685fab2e3b9b2 cmucl-18e-r2.ebuild 3248
+MD5 9a6fbf356e442399bc77f8389f120f6f cmucl-18e-r2.ebuild~ 3321
MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e 205
MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e-r1 205
+MD5 df309c5d109052b9c57d79bb4aac5871 files/digest-cmucl-18e-r2 137
MD5 997a2bfdcd98bc978f6c3b79ba8f2264 files/18e/README.Gentoo 848
MD5 fc89ac560cffc93b097f34b594373113 files/18e/herald-save.lisp-gentoo.patch 756
MD5 7c6e25bb371b16cea4f8cad6f64a0317 files/18e/site-init.lisp.in 2857
diff --git a/dev-lisp/cmucl/cmucl-18e-r2.ebuild b/dev-lisp/cmucl/cmucl-18e-r2.ebuild
new file mode 100644
index 000000000000..d6a374562040
--- /dev/null
+++ b/dev-lisp/cmucl/cmucl-18e-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r2.ebuild,v 1.1 2004/01/28 22:12:37 mkennedy Exp $
+
+inherit common-lisp-common
+
+DEB_PV=8
+
+DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
+HOMEPAGE="http://www.cons.org/cmucl/
+ http://packages.debian.org/unstable/devel/cmucl.html"
+LICENSE="public-domain"
+DEPEND="dev-lisp/common-lisp-controller
+ x11-libs/lesstif
+ doc? ( app-text/tetex )"
+# X? ( x11-libs/lesstif )"
+IUSE="doc X"
+SLOT="0"
+KEYWORDS="x86"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}/herald-save.lisp-gentoo.patch
+ epatch ${FILESDIR}/${PV}/install-clc.lisp-gentoo.patch
+}
+
+src_compile() {
+ PATH=${WORKDIR}/bin:$PATH CMUCLCORE=${WORKDIR}/lib/cmucl/lib/lisp.core make || die
+ if use doc; then
+ make -C src/docs
+ fi
+}
+
+src_install() {
+ insinto /usr/lib/cmucl/include
+ doins src/lisp/*.h target/lisp/*.h target/lisp/*.map target/lisp/*.nm
+ insinto /usr/lib/cmucl
+ cp target/lisp/lisp.core lisp-dist.core
+ doins lisp-dist.core
+
+ dodoc target/lisp/lisp.{nm,map}
+ doman src/general-info/{cmucl,lisp}.1
+
+ dobin target/lisp/lisp
+ dobin own-work/Demos/lisp-start
+
+ insinto /usr/lib/cmucl
+ doins own-work/install-clc.lisp
+ exeinto /usr/lib/common-lisp/bin
+ cp own-work/cmucl-script.sh cmucl.sh
+ doexe cmucl.sh
+
+ insinto /etc/common-lisp/cmucl
+ sed "s,@PF@,${PF},g" <${FILESDIR}/${PV}/site-init.lisp.in >site-init.lisp
+ doins site-init.lisp
+ dosym /etc/common-lisp/cmucl/site-init.lisp /usr/lib/cmucl/site-init.lisp
+
+ dodir /etc/env.d
+ cat >${D}/etc/env.d/50cmucl <<EOF
+# CMUCLLIB=/usr/lib/cmucl
+EOF
+ [ -f /etc/lisp-config.lisp ] || touch ${D}/etc/lisp-config.lisp
+
+ insinto /usr/share/doc/${P}/html/Basic-tutorial
+ doins own-work/tutorials/Basic-tutorial/*
+ insinto /usr/share/doc/${P}/html/Clos
+ doins own-work/tutorials/Clos/*
+ docinto notes
+ dodoc own-work/tutorials/notes/*
+
+ insinto /usr/lib/cmucl
+ doins own-work/hemlock11.*
+
+ if use doc; then
+ dodoc src/docs/*/*.{ps,pdf}
+ fi
+
+ if use X; then
+ exeinto /usr/lib/cmucl
+ doexe target/motif/server/motifd
+ insinto /usr/lib/cmucl/subsystems/
+ doins target/interface/clm-library.x86f
+ fi
+
+ keepdir /usr/lib/common-lisp/cmucl
+
+ # BIG FAT HACK
+ #
+ # Since the Portage emerge step kills file timestamp information,
+ # we need to compensate by ensuring all .x86f files are more
+ # recent than their .lisp source.
+
+ dodir /usr/share/${PN}
+ tar cpvzf ${D}/usr/share/${PN}/portage-timestamp-compensate -C ${D}/usr/lib/${PN} .
+}
+
+pkg_postinst() {
+ chown cl-builder:cl-builder /usr/lib/common-lisp/cmucl
+ tar xvpzf /usr/share/${PN}/portage-timestamp-compensate -C /usr/lib/${PN}
+ rm -rf /usr/lib/common-lisp/${PN}/*
+ /usr/bin/clc-autobuild-impl ${PN} yes
+ register-common-lisp-implementation ${PN}
+
+}
+
+pkg_prerm() {
+ # Since we keep our own time stamps we must manually remove them
+ # here.
+ if [ ! -x /usr/bin/lisp ]; then
+ rm -rf /usr/lib/${PN}
+ fi
+ rm -rf /usr/lib/common-lisp/${PN}/*
+}
diff --git a/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch b/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch
index de70a1259102..62d6e66d0750 100644
--- a/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch
+++ b/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch
@@ -1,6 +1,7 @@
---- cmucl-18e.orig.orig/src/code/save.lisp 2003-09-23 15:57:49.993364656 -0500
-+++ cmucl-18e.orig/src/code/save.lisp 2003-09-23 15:56:31.261333744 -0500
-@@ -289,12 +289,9 @@
+diff -ur cmucl-18e.original/src/code/save.lisp cmucl-18e/src/code/save.lisp
+--- cmucl-18e.original/src/code/save.lisp 2003-06-08 02:23:44.000000000 -0500
++++ cmucl-18e/src/code/save.lisp 2004-01-14 14:03:28.487836232 -0600
+@@ -289,11 +289,9 @@
))
(setf (getf *herald-items* :bugs)
@@ -9,10 +10,9 @@
- "or to "
- "pvaneynd@debian.org" terpri
- "type (help) for help, (quit) to exit, and (demo) to see the demos" terpri
-- terpri
+ '("For support see http://www.cons.org/cmucl/support.html" terpri
-+ "Send bug reports to the Gentoo Bugzilla http://bugs.gentoo.org" terpri
-+ "Type (help) for help, (quit) to exit, and (demo) to see the demos" terpri
++ "Send bug reports to http://bugs.gentoo.org." terpri
++ "Type (help) for help or (quit) to exit." terpri
+ terpri
"Loaded subsystems:"))
- ;;; PRINT-HERALD -- Public
diff --git a/dev-lisp/cmucl/files/18e/install-clc.lisp-gentoo.patch b/dev-lisp/cmucl/files/18e/install-clc.lisp-gentoo.patch
new file mode 100644
index 000000000000..b155c7f16156
--- /dev/null
+++ b/dev-lisp/cmucl/files/18e/install-clc.lisp-gentoo.patch
@@ -0,0 +1,35 @@
+diff -ur cmucl-18e.original/own-work/install-clc.lisp cmucl-18e/own-work/install-clc.lisp
+--- cmucl-18e.original/own-work/install-clc.lisp 2003-05-02 02:49:32.000000000 -0500
++++ cmucl-18e/own-work/install-clc.lisp 2004-01-15 02:25:05.514260000 -0600
+@@ -10,15 +10,17 @@
+ (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp"))
+ (unix:unix-exit 1))
+
+-(unless (ignore-errors
++;; (unless (ignore-errors
+ (common-lisp-controller:init-common-lisp-controller
+ "/usr/lib/common-lisp/cmucl/"
+ :version 3)
+- t)
+- (format t "~%Error during init of common-lisp-controller~%")
+- (unix:unix-exit 1))
++;; t)
++;; (format t "~%Error during init of common-lisp-controller~%")
++;; (unix:unix-exit 1))
+
+-(defun common-lisp-controller:send-clc-command (command package)
++(in-package :common-lisp-controller)
++
++(defun send-clc-command (command package)
+ (let ((process
+ (ext:run-program "/usr/bin/clc-send-command"
+ (list
+@@ -40,6 +42,8 @@
+ package
+ "cmucl"))))
+
++(in-package "COMMON-LISP-USER")
++
+ (unless (ignore-errors
+ ;; it loaded, configure it for common-lisp-controller use:
+ (format t "~%Saving to new-lisp.core...")
diff --git a/dev-lisp/cmucl/files/18e/site-init.lisp.in b/dev-lisp/cmucl/files/18e/site-init.lisp.in
index 3de2acb23253..ad145414ca43 100644
--- a/dev-lisp/cmucl/files/18e/site-init.lisp.in
+++ b/dev-lisp/cmucl/files/18e/site-init.lisp.in
@@ -8,6 +8,7 @@
;;; Heavy modifications by Peter Van Eynde
;;; More modifications for Gentoo by Matthew Kennedy
+;;; <mkennedy@gentoo.org>
(in-package "SYSTEM")
@@ -33,70 +34,25 @@
;;; newbie functions, delete if you don't like them
-#-hemlock
-(defun ed (&rest rest)
- (multiple-value-bind (return errorp)
- (ignore-errors (require :cmucl-hemlock))
- (if errorp
- (error "Sorry, cannot find hemlock, please install and use ilisp. Reason: ~S" errorp)
- (apply #'ed rest))))
-
(defun help ()
(format t "~
-Welcome to CMUCL for Linux.
-
-If you aren't running this with ilisp in emacs,
-or aren't intending to use hemlock then you
-deserve to lose. :-)
-
-Read the documentation in /usr/share/doc/@PF@.
+Welcome to the Gentoo GNU/Linux port of CMUCL.
-(quit) is to quit.
-(ed) starts hemlock (if installed)
-(demo) shows a list of demos
-(describe 'progn) gives information about progn for
- example.
-(inspect '*a*) interactively inspects *a* for example.
-"))
-
-(defun demo ()
- (format t "Some demos are in the source package, some in the
-normal package.
+If you aren't running this with ILISP (see: app-emacs/ilisp or
+app-xemacs/ilisp) in Emacs, or don't intend to use Hemlock
+(see: dev-lisp/cmucl-source) then you deserve to lose. :-)
-General demos:
-CLX demos:
- if you have installed cmucl-source you can do:
- (require :cmucl-clx)
- (load \"cl-library:cmucl-clx;demo;hello\")
- (xlib::hello-world \"\")
- (load \"cl-library:;cmucl-clx;demo;menu\")
- (xlib::just-say-lisp \"\")
- (xlib::pop-up \"\"
- '(\"Linux\" \"FreeBSD\" \"OpenBSD\"))
- exit by pressing control+C followed by a keypress.
+The CMUCL REPL does not have GNU Readline-like support, however
+you may wish to install rlwap (see: app-misc/rlwrap) to achieve
+the same effect.
-Clue demos:
- if you have installed the clue package you can do:
- (require :clue)
- (load \"cl-library:;clue;examples;menu\")
- (clue-examples::beatlemenuia \"\")
- (clue-examples::pick-one \"\"
- \"One\"
- \"Two\"
- \"Three\")
- (clue-examples::just-say-lisp \"\")
-
- or you can use the Clio demos:
- (require :clio)
- (require :clio-examples)
- (clio-examples::sketch :host \"\")
+If you think you found a bug, please use http://bugs.gentoo.org
-Pictures demos:
- (require :pictures)
- (load \"cl-library:;pictures;examples;road-demo\")
- (pictures::road-demo)
- press control-a to animate
+Read the documentation in /usr/share/doc/@PF@.
+(quit) exit Lisp
+(describe 'foo) gives information about foo
+(inspect '*foo*) interactively inspects *foo*
+(apropos \"foo\") briefly describe all symbols which match \"foo\"
"))
-
diff --git a/dev-lisp/cmucl/files/digest-cmucl-18e-r2 b/dev-lisp/cmucl/files/digest-cmucl-18e-r2
new file mode 100644
index 000000000000..755469c77d76
--- /dev/null
+++ b/dev-lisp/cmucl/files/digest-cmucl-18e-r2
@@ -0,0 +1,2 @@
+MD5 79384e120d128e8ea48dd414bfbff4cc cmucl_18e-8.tar.gz 6305420
+MD5 695f4a6abc5af6276f776a9739c2c7e7 cmucl-18e-x86-linux.tar.bz2 6404635