summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-08-31 14:54:34 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-08-31 14:54:34 +0000
commit07384f7389fe89b2d393039afd09ac9623e2a16a (patch)
tree5af2fd2c9735e7f36f4bb0f11bcc836c14ff1948
parentFix bailout on bad digest. Bug #322407 (diff)
downloadgentoo-2-07384f7389fe89b2d393039afd09ac9623e2a16a.tar.gz
gentoo-2-07384f7389fe89b2d393039afd09ac9623e2a16a.tar.bz2
gentoo-2-07384f7389fe89b2d393039afd09ac9623e2a16a.zip
Honour Gentoo LDFLAGS. Closes bug #333997.
(Portage version: 2.1.8.3/cvs/Linux i686)
-rw-r--r--x11-plugins/yawmppp/ChangeLog7
-rw-r--r--x11-plugins/yawmppp/yawmppp-2.0.2.ebuild14
2 files changed, 17 insertions, 4 deletions
diff --git a/x11-plugins/yawmppp/ChangeLog b/x11-plugins/yawmppp/ChangeLog
index bb19ff1bdf91..a7691cabca82 100644
--- a/x11-plugins/yawmppp/ChangeLog
+++ b/x11-plugins/yawmppp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/yawmppp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/yawmppp/ChangeLog,v 1.9 2007/02/06 02:06:50 flameeyes Exp $
+# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/yawmppp/ChangeLog,v 1.10 2010/08/31 14:54:34 s4t4n Exp $
+
+ 31 Aug 2010; Michele Noberasco <s4t4n@gentoo.org> ChangeLog:
+ Honour Gentoo LDFLAGS. Closes bug #333997.
06 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-plugins/yawmppp/yawmppp-2.0.2.ebuild b/x11-plugins/yawmppp/yawmppp-2.0.2.ebuild
index bca06b05397b..a710855d9b1a 100644
--- a/x11-plugins/yawmppp/yawmppp-2.0.2.ebuild
+++ b/x11-plugins/yawmppp/yawmppp-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/yawmppp/yawmppp-2.0.2.ebuild,v 1.7 2010/07/22 14:35:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/yawmppp/yawmppp-2.0.2.ebuild,v 1.8 2010/08/31 14:54:34 s4t4n Exp $
inherit eutils
@@ -20,7 +20,17 @@ src_unpack() {
cd "${S}"/src/dockapp
#Fix bug #95959
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
+ epatch "${FILESDIR}"/"${P}-Makefile.in.patch"
+
+ #Fix bug #333997
+ sed -i 's/-o yawmppp/$(LDFLAGS) -o yawmppp/' Makefile.in
+ sed -i 's/-o yagetmodemspeed/$(LDFLAGS) -o yagetmodemspeed/' Makefile.in
+ cd ../thinppp
+ sed -i 's/-o yawmppp.thin/$(LDFLAGS) -o yawmppp.thin/' Makefile.in
+ cd ../gtklog
+ sed -i 's/-o yawmppp.log/$(LDFLAGS) -o yawmppp.log/' Makefile.in
+ cd ../gtksetup
+ sed -i 's/-o yawmppp.pref/$(LDFLAGS) -o yawmppp.pref/' Makefile.in
}
src_compile() {