summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-01-03 15:36:18 +0000
committerDaniel Goller <morfic@gentoo.org>2005-01-03 15:36:18 +0000
commit05bdb69791893577d0d88fd4cb9d95e0161bbe88 (patch)
treed8a31eab0821ef8115ca6a6e28cdae9b7cc59d56
parentadded source useflag to dev-java/xml-xmlbeans (diff)
downloadgentoo-2-05bdb69791893577d0d88fd4cb9d95e0161bbe88.tar.gz
gentoo-2-05bdb69791893577d0d88fd4cb9d95e0161bbe88.tar.bz2
gentoo-2-05bdb69791893577d0d88fd4cb9d95e0161bbe88.zip
initial commit of mupen64-glide64 plugin
-rw-r--r--games-emulation/mupen64-glide64/ChangeLog11
-rw-r--r--games-emulation/mupen64-glide64/Manifest6
-rw-r--r--games-emulation/mupen64-glide64/files/digest-mupen64-glide64-0.71
-rw-r--r--games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-compile.patch107
-rw-r--r--games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-gtk2.patch27
-rw-r--r--games-emulation/mupen64-glide64/metadata.xml5
-rw-r--r--games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild36
7 files changed, 193 insertions, 0 deletions
diff --git a/games-emulation/mupen64-glide64/ChangeLog b/games-emulation/mupen64-glide64/ChangeLog
new file mode 100644
index 000000000000..49a5478db97c
--- /dev/null
+++ b/games-emulation/mupen64-glide64/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-emulation/mupen64-glide64
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/ChangeLog,v 1.1 2005/01/03 15:36:18 morfic Exp $
+
+*mupen64-glide64-0.7 (02 Jan 2005)
+
+ 02 Jan 2005; Daniel Goller <morfic@gentoo.org>
+ +files/mupen64-glide64-0.7-compile.patch,
+ +files/mupen64-glide64-0.7-gtk2.patch, +mupen64-glide64-0.7.ebuild:
+ Initial commit of mupen64 plugin, needs work, we'll go from here
+
diff --git a/games-emulation/mupen64-glide64/Manifest b/games-emulation/mupen64-glide64/Manifest
new file mode 100644
index 000000000000..726e1739a511
--- /dev/null
+++ b/games-emulation/mupen64-glide64/Manifest
@@ -0,0 +1,6 @@
+MD5 2f3561e7ce2bc2c173859bc056bcec74 mupen64-glide64-0.7.ebuild 1006
+MD5 71b77780d34b610bb8a117324cb03250 ChangeLog 399
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 2f68b9e4d03102e87c1b845f4112b051 files/mupen64-glide64-0.7-compile.patch 4677
+MD5 42c247074d570fc3665a11d129a2e0d1 files/mupen64-glide64-0.7-gtk2.patch 1231
+MD5 ea5cfac2f37f3bea3a5a9ac9b6c06854 files/digest-mupen64-glide64-0.7 67
diff --git a/games-emulation/mupen64-glide64/files/digest-mupen64-glide64-0.7 b/games-emulation/mupen64-glide64/files/digest-mupen64-glide64-0.7
new file mode 100644
index 000000000000..fc9d80b5f368
--- /dev/null
+++ b/games-emulation/mupen64-glide64/files/digest-mupen64-glide64-0.7
@@ -0,0 +1 @@
+MD5 3078c5c3f960728f99af825ab0af69e0 glide64_0_7_ME.tar.bz2 231051
diff --git a/games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-compile.patch b/games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-compile.patch
new file mode 100644
index 000000000000..ae6702208e68
--- /dev/null
+++ b/games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-compile.patch
@@ -0,0 +1,107 @@
+diff -ru glide64_0_7_ME/Makefile glide64_0_7_ME.working/Makefile
+--- glide64_0_7_ME/Makefile 2004-07-03 14:07:06.000000000 -0700
++++ glide64_0_7_ME.working/Makefile 2005-01-01 20:50:24.886864494 -0800
+@@ -1,7 +1,7 @@
+ CC = gcc
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -g -mmmx -msse
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
++CFLAGS = -DUSE_GTK -DGL_GLEXT_PROTOTYPES `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/
+ CXX = g++
+ CPPFLAGS = $(CFLAGS)
+ LD = g++
+diff -ru glide64_0_7_ME/wrapper/combiner.cpp glide64_0_7_ME.working/wrapper/combiner.cpp
+--- glide64_0_7_ME/wrapper/combiner.cpp 2004-06-19 16:11:54.000000000 -0700
++++ glide64_0_7_ME.working/wrapper/combiner.cpp 2005-01-01 20:47:08.752963059 -0800
+@@ -4,7 +4,7 @@
+ #include "../winlnxdefs.h"
+ #endif // _WIN32
+ #include <GL/gl.h>
+-#include "glext.h"
++#include <GL/glext.h>
+ #include "glide.h"
+ #include "main.h"
+
+diff -ru glide64_0_7_ME/wrapper/geometry.cpp glide64_0_7_ME.working/wrapper/geometry.cpp
+--- glide64_0_7_ME/wrapper/geometry.cpp 2004-06-20 03:00:18.000000000 -0700
++++ glide64_0_7_ME.working/wrapper/geometry.cpp 2005-01-01 20:42:31.730992830 -0800
+@@ -4,8 +4,8 @@
+ #include "../winlnxdefs.h"
+ #endif // _WIN32
+ #include <GL/gl.h>
++#include <GL/glext.h>
+ #include "glide.h"
+-#include "glext.h"
+ #include "main.h"
+
+ static int xy_off;
+diff -ru glide64_0_7_ME/wrapper/main.cpp glide64_0_7_ME.working/wrapper/main.cpp
+--- glide64_0_7_ME/wrapper/main.cpp 2004-07-02 12:57:48.000000000 -0700
++++ glide64_0_7_ME.working/wrapper/main.cpp 2005-01-01 20:51:32.459133270 -0800
+@@ -20,10 +20,6 @@
+ #endif // _WIN32
+
+
+-PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+-PFNGLBLENDFUNCSEPARATEEXTPROC glBlendFuncSeparateEXT;
+-PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
+-PFNGLFOGCOORDFPROC glFogCoordfEXT;
+ #ifdef _WIN32
+ PFNWGLGETEXTENSIONSSTRINGARBPROC wglGetExtensionsStringARB;
+
+@@ -505,8 +501,8 @@
+ glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)wglGetProcAddress("glActiveTextureARB");
+ glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)wglGetProcAddress("glMultiTexCoord2fARB");
+ #else // _WIN32
+- glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)SDL_GL_GetProcAddress("glActiveTextureARB");
+- glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)SDL_GL_GetProcAddress("glMultiTexCoord2fARB");
++// glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)SDL_GL_GetProcAddress("glActiveTextureARB");
++// glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)SDL_GL_GetProcAddress("glMultiTexCoord2fARB");
+ #endif // _WIN32
+ glGetIntegerv(GL_MAX_TEXTURE_UNITS_ARB, &nbTextureUnits);
+ if (nbTextureUnits == 1) display_warning((unsigned char*)"You need a video card that has at least 2 texture units");
+@@ -523,7 +519,7 @@
+ #ifdef _WIN32
+ glBlendFuncSeparateEXT = (PFNGLBLENDFUNCSEPARATEEXTPROC)wglGetProcAddress("glBlendFuncSeparateEXT");
+ #else // _WIN32
+- glBlendFuncSeparateEXT = (PFNGLBLENDFUNCSEPARATEEXTPROC)SDL_GL_GetProcAddress("glBlendFuncSeparateEXT");
++ //glBlendFuncSeparateEXT = (PFNGLBLENDFUNCSEPARATEEXTPROC)SDL_GL_GetProcAddress("glBlendFuncSeparateEXT");
+ #endif // _WIN32
+
+ if (isExtensionSupported("GL_EXT_fog_coord") == FALSE)
+@@ -561,7 +557,7 @@
+ viewport_offset = 0;
+ }
+ #else // _WIN32
+- glFogCoordfEXT = (PFNGLFOGCOORDFPROC)SDL_GL_GetProcAddress("glFogCoordfEXT");
++ //glFogCoordfEXT = (PFNGLFOGCOORDFPROC)SDL_GL_GetProcAddress("glFogCoordfEXT");
+ #endif // _WIN32
+ widtho = width/2;
+ if (!fullscreen)
+diff -ru glide64_0_7_ME/wrapper/main.h glide64_0_7_ME.working/wrapper/main.h
+--- glide64_0_7_ME/wrapper/main.h 2004-06-20 12:08:48.000000000 -0700
++++ glide64_0_7_ME.working/wrapper/main.h 2005-01-01 20:42:07.669225539 -0800
+@@ -5,7 +5,7 @@
+ #include <windows.h>
+ #endif // _WIN32
+ #include <GL/gl.h>
+-#include "glext.h"
++#include <GL/glext.h>
+ #include "glide.h"
+
+ void display_warning(unsigned char *text, ...);
+@@ -15,12 +15,12 @@
+ void updateCombiner(int i);
+ void updateCombinera(int i);
+
+-//#ifdef _WIN32
++#ifdef _WIN32
+ extern PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+ extern PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
+ extern PFNGLBLENDFUNCSEPARATEEXTPROC glBlendFuncSeparateEXT;
+ extern PFNGLFOGCOORDFPROC glFogCoordfEXT;
+-//#endif // _WIN32
++#endif // _WIN32
+ extern int w_buffer_mode;
+ extern int nbTextureUnits;
+ extern int width, height, widtho, heighto;
diff --git a/games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-gtk2.patch b/games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-gtk2.patch
new file mode 100644
index 000000000000..1939ac45d97c
--- /dev/null
+++ b/games-emulation/mupen64-glide64/files/mupen64-glide64-0.7-gtk2.patch
@@ -0,0 +1,27 @@
+--- glide64_0_7_ME/Config.cpp.old 2005-01-02 13:21:06.399041458 -0800
++++ glide64_0_7_ME/Config.cpp 2005-01-02 13:21:09.975475355 -0800
+@@ -594,7 +594,7 @@
+ static void okButtonCallback(GtkWidget *widget, void *data)
+ {
+ ConfigDialog *configDialog = (ConfigDialog*)data;
+- char *s;
++ const gchar *s;
+ int i,n=0;
+
+ s = gtk_entry_get_text(GTK_ENTRY(GTK_COMBO(configDialog->windowResCombo)->entry));
+--- glide64_0_7_ME/Makefile.old 2005-01-02 13:17:39.755824013 -0800
++++ glide64_0_7_ME/Makefile 2005-01-02 13:19:39.914670229 -0800
+@@ -1,11 +1,11 @@
+ CC = gcc
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -g -mmmx -msse
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-CFLAGS = -DUSE_GTK -DGL_GLEXT_PROTOTYPES `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/
++CFLAGS = -DUSE_GTK -DGL_GLEXT_PROTOTYPES `sdl-config --cflags` `pkg-config --cflags gtk+-2.0` -D_GTK2 -Iwrapper/
+ CXX = g++
+ CPPFLAGS = $(CFLAGS)
+ LD = g++
+-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
++LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL `pkg-config --libs gtk+-2.0`
+
+ OBJECTS = Main.o \
+ rdp.o \
diff --git a/games-emulation/mupen64-glide64/metadata.xml b/games-emulation/mupen64-glide64/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/mupen64-glide64/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
new file mode 100644
index 000000000000..568c5f664423
--- /dev/null
+++ b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.1 2005/01/03 15:36:18 morfic Exp $
+
+inherit games
+
+DESCRIPTION="An opengl graphics plugin for the mupen64 N64 emulator"
+HOMEPAGE="http://mupen64.emulation64.com/"
+SRC_URI="mirror://gentoo/glide64_0_7_ME.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/glide64_0_7_ME"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-compile.patch || die "patch failed"
+ use gtk2 && epatch ${FILESDIR}/${P}-gtk2.patch || die "patch failed"
+
+ make clean || die "couldn't clean"
+ sed -i -e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" Makefile || \
+ die "couldn't apply cflags"
+ make || die "couldn't compile"
+}
+
+src_install() {
+ exeinto "${GAMES_LIBDIR}/mupen64/plugins"
+ doexe Glide64.so || die "doexe failed"
+ insinto "${GAMES_LIBDIR}/mupen64/plugins"
+ doins Glide64.ini
+ prepgamesdirs
+}