summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-02 12:03:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-02 12:03:42 +0000
commit05ae137df7e7779d4673ae57fda2c4cc90192e67 (patch)
treee0979b86ae4ac372e3f5abac53849f1ca54704f4
parentVersion bump (diff)
downloadgentoo-2-05ae137df7e7779d4673ae57fda2c4cc90192e67.tar.gz
gentoo-2-05ae137df7e7779d4673ae57fda2c4cc90192e67.tar.bz2
gentoo-2-05ae137df7e7779d4673ae57fda2c4cc90192e67.zip
Call udevadm with the hwdb target only if it's supported.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--sys-apps/hwids/ChangeLog6
-rw-r--r--sys-apps/hwids/hwids-20121202.2.ebuild4
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 7c7fe0f22c14..3e522a33250c 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.47 2012/12/02 09:29:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.48 2012/12/02 12:03:42 ssuominen Exp $
+
+ 02 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> hwids-20121202.2.ebuild,
+ hwids-99999999.ebuild:
+ Call udevadm with the hwdb target only if it's supported.
02 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> hwids-20121202.2.ebuild,
hwids-99999999.ebuild:
diff --git a/sys-apps/hwids/hwids-20121202.2.ebuild b/sys-apps/hwids/hwids-20121202.2.ebuild
index 1f0fa4882019..4319939e19b4 100644
--- a/sys-apps/hwids/hwids-20121202.2.ebuild
+++ b/sys-apps/hwids/hwids-20121202.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121202.2.ebuild,v 1.4 2012/12/02 09:29:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121202.2.ebuild,v 1.5 2012/12/02 12:03:42 ssuominen Exp $
EAPI=5
inherit udev
@@ -52,7 +52,7 @@ src_install() {
}
pkg_postinst() {
- if use udev && has_version '>=virtual/udev-180'; then
+ if use udev && udevadm 2>&1 | grep -qs hwdb; then
udevadm hwdb --update
fi
}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 1fd8d734fad8..83bf373ab2c7 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.7 2012/12/02 09:29:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.8 2012/12/02 12:03:42 ssuominen Exp $
EAPI=5
inherit udev
@@ -48,7 +48,7 @@ src_install() {
}
pkg_postinst() {
- if use udev && has_version '>=virtual/udev-180'; then
+ if use udev && udevadm 2>&1 | grep -qs hwdb; then
udevadm hwdb --update
fi
}