summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-08-08 05:29:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-08-08 05:29:52 +0000
commit0544bc7c2773120c6b39685f122c5bf51e94c33c (patch)
treef3caf2c3af387f524ab8e59b5465595e80e1833f
parentVersion bump. (diff)
downloadgentoo-2-0544bc7c2773120c6b39685f122c5bf51e94c33c.tar.gz
gentoo-2-0544bc7c2773120c6b39685f122c5bf51e94c33c.tar.bz2
gentoo-2-0544bc7c2773120c6b39685f122c5bf51e94c33c.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/cairocffi/ChangeLog7
-rw-r--r--dev-python/cairocffi/cairocffi-0.7.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/cairocffi/ChangeLog b/dev-python/cairocffi/ChangeLog
index e0a626202610..5033fac4efb5 100644
--- a/dev-python/cairocffi/ChangeLog
+++ b/dev-python/cairocffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cairocffi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/ChangeLog,v 1.13 2015/06/25 08:30:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/ChangeLog,v 1.14 2015/08/08 05:29:52 patrick Exp $
+
+*cairocffi-0.7.2 (08 Aug 2015)
+
+ 08 Aug 2015; Patrick Lauer <patrick@gentoo.org> +cairocffi-0.7.2.ebuild:
+ Bump
*cairocffi-0.7.1 (25 Jun 2015)
diff --git a/dev-python/cairocffi/cairocffi-0.7.2.ebuild b/dev-python/cairocffi/cairocffi-0.7.2.ebuild
new file mode 100644
index 000000000000..180a505803ad
--- /dev/null
+++ b/dev-python/cairocffi/cairocffi-0.7.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/cairocffi-0.7.2.ebuild,v 1.1 2015/08/08 05:29:52 patrick Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/SimonSapin/cairocffi"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/cffi-1.1.0:=[$(python_gen_usedep 'python*')]
+ >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
+ x11-libs/cairo:0=
+ x11-libs/gdk-pixbuf[jpeg]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ # Intersphinx cause the usual d'loading of objects.inv from TWO online sites
+ "${FILESDIR}"/mapping.patch
+ "${FILESDIR}"/${PN}-0.7.1-test.patch
+ )
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test -v --pyargs cairocffi || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}