summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-05-17 22:55:45 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-05-17 22:55:45 +0000
commit05164fb62d33bfa5c8c3a92881b3272d2a897427 (patch)
tree861c0788ff2c8107b5f2f7a91086d24cb046a1cb
parentStable for ia64, wrt bug #463044 (diff)
downloadgentoo-2-05164fb62d33bfa5c8c3a92881b3272d2a897427.tar.gz
gentoo-2-05164fb62d33bfa5c8c3a92881b3272d2a897427.tar.bz2
gentoo-2-05164fb62d33bfa5c8c3a92881b3272d2a897427.zip
version bump for bug #469762. Also sync live ebuild.
(Portage version: 2.2.0_alpha175/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
-rw-r--r--dev-lang/go/ChangeLog8
-rw-r--r--dev-lang/go/files/go-1.1-no-Werror.patch12
-rw-r--r--dev-lang/go/go-1.1.ebuild139
-rw-r--r--dev-lang/go/go-9999.ebuild10
4 files changed, 163 insertions, 6 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 1b1facee3fbd..d5ab88214f4f 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.11 2013/04/16 16:10:18 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.12 2013/05/17 22:55:44 williamh Exp $
+
+*go-1.1 (17 May 2013)
+
+ 17 May 2013; William Hubbs <williamh@gentoo.org> +go-1.1.ebuild,
+ go-9999.ebuild, +files/go-1.1-no-Werror.patch:
+ version bump for bug #469762. Also sync live ebuild.
16 Apr 2013; William Hubbs <williamh@gentoo.org> go-9999.ebuild:
sync live ebuild
diff --git a/dev-lang/go/files/go-1.1-no-Werror.patch b/dev-lang/go/files/go-1.1-no-Werror.patch
new file mode 100644
index 000000000000..f5c45767ae5c
--- /dev/null
+++ b/dev-lang/go/files/go-1.1-no-Werror.patch
@@ -0,0 +1,12 @@
+Disable -Werror.
+
+--- a/src/cmd/dist/build.c
++++ b/src/cmd/dist/build.c
+@@ -384,7 +384,6 @@ static char *proto_gccargs[] = {
+ "-Wno-unknown-pragmas",
+ "-Wno-switch",
+ "-Wno-comment",
+- "-Werror",
+ "-fno-common",
+ "-ggdb",
+ "-O2",
diff --git a/dev-lang/go/go-1.1.ebuild b/dev-lang/go/go-1.1.ebuild
new file mode 100644
index 000000000000..da9938914ceb
--- /dev/null
+++ b/dev-lang/go/go-1.1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.1.ebuild,v 1.1 2013/05/17 22:55:44 williamh Exp $
+
+EAPI=5
+
+export CTARGET=${CTARGET:-${CHOST}}
+
+inherit bash-completion-r1 elisp-common eutils
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://go.googlecode.com/hg"
+ inherit mercurial
+else
+ SRC_URI="http://go.googlecode.com/files/go${PV}.src.tar.gz"
+ # Upstream only supports go on amd64, arm and x86 architectures.
+ KEYWORDS="-* ~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="A concurrent garbage collected and typesafe programming language"
+HOMEPAGE="http://www.golang.org"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="bash-completion emacs vim-syntax zsh-completion"
+
+DEPEND="sys-apps/ed"
+RDEPEND="bash-completion? ( app-shells/bash-completion )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ zsh-completion? ( app-shells/zsh-completion )"
+
+# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
+QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/linux*/*"
+
+# The go language uses *.a files which are _NOT_ libraries and should not be
+# stripped.
+STRIP_MASK="/usr/lib/go/pkg/linux*/*.a"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}"/go
+fi
+
+src_prepare()
+{
+ if [[ ${PV} != 9999 ]]; then
+ epatch "${FILESDIR}"/${P}-no-Werror.patch
+ fi
+ epatch_user
+}
+
+src_compile()
+{
+ export GOROOT_FINAL=/usr/lib/go
+ export GOROOT="$(pwd)"
+ export GOBIN="${GOROOT}/bin"
+ if [[ $CTARGET = armv5* ]]
+ then
+ export GOARM=5
+ fi
+
+ cd src
+ ./make.bash || die "build failed"
+ cd ..
+
+ if use emacs; then
+ elisp-compile misc/emacs/*.el
+ fi
+}
+
+src_test()
+{
+ cd src
+ PATH="${GOBIN}:${PATH}" \
+ ./run.bash --no-rebuild --banner || die "tests failed"
+}
+
+src_install()
+{
+ dobin bin/*
+ dodoc AUTHORS CONTRIBUTORS PATENTS README
+
+ dodir /usr/lib/go
+ insinto /usr/lib/go
+
+ # There is a known issue which requires the source tree to be installed [1].
+ # Once this is fixed, we can consider using the doc use flag to control
+ # installing the doc and src directories.
+ # [1] http://code.google.com/p/go/issues/detail?id=2775
+ doins -r doc include lib pkg src
+
+ if use bash-completion; then
+ dobashcomp misc/bash/go
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} misc/emacs/*.el misc/emacs/*.elc
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r misc/vim/ftdetect
+ doins -r misc/vim/ftplugin
+ doins -r misc/vim/syntax
+ doins -r misc/vim/plugin
+ doins -r misc/vim/indent
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/go
+ fi
+
+ fperms -R +x /usr/lib/go/pkg/tool
+}
+
+pkg_postinst()
+{
+ if use emacs; then
+ elisp-site-regen
+ fi
+
+ # If the go tool sees a package file timestamped older than a dependancy it
+ # will rebuild that file. So, in order to stop go from rebuilding lots of
+ # packages for every build we need to fix the timestamps. The compiler and
+ # linker are also checked - so we need to fix them too.
+ ebegin "fixing timestamps to avoid unnecessary rebuilds"
+ tref="usr/lib/go/pkg/*/runtime.a"
+ find "${ROOT}"usr/lib/go -type f \
+ -exec touch -r "${ROOT}"${tref} {} \;
+ eend $?
+}
+
+pkg_postrm()
+{
+ if use emacs; then
+ elisp-site-regen
+ fi
+}
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 44b0f95fb5ea..48835820c6ec 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.10 2013/04/16 16:10:18 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.11 2013/05/17 22:55:44 williamh Exp $
-EAPI=4
+EAPI=5
export CTARGET=${CTARGET:-${CHOST}}
@@ -33,8 +33,8 @@ RDEPEND="bash-completion? ( app-shells/bash-completion )
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/linux*/*"
- # The go language stores binary data for packages in *.a files.
- # These are _NOT_ libraries, and should not be stripped.
+# The go language uses *.a files which are _NOT_ libraries and should not be
+# stripped.
STRIP_MASK="/usr/lib/go/pkg/linux*/*.a"
if [[ ${PV} != 9999 ]]; then
@@ -44,7 +44,7 @@ fi
src_prepare()
{
if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}"/${P}-hardened.patch
+ epatch "${FILESDIR}"/${P}-no-Werror.patch
fi
epatch_user
}