summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-09-21 13:26:42 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-09-21 13:26:42 +0000
commit03c14867e26fc376d7535a056547de9e302cd4e5 (patch)
tree54b1614d1ea6e5ca389f686db864097a503269aa
parentFix build after games eclass changes. Bug #428654 (diff)
downloadgentoo-2-03c14867e26fc376d7535a056547de9e302cd4e5.tar.gz
gentoo-2-03c14867e26fc376d7535a056547de9e302cd4e5.tar.bz2
gentoo-2-03c14867e26fc376d7535a056547de9e302cd4e5.zip
New USE flag doc; build with USE=-fox fixed
(Portage version: 2.2.0_alpha130/cvs/Linux i686)
-rw-r--r--sci-mathematics/gsl-shell/ChangeLog6
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch25
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild16
3 files changed, 44 insertions, 3 deletions
diff --git a/sci-mathematics/gsl-shell/ChangeLog b/sci-mathematics/gsl-shell/ChangeLog
index 3fb72430bf7e..aa5514833b6b 100644
--- a/sci-mathematics/gsl-shell/ChangeLog
+++ b/sci-mathematics/gsl-shell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/gsl-shell
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.1 2012/09/20 16:09:24 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.2 2012/09/21 13:26:41 grozin Exp $
+
+ 21 Sep 2012; Andrey Grozin <grozin@gentoo.org> gsl-shell-2.2.0_beta1.ebuild,
+ +files/gsl-shell-nogui.patch:
+ New USE flag doc; build with USE=-fox fixed
*gsl-shell-2.2.0_beta1 (20 Sep 2012)
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch b/sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch
new file mode 100644
index 000000000000..16d3eb0f04d2
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch
@@ -0,0 +1,25 @@
+diff -r -U1 gsl-shell.orig/Makefile gsl-shell/Makefile
+--- gsl-shell.orig/Makefile 2012-09-21 19:54:05.000000000 +0700
++++ gsl-shell/Makefile 2012-09-21 19:53:37.000000000 +0700
+@@ -29,3 +29,2 @@
+ GSL_SHELL = gsl-shell$(EXE_EXT)
+-GSL_SHELL_GUI = gsl-shell-gui$(EXE_EXT)
+ LUA_CFLAGS = -I$(LUADIR)/src
+@@ -73,4 +72,3 @@
+ INCLUDES += $(PTHREADS_CFLAGS) -Iagg-plot
+-GUI_SUBDIR = fox-gui
+-SUBDIRS += agg-plot $(GUI_SUBDIR)
++SUBDIRS += agg-plot
+ LUAGSL_LIBS += agg-plot/libaggplot.a
+@@ -105,6 +103,5 @@
+
+-install: $(GSL_SHELL) $(GUI_SUBDIR)
++install: $(GSL_SHELL)
+ mkdir -p $(INSTALL_BIN_DIR)
+ cp $(GSL_SHELL) $(INSTALL_BIN_DIR)
+- cp fox-gui/$(GSL_SHELL_GUI) $(INSTALL_BIN_DIR)
+ mkdir -p $(INSTALL_LIB_DIR)
+@@ -122,3 +119,2 @@
+ $(MAKE) -C $(LUADIR) clean
+- $(MAKE) -C fox-gui clean
+ $(HOST_RM) *.o $(TARGETS)
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
index 330339890dea..b51644621cae 100644
--- a/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild,v 1.1 2012/09/20 16:09:24 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild,v 1.2 2012/09/21 13:26:41 grozin Exp $
EAPI=4
inherit eutils versionator
@@ -12,13 +12,14 @@ SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86"
-IUSE="fox"
+IUSE="doc fox"
DEPEND=">=sci-libs/gsl-1.14
>=x11-libs/agg-2.5
>=media-libs/freetype-2.4.10
sys-libs/readline
|| ( media-fonts/ubuntu-font-family media-fonts/freefont-ttf media-fonts/dejavu )
+ doc? ( dev-python/sphinx[latex] )
fox? ( x11-libs/fox:1.6 )"
RDEPEND="${DEPEND}"
@@ -26,8 +27,19 @@ S="${WORKDIR}"
src_prepare() {
epatch "${FILESDIR}/${PN}.patch"
+ use fox || epatch "${FILESDIR}/${PN}-nogui.patch"
}
src_compile() {
emake -j1 CFLAGS="${CFLAGS}"
+ if use doc; then
+ pushd doc/user-manual > /dev/null
+ emake -j1 html
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/user-manual/_build/html/*
}