summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-26 09:36:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-26 09:36:29 +0000
commit03290617214f49d5a6af2df639b8cc73579c8f7e (patch)
treefd7a4d2654256713866a36b844926d65caf935ad
parentneed eutils for epatch (diff)
downloadgentoo-2-03290617214f49d5a6af2df639b8cc73579c8f7e.tar.gz
gentoo-2-03290617214f49d5a6af2df639b8cc73579c8f7e.tar.bz2
gentoo-2-03290617214f49d5a6af2df639b8cc73579c8f7e.zip
fix bug #39398, revision bump for it.
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/files/digest-php-4.3.4-r42
-rw-r--r--dev-php/php/php-4.3.4-r4.ebuild46
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index f58b60ca9587..e48c478911f2 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.73 2004/01/24 12:31:25 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.74 2004/01/26 09:36:28 robbat2 Exp $
+
+*php-4.3.4-r4 (26 Jan 2004)
+
+ 26 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> php-4.3.4-r4.ebuild:
+ fix bug #39398, revision bump for it.
24 Jan 2004; <gustavoz@gentoo.org> php-4.3.4-r3.ebuild:
marked stable on sparc
diff --git a/dev-php/php/files/digest-php-4.3.4-r4 b/dev-php/php/files/digest-php-4.3.4-r4
new file mode 100644
index 000000000000..d65ce9576341
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.4-r4
@@ -0,0 +1,2 @@
+MD5 b9dd601863e08e52e3c4d5e02c2627cf php-4.3.4.tar.bz2 3774324
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php/php-4.3.4-r4.ebuild b/dev-php/php/php-4.3.4-r4.ebuild
new file mode 100644
index 000000000000..f39ed746fc00
--- /dev/null
+++ b/dev-php/php/php-4.3.4-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.4-r4.ebuild,v 1.1 2004/01/26 09:36:29 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php-sapi eutils
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha hppa amd64 ia64"
+
+src_compile() {
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php-sapi_src_compile
+}
+
+
+src_install() {
+ PHP_INSTALLTARGETS="${PHP_INSTALLTARGETS} install-cli install-programs install-pear install-build install-headers"
+ php-sapi_src_install
+
+ einfo "Fixing PEAR cache location"
+ local oldloc="${T}/pear/cache"
+ local old="s:${#oldloc}:\"${oldloc}\""
+ local newloc="/tmp/pear/cache"
+ local new="s:${#newloc}:\"${newloc}\""
+ sed "s|${old}|${new}|" -i ${D}/etc/pear.conf
+ keepdir /tmp/pear/cache
+
+ einfo "Installing manpage"
+ doman sapi/cli/php.1
+}
+
+pkg_postinst() {
+ php-sapi_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You cannot use it on a webserver."
+
+ if [ "`md5sum ${ROOT}/root/.pearrc`" = "f0243f51b2457bc545158cf066e4e7a2 ${ROOT}/root/.pearrc" ]; then
+ einfo "Cleaning up an old PEAR install glitch"
+ mv ${ROOT}/root/.pearrc ${ROOT}/root/.pearrc.`date +%Y%m%d%H%M%S`
+ fi
+}