summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-24 04:45:53 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-24 04:45:53 +0000
commit018b560a551469b325df119e17cb31e3a9f28a68 (patch)
tree6e2a11246cda7acf00bde907f210b9e38a837c39
parentremoved supervise support and added runscript support (diff)
downloadgentoo-2-018b560a551469b325df119e17cb31e3a9f28a68.tar.gz
gentoo-2-018b560a551469b325df119e17cb31e3a9f28a68.tar.bz2
gentoo-2-018b560a551469b325df119e17cb31e3a9f28a68.zip
python, portage fixes
-rw-r--r--dev-lang/python/python-2.0-r4.ebuild2
-rw-r--r--profiles/default-1.0_rc6/make.defaults25
-rw-r--r--profiles/default-1.0_rc6/packages.bootstrap5
-rw-r--r--profiles/default-1.0_rc6/packages.build28
-rw-r--r--profiles/package.mask1
-rw-r--r--sys-apps/portage/portage-1.5.4.ebuild5
-rw-r--r--sys-devel/spython/spython-2.0-r4.ebuild91
-rw-r--r--sys-devel/spython/spython-2.0-r5.ebuild84
-rw-r--r--sys-devel/spython/spython-2.0-r6.ebuild93
-rw-r--r--sys-devel/spython/spython-2.0-r7.ebuild4
10 files changed, 45 insertions, 293 deletions
diff --git a/dev-lang/python/python-2.0-r4.ebuild b/dev-lang/python/python-2.0-r4.ebuild
index 9b191d47118b..174e3fb846c3 100644
--- a/dev-lang/python/python-2.0-r4.ebuild
+++ b/dev-lang/python/python-2.0-r4.ebuild
@@ -7,7 +7,7 @@
S=${WORKDIR}/Python-2.0
S2=${WORKDIR}/python-fchksum-1.1
DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
+SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
diff --git a/profiles/default-1.0_rc6/make.defaults b/profiles/default-1.0_rc6/make.defaults
index 5915cac18ea8..3900468c2977 100644
--- a/profiles/default-1.0_rc6/make.defaults
+++ b/profiles/default-1.0_rc6/make.defaults
@@ -1,23 +1,10 @@
# Copyright 2000 Daniel Robbins, Gentoo Technologies, Inc.
# System-wide defaults for the Portage system
-# Host-type
-CHOST=i486-pc-linux-gnu
+USE="slang readline gpm berkdb gdbm tcpd pam libwww ssl
+ lm_sensors lvm pcmcia-cs alsa
+ nls mmx mitshm
+ esd lcms gif sdl vorbis ogg
+ gnome gtk X qt kde motif opengl mozilla"
-PLATFORM=$CHOST
-
-# Options passed to make during the build process
-MAKEOPTS="-j2"
-
-# Fetching command (5 tries, passive ftp for firewall compatibility)
-FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp \${x} -P \${DISTDIR}"
-#For Prozilla (really rocks):
-#FETCHCOMMAND="/usr/bin/proz -s \${x} -P \${DISTDIR}"
-
-# Global configure options
-
-# C Compiler flags
-CFLAGS="-m486 -march=i486 -O2"
-# C++ Compiler flags
-CXXFLAGS="-m486 -march=i486 -O2"
-#DEBUG=true
+#inheriting nearly everything from make.globals at the moment :)
diff --git a/profiles/default-1.0_rc6/packages.bootstrap b/profiles/default-1.0_rc6/packages.bootstrap
new file mode 100644
index 000000000000..720e60bb9177
--- /dev/null
+++ b/profiles/default-1.0_rc6/packages.bootstrap
@@ -0,0 +1,5 @@
+./sys-apps/portage/portage-1.5.4.ebuild
+./sys-libs/glibc/glibc-2.2.3-r5.ebuild
+./sys-devel/binutils/binutils-2.11.90.0.7.ebuild
+./sys-devel/gcc/gcc-2.95.3-r1.ebuild
+./sys-devel/gettext/gettext-0.10.39.ebuild
diff --git a/profiles/default-1.0_rc6/packages.build b/profiles/default-1.0_rc6/packages.build
new file mode 100644
index 000000000000..3630df960048
--- /dev/null
+++ b/profiles/default-1.0_rc6/packages.build
@@ -0,0 +1,28 @@
+./sys-apps/baselayout/baselayout-1.6-r1.ebuild
+./sys-libs/glibc/glibc-2.2.3-r5.ebuild
+./sys-apps/bash/bash-2.04-r4.ebuild
+./sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
+./sys-apps/debianutils/debianutils-1.13.3-r4.ebuild
+./sys-apps/diffutils/diffutils-2.7-r4.ebuild
+./sys-apps/file/file-3.33-r3.ebuild
+./sys-apps/fileutils/fileutils-4.1-r2.ebuild
+./sys-apps/findutils/findutils-4.1-r6.ebuild
+./sys-apps/gawk/gawk-3.0.6-r4.ebuild
+./sys-apps/grep/grep-2.4.2-r4.ebuild
+./sys-apps/gzip/gzip-1.2.4a-r5.ebuild
+./sys-apps/portage/portage-1.5.4.ebuild
+./sys-apps/sed/sed-3.02.80-r3.ebuild
+./sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
+./sys-apps/tar/tar-1.13.19-r1.ebuild
+./sys-apps/textutils/textutils-2.0.10-r3.ebuild
+./sys-devel/binutils/binutils-2.11.90.0.7.ebuild
+./sys-devel/bison/bison-1.28-r3.ebuild
+./sys-devel/flex/flex-2.5.4a-r4.ebuild
+./sys-devel/gcc/gcc-2.95.3-r1.ebuild
+./sys-devel/make/make-3.79.1-r3.ebuild
+./sys-devel/patch/patch-2.5.4-r3.ebuild
+./sys-devel/spython/spython-2.0-r7.ebuild
+./net-misc/wget/wget-1.7-r1.ebuild
+./net-misc/rsync/rsync-2.4.6-r4.ebuild
+./sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild
+./app-editors/e3/e3-1.7-r2.ebuild
diff --git a/profiles/package.mask b/profiles/package.mask
index 2d9a1a33a1fa..709c73fc3cc6 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -107,7 +107,6 @@ app-editors/gtk-xemacs
>=net-fs/netatalk-1.5
>=media-libs/freetype-2.0.4
>=dev-db/unixODBC-2.0.8
-=sys-devel/spython-2.0-r5
=app-arch/unzip-5.42
=dev-java/blackdown-1.3.1
diff --git a/sys-apps/portage/portage-1.5.4.ebuild b/sys-apps/portage/portage-1.5.4.ebuild
index 10b451024ef9..65b41c5ddc01 100644
--- a/sys-apps/portage/portage-1.5.4.ebuild
+++ b/sys-apps/portage/portage-1.5.4.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2001 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.5.4.ebuild,v 1.2 2001/08/22 21:36:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.5.4.ebuild,v 1.3 2001/08/24 04:45:53 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Portage autobuild system"
SRC_URI=""
HOMEPAGE="http://www.gentoo.org"
-RDEPEND="sys-devel/spython"
+#debianutils is for "readlink"
+RDEPEND="sys-devel/spython sys-apps/debianutils"
PPV=1.5
src_unpack() {
diff --git a/sys-devel/spython/spython-2.0-r4.ebuild b/sys-devel/spython/spython-2.0-r4.ebuild
deleted file mode 100644
index ee09fa17c991..000000000000
--- a/sys-devel/spython/spython-2.0-r4.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.5 2001/04/28 08:24:12 achim Exp $
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND=">=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
-
-RDEPEND="virtual/glibc"
-PROVIDE="virtual/python"
-
-src_unpack() {
-
- unpack BeOpen-Python-2.0.tar.bz2
-
- cd ${S}/Modules
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- echo '*static*' >> Setup.local
-
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
-
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
-}
-
-src_compile() {
-
- export LDFLAGS=-static
-
- try ./configure --prefix=/usr --without-libdb
-
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
-
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-
-}
-
-src_install() {
-
- dodir /usr/share/man
- try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
- rm ${D}/usr/bin/python
- mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
-
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share/man
- fi
-}
-
-pkg_postinst() {
-
- if [ ! -e "${ROOT}/usr/bin/python" ]
- then
- ln -s spython ${ROOT}/usr/bin/python
- fi
-}
diff --git a/sys-devel/spython/spython-2.0-r5.ebuild b/sys-devel/spython/spython-2.0-r5.ebuild
deleted file mode 100644
index a6766fc94fa2..000000000000
--- a/sys-devel/spython/spython-2.0-r5.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r5.ebuild,v 1.1 2001/07/12 03:08:24 pete Exp $
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND=">=sys-devel/autoconf-2.13
- >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2 )"
-
-RDEPEND="virtual/glibc"
-PROVIDE="virtual/python"
-
-src_unpack() {
-
- unpack BeOpen-Python-2.0.tar.bz2
- cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
- autoconf
-
- cd ${S}/Modules
-
- cp -a ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- echo '*static*' >> Setup.local
-
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
-
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
-
- cd python-fchksum-1.1
- cp -a md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
-}
-
-src_compile() {
-
- export LDFLAGS=-static
-
- try ./configure --prefix=/usr --without-libdb
-
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
-
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-
-}
-
-src_install() {
-
- dodir /usr/share/man
- try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
-
- rm -rf ${D}/usr/include
- rm -rf ${D}/usr/lib/${PN}${PV}/config
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share
- fi
-}
diff --git a/sys-devel/spython/spython-2.0-r6.ebuild b/sys-devel/spython/spython-2.0-r6.ebuild
deleted file mode 100644
index 6656acefcd27..000000000000
--- a/sys-devel/spython/spython-2.0-r6.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r6.ebuild,v 1.1 2001/08/04 18:22:45 pete Exp $
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND=">=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
-
-RDEPEND="virtual/glibc"
-PROVIDE="virtual/python"
-
-src_unpack() {
-
- unpack BeOpen-Python-2.0.tar.bz2
-
- cd ${S}/Modules
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- echo '*static*' >> Setup.local
-
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
-
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
-}
-
-src_compile() {
-
- export LDFLAGS=-static
-
- try ./configure --prefix=/usr --without-libdb
-
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
-
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-
-}
-
-src_install() {
-
- dodir /usr/share/man
- try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
- rm ${D}/usr/bin/python
- mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
-
- if [ "`use build`" ] || [ "`use bootcd`" ]
- then
- rm -rf ${D}/usr/share/man
- rm -rf ${D}/usr/lib/python${PV}/{test,config}
- rm -rf ${D}/usr/include
- fi
-}
-
-pkg_postinst() {
-
- if [ ! -e "${ROOT}/usr/bin/python" ]
- then
- ln -s spython ${ROOT}/usr/bin/python
- fi
-}
diff --git a/sys-devel/spython/spython-2.0-r7.ebuild b/sys-devel/spython/spython-2.0-r7.ebuild
index 5c5c7f526cee..e33a9cc274ed 100644
--- a/sys-devel/spython/spython-2.0-r7.ebuild
+++ b/sys-devel/spython/spython-2.0-r7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.3 2001/08/17 23:41:54 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.4 2001/08/24 04:45:53 drobbins Exp $
S=${WORKDIR}/Python-2.0
S2=${WORKDIR}/python-fchksum-1.1
DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
+SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"