summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-11-07 05:44:32 +0000
committerParag Mehta <pm@gentoo.org>2001-11-07 05:44:32 +0000
commit01785d4c7406e56b4c874e518725147be965c73b (patch)
treea2d10aaa82c9554582c0687e2fa0db233ed9d524
parentcleaned up font installation (diff)
downloadgentoo-2-01785d4c7406e56b4c874e518725147be965c73b.tar.gz
gentoo-2-01785d4c7406e56b4c874e518725147be965c73b.tar.bz2
gentoo-2-01785d4c7406e56b4c874e518725147be965c73b.zip
new updated recommended package.
-rw-r--r--app-editors/nano/files/digest-nano-1.0.61
-rw-r--r--app-editors/nano/nano-1.0.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/nano/files/digest-nano-1.0.6 b/app-editors/nano/files/digest-nano-1.0.6
new file mode 100644
index 000000000000..fcf6fe57f91a
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.0.6
@@ -0,0 +1 @@
+MD5 01db121b6f4645480af29d3926a4b662 nano-1.0.6.tar.gz 434176
diff --git a/app-editors/nano/nano-1.0.6.ebuild b/app-editors/nano/nano-1.0.6.ebuild
new file mode 100644
index 000000000000..2f43a792876a
--- /dev/null
+++ b/app-editors/nano/nano-1.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.6.ebuild,v 1.1 2001/11/07 05:44:32 pm Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Clone of PICO with more Fuctions in a smaller Size"
+#SRC_URI="http://www.nano-editor.org/dist/v1.0/${A}"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --enable-extra --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make DESTDIR=${D} install
+ if [ -z "`use bootcd`" ] && [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog README
+ else
+ rm -rf ${D}/usr/share
+ fi
+}