summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-12-01 20:02:21 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-12-01 20:02:21 +0000
commit00e31b05727a095a9aff61c93fe4bedd1b821e37 (patch)
tree39a193f4313d90ae96601d61182ae89f31833f17
parentMasking examples flag on dev-util/qt-creator (diff)
downloadgentoo-2-00e31b05727a095a9aff61c93fe4bedd1b821e37.tar.gz
gentoo-2-00e31b05727a095a9aff61c93fe4bedd1b821e37.tar.bz2
gentoo-2-00e31b05727a095a9aff61c93fe4bedd1b821e37.zip
Restoring ~ppc and ~ppc64 keywords and masking examples in powerpc profile. Removing 1.2.90 technology preview.
(Portage version: 2.2_rc54/cvs/Linux x86_64)
-rw-r--r--dev-util/qt-creator/ChangeLog6
-rw-r--r--dev-util/qt-creator/qt-creator-1.2.90.ebuild102
-rw-r--r--dev-util/qt-creator/qt-creator-1.3.0.ebuild8
3 files changed, 9 insertions, 107 deletions
diff --git a/dev-util/qt-creator/ChangeLog b/dev-util/qt-creator/ChangeLog
index 9c7cc0016192..81f9dc0145a7 100644
--- a/dev-util/qt-creator/ChangeLog
+++ b/dev-util/qt-creator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/qt-creator
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/ChangeLog,v 1.32 2009/12/01 18:38:01 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/ChangeLog,v 1.33 2009/12/01 20:02:21 ayoy Exp $
+
+ 01 Dec 2009; Dominik Kapusta <ayoy@gentoo.org> -qt-creator-1.2.90.ebuild,
+ qt-creator-1.3.0.ebuild:
+ Restoring ~ppc and ~ppc64 keywords and masking examples in powerpc profile
*qt-creator-1.3.0 (01 Dec 2009)
diff --git a/dev-util/qt-creator/qt-creator-1.2.90.ebuild b/dev-util/qt-creator/qt-creator-1.2.90.ebuild
deleted file mode 100644
index 8192577a9808..000000000000
--- a/dev-util/qt-creator/qt-creator-1.2.90.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-1.2.90.ebuild,v 1.2 2009/10/03 19:27:58 hwoarang Exp $
-
-EAPI="2"
-
-inherit qt4 multilib
-MY_PN="${PN/-/}"
-
-DESCRIPTION="Lightweight IDE for C++ development centering around Qt"
-HOMEPAGE="http://labs.qtsoftware.com/page/Projects/Tools/QtCreator"
-SRC_URI="ftp://ftp.qt.nokia.com/${MY_PN}/${P}-src.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bineditor bookmarks +cmake cvs debug +debugger +designer doc examples fakevim git kde perforce qtscript subversion"
-
-DEPEND=">=x11-libs/qt-assistant-4.5.0:4
- >=x11-libs/qt-gui-4.5.0:4[dbus,qt3support]"
-
-RDEPEND="${DEPEND}
- >=x11-libs/qt-sql-4.5.0:4
- >=x11-libs/qt-svg-4.5.0:4
- >=x11-libs/qt-test-4.5.0:4
- >=x11-libs/qt-webkit-4.5.0:4
- !kde? ( || ( >=x11-libs/qt-phonon-4.5.0:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- cmake? ( dev-util/cmake )
- cvs? ( dev-util/cvs )
- debugger? ( sys-devel/gdb )
- examples? ( >=x11-libs/qt-demo-4.5.0:4 )
- git? ( dev-util/git )
- qtscript? ( >=x11-libs/qt-script-4.5.0:4 )
- subversion? ( dev-util/subversion )"
-
-PLUGINS="bookmarks bineditor cmake cvs debugger designer fakevim git perforce qtscript subversion"
-
-PATCHES=(
- "${FILESDIR}/docs_gen-${PV}.patch"
-)
-
-S="${WORKDIR}/${P}-src"
-
-LANGS="de es fr it ja ru"
-
-for x in ${LANGS}; do
- IUSE="${IUSE} linguas_${x}"
-done
-
-src_prepare() {
- qt4_src_prepare
-
- # bug 263087
- for plugin in ${PLUGINS};do
- if ! use ${plugin};then
- einfo "Disabling ${plugin} support"
- if [[ ${plugin} == "cmake" ]];then
- plugin="cmakeprojectmanager"
- elif [[ ${plugin} == "qtscript" ]];then
- plugin="qtscripteditor"
- fi
- sed -i "/plugin_${plugin}/s:^:#:" src/plugins/plugins.pro \
- || die "Failed to disable ${plugin} plugin"
- fi
- done
-
- if use perforce;then
- ewarn
- ewarn "You have enabled perforce plugin."
- ewarn "In order to use it, you need to manually"
- ewarn "download perforce client from http://www.perforce.com/perforce/downloads/index.html"
- ewarn
- ebeep 5
- fi
-}
-
-src_configure() {
- eqmake4 ${MY_PN}.pro IDE_LIBRARY_BASENAME="$(get_libdir)"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}/usr" install_subtargets || die "emake install failed"
- # fix binary name bug 275859
- mv "${D}"/usr/bin/${MY_PN}.bin "${D}"/usr/bin/${MY_PN} || die "failed to rename executable"
- if use doc;then
- emake INSTALL_ROOT="${D}/usr" install_qch_docs || die "emake install qch_docs failed"
- fi
- make_desktop_entry ${MY_PN} QtCreator qtcreator_logo_48 \
- 'Qt;Development;IDE' || die "make_desktop_entry failed"
-
- # install translations
- insinto /usr/share/${MY_PN}/translations/
- for x in ${LINGUAS};do
- for lang in ${LANGS};do
- if [[ ${x} == ${lang} ]];then
- doins share/${MY_PN}/translations/${MY_PN}_${x}.qm \
- || die "failed to install translations"
- fi
- done
- done
-}
diff --git a/dev-util/qt-creator/qt-creator-1.3.0.ebuild b/dev-util/qt-creator/qt-creator-1.3.0.ebuild
index 4154bb6f1e9f..55655687b62f 100644
--- a/dev-util/qt-creator/qt-creator-1.3.0.ebuild
+++ b/dev-util/qt-creator/qt-creator-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-1.3.0.ebuild,v 1.1 2009/12/01 18:38:01 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-1.3.0.ebuild,v 1.2 2009/12/01 20:02:21 ayoy Exp $
EAPI="2"
@@ -13,11 +13,11 @@ SRC_URI="http://get.qt.nokia.com/qtcreator/${P}-src.zip"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="bineditor bookmarks +cmake cvs debug +debugger +designer doc examples fakevim git kde mercurial perforce qtscript subversion"
-DEPEND=">=x11-libs/qt-assistant-4.6.0_alpha_pre1:4
- >=x11-libs/qt-gui-4.6.0_alpha_pre1:4[dbus,qt3support]"
+DEPEND=">=x11-libs/qt-assistant-4.6.0:4
+ >=x11-libs/qt-gui-4.6.0:4[dbus,qt3support]"
RDEPEND="${DEPEND}
>=x11-libs/qt-sql-4.6.0:4