summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-02-10 03:52:03 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-02-10 03:52:03 +0000
commit000c7aed8bb9ccf23ae990a77d625fe03680fcd3 (patch)
tree56a38950cce0dfd780765d1cfa7fd02453082396
parentMarked ppc/ppc64 stable for bug #300126. (diff)
downloadgentoo-2-000c7aed8bb9ccf23ae990a77d625fe03680fcd3.tar.gz
gentoo-2-000c7aed8bb9ccf23ae990a77d625fe03680fcd3.tar.bz2
gentoo-2-000c7aed8bb9ccf23ae990a77d625fe03680fcd3.zip
Clean up wxGTK handling/old 2.4 workarounds. wxwindows->wxwidgets.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
-rw-r--r--app-emulation/bochs/ChangeLog8
-rw-r--r--app-emulation/bochs/bochs-2.3.6.ebuild27
-rw-r--r--app-emulation/bochs/bochs-2.3.7.ebuild27
-rw-r--r--app-emulation/bochs/bochs-2.3.ebuild21
-rw-r--r--app-emulation/bochs/bochs-2.4.1.ebuild27
5 files changed, 44 insertions, 66 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 7781e8cd9642..d4efa5fb4fdc 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/bochs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.85 2009/09/23 15:32:34 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.86 2010/02/10 03:52:03 dirtyepic Exp $
+
+ 10 Feb 2010; Ryan Hill <dirtyepic@gentoo.org> bochs-2.3.ebuild,
+ bochs-2.3.6.ebuild, bochs-2.3.7.ebuild, bochs-2.4.1.ebuild:
+ Clean up wxGTK handling/old 2.4 workarounds. wxwindows->wxwidgets.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> bochs-2.3.ebuild,
bochs-2.3.6.ebuild, bochs-2.3.7.ebuild, bochs-2.4.1.ebuild:
diff --git a/app-emulation/bochs/bochs-2.3.6.ebuild b/app-emulation/bochs/bochs-2.3.6.ebuild
index e5f461dfe469..2947c5d59cd6 100644
--- a/app-emulation/bochs/bochs-2.3.6.ebuild
+++ b/app-emulation/bochs/bochs-2.3.6.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.4 2009/09/23 15:32:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.5 2010/02/10 03:52:03 dirtyepic Exp $
-inherit eutils wxwidgets autotools
+WX_GTK_VER=2.6
+
+inherit eutils wxwidgets
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
@@ -12,7 +14,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="X debugger readline usb wxwindows svga sdl ncurses vnc acpi"
+IUSE="X debugger readline usb wxwidgets svga sdl ncurses vnc acpi"
RDEPEND="X? ( x11-libs/libICE
x11-libs/libSM
@@ -20,7 +22,7 @@ RDEPEND="X? ( x11-libs/libICE
x11-libs/libXpm )
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
- wxwindows? ( =x11-libs/wxGTK-2.6* )
+ wxwidgets? ( =x11-libs/wxGTK-2.6* )
readline? ( sys-libs/readline )
ncurses? ( sys-libs/ncurses )"
@@ -39,27 +41,18 @@ src_unpack() {
-e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
Makefile.in || \
die "sed Makefile.in failed"
-
- # Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
- sed -i -e "s:wx-config:wx-config-2.6:" configure.in
- eautoconf
}
src_compile() {
- export WX_GTK_VER=2.6
-
- use wxwindows && \
- need-wxwidgets gtk2
-
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"
use amd64 && \
myconf="--enable-x86-64"
- use wxwindows && \
+ use wxwidgets && \
myconf="${myconf} --with-wx"
- use wxwindows || \
+ use wxwidgets || \
myconf="${myconf} --without-wx"
use vnc && \
@@ -120,7 +113,7 @@ src_install() {
dodoc README.rfb || die "dodoc failed"
fi
- if [ use wxwindows ]
+ if [ use wxwidgets ]
then
dodoc README-wxWindows || die "dodoc failed"
fi
diff --git a/app-emulation/bochs/bochs-2.3.7.ebuild b/app-emulation/bochs/bochs-2.3.7.ebuild
index 8aa8ae1433e3..3647951167ad 100644
--- a/app-emulation/bochs/bochs-2.3.7.ebuild
+++ b/app-emulation/bochs/bochs-2.3.7.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.7.ebuild,v 1.6 2009/09/23 15:32:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.7.ebuild,v 1.7 2010/02/10 03:52:03 dirtyepic Exp $
-inherit eutils wxwidgets autotools
+WX_GTK_VER=2.6
+
+inherit eutils wxwidgets
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
@@ -12,7 +14,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 ppc ~sparc x86"
-IUSE="X debugger readline usb wxwindows svga sdl ncurses vnc acpi"
+IUSE="X debugger readline usb wxwidgets svga sdl ncurses vnc acpi"
RDEPEND="X? ( x11-libs/libICE
x11-libs/libSM
@@ -20,7 +22,7 @@ RDEPEND="X? ( x11-libs/libICE
x11-libs/libXpm )
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
- wxwindows? ( =x11-libs/wxGTK-2.6* )
+ wxwidgets? ( =x11-libs/wxGTK-2.6* )
readline? ( sys-libs/readline )
ncurses? ( sys-libs/ncurses )"
@@ -42,27 +44,18 @@ src_unpack() {
-e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
Makefile.in || \
die "sed Makefile.in failed"
-
- # Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
- sed -i -e "s:wx-config:wx-config-2.6:" configure.in
- eautoconf
}
src_compile() {
- export WX_GTK_VER=2.6
-
- use wxwindows && \
- need-wxwidgets gtk2
-
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"
use amd64 && \
myconf="--enable-x86-64"
- use wxwindows && \
+ use wxwidgets && \
myconf="${myconf} --with-wx"
- use wxwindows || \
+ use wxwidgets || \
myconf="${myconf} --without-wx"
use vnc && \
@@ -152,7 +145,7 @@ src_install() {
dodoc README.rfb || die "dodoc failed"
fi
- if [ use wxwindows ]
+ if [ use wxwidgets ]
then
dodoc README-wxWindows || die "dodoc failed"
fi
diff --git a/app-emulation/bochs/bochs-2.3.ebuild b/app-emulation/bochs/bochs-2.3.ebuild
index 464d22d61b0f..774272eb5c0c 100644
--- a/app-emulation/bochs/bochs-2.3.ebuild
+++ b/app-emulation/bochs/bochs-2.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.8 2009/09/23 15:32:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.9 2010/02/10 03:52:03 dirtyepic Exp $
+
+WX_GTK_VER=2.6
inherit eutils wxwidgets autotools
@@ -12,14 +14,14 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 ppc ~sparc x86"
-IUSE="debugger readline sdl wxwindows X ncurses vnc"
+IUSE="debugger readline sdl wxwidgets X ncurses vnc"
RDEPEND="X? ( x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXpm )
sdl? ( media-libs/libsdl )
- wxwindows? ( =x11-libs/wxGTK-2.6* )
+ wxwidgets? ( =x11-libs/wxGTK-2.6* )
readline? ( sys-libs/readline )
ncurses? ( sys-libs/ncurses )"
@@ -41,8 +43,6 @@ src_unpack() {
sed -i -e "s:/opt/gnome:/usr:" configure
# Fix some bad coding for gcc-4.1 compliance
sed -i -e "s:\#ifndef PARANOID:\#if 0:" iodev/hdimage.h
-# Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
- sed -i -e "s:wx-config:wx-config-2.6:" configure
# wx unicode patches from fedora and bits the fedora missed
# epatch ${DISTDIR}/${P}-unicode.patch.gz
epatch ${FILESDIR}/${P}-redog.patch
@@ -52,18 +52,13 @@ src_unpack() {
}
src_compile() {
- export WX_GTK_VER=2.6
-
- use wxwindows && \
- need-wxwidgets gtk2
-
[[ "$ARCH" == "x86" ]] \
&& myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"
myconf="${myconf} `use_enable readline`"
- use wxwindows && \
+ use wxwidgets && \
myconf="${myconf} --with-wx"
- use wxwindows || \
+ use wxwidgets || \
myconf="${myconf} --without-wx"
use debugger && \
myconf="$myconf --enable-debugger --enable-disasm \
diff --git a/app-emulation/bochs/bochs-2.4.1.ebuild b/app-emulation/bochs/bochs-2.4.1.ebuild
index a6522b4297d1..1c902e700d02 100644
--- a/app-emulation/bochs/bochs-2.4.1.ebuild
+++ b/app-emulation/bochs/bochs-2.4.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.2 2009/09/23 15:32:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.3 2010/02/10 03:52:03 dirtyepic Exp $
-inherit eutils wxwidgets autotools
+WX_GTK_VER=2.6
+
+inherit eutils wxwidgets
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
@@ -12,7 +14,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="X debugger readline usb wxwindows svga sdl ncurses vnc acpi"
+IUSE="X debugger readline usb wxwidgets svga sdl ncurses vnc acpi"
RDEPEND="X? ( x11-libs/libICE
x11-libs/libSM
@@ -20,7 +22,7 @@ RDEPEND="X? ( x11-libs/libICE
x11-libs/libXpm )
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
- wxwindows? ( =x11-libs/wxGTK-2.6* )
+ wxwidgets? ( =x11-libs/wxGTK-2.6* )
readline? ( sys-libs/readline )
ncurses? ( sys-libs/ncurses )"
@@ -39,27 +41,18 @@ src_unpack() {
-e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
Makefile.in || \
die "sed Makefile.in failed"
-
- # Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
- sed -i -e "s:wx-config:wx-config-2.6:" configure.in
- eautoconf
}
src_compile() {
- export WX_GTK_VER=2.6
-
- use wxwindows && \
- need-wxwidgets gtk2
-
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"
use amd64 && \
myconf="--enable-x86-64"
- use wxwindows && \
+ use wxwidgets && \
myconf="${myconf} --with-wx"
- use wxwindows || \
+ use wxwidgets || \
myconf="${myconf} --without-wx"
use vnc && \
@@ -146,7 +139,7 @@ src_install() {
dodoc README.rfb || die "dodoc failed"
fi
- if [ use wxwindows ]
+ if [ use wxwidgets ]
then
dodoc README-wxWindows || die "dodoc failed"
fi