aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gentoo.org>2013-08-28 17:46:29 +0300
committerPavlos Ratis <dastergon@gentoo.org>2013-09-01 20:02:14 +0300
commitc259b7c0f1935a4464946a66119504957921b7a8 (patch)
tree57aa268f5ea2b37f5ef80ac0115ebde85f57d5b8 /setup.py
parentMerge pull request #81 from tampakrap/test_ldapuser (diff)
downloadidentity.gentoo.org-c259b7c0f1935a4464946a66119504957921b7a8.tar.gz
identity.gentoo.org-c259b7c0f1935a4464946a66119504957921b7a8.tar.bz2
identity.gentoo.org-c259b7c0f1935a4464946a66119504957921b7a8.zip
add support for user settings
Basic setting pages that allow users to edit easily their LDAP attributes via web forms. Settings: * Profile settings (first name , last name, email , timezone, birthday, * passwords) * Contact settings (website, IM , GPG fingerprint, location, longitude, latitude) * Gentoo settings (mentors, developer bug, join date, retire date, ssh key) Notes: * Currently settings work only with single values and not * listfields. * Timezone needed for OpenID (cc: @mgorny) * Gentoo Account Settings page is available for everyone.(testing purposes)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 92adfe0..306ee40 100755
--- a/setup.py
+++ b/setup.py
@@ -46,6 +46,7 @@ setup(
'python-ldap>=2.4.10',
'python-memcached>=1.53',
'python-openid>=2.2.5',
+ 'pytz>=2012j',
'qrcode>=3.0',
],
setup_requires=[