summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-05-14 15:25:07 +0200
committerMartin Väth <martin@mvath.de>2023-05-14 15:25:07 +0200
commit5ed04a79d902ca706f0fb1e6d43c5fea632de461 (patch)
treee433f57f6bd064fc77da05347b2bdef3073b2124 /sci-geosciences
parentx11-libs/gtk+/gtk+:2 revision bump (diff)
downloadmv-5ed04a79d902ca706f0fb1e6d43c5fea632de461.tar.gz
mv-5ed04a79d902ca706f0fb1e6d43c5fea632de461.tar.bz2
mv-5ed04a79d902ca706f0fb1e6d43c5fea632de461.zip
sci-geosciences/googleearth: https://github.com/vaeth/mv-overlay/issues/33
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/googleearth/googleearth-7.1.8.3036-r4.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.1.8.3036-r3.ebuild)1
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.0.3832-r4.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.0.3832-r3.ebuild)1
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.4-r2.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.4-r1.ebuild)1
3 files changed, 3 insertions, 0 deletions
diff --git a/sci-geosciences/googleearth/googleearth-7.1.8.3036-r3.ebuild b/sci-geosciences/googleearth/googleearth-7.1.8.3036-r4.ebuild
index 195dc2e9..993f53a1 100644
--- a/sci-geosciences/googleearth/googleearth-7.1.8.3036-r3.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.1.8.3036-r4.ebuild
@@ -86,6 +86,7 @@ src_prepare() {
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
chmod u+w "${x}" || die
+ [[ ${x} != libicudata.so.* ]] || continue
patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done
diff --git a/sci-geosciences/googleearth/googleearth-7.3.0.3832-r3.ebuild b/sci-geosciences/googleearth/googleearth-7.3.0.3832-r4.ebuild
index e3cf22a6..a14598df 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.0.3832-r3.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.0.3832-r4.ebuild
@@ -72,6 +72,7 @@ src_prepare() {
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
chmod u+w "${x}" || die
+ [[ ${x} != libicudata.so.* ]] || continue
patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done
diff --git a/sci-geosciences/googleearth/googleearth-7.3.4-r1.ebuild b/sci-geosciences/googleearth/googleearth-7.3.4-r2.ebuild
index 7bb9f355..e6322c1f 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.4-r1.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.4-r2.ebuild
@@ -61,6 +61,7 @@ src_prepare() {
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
chmod u+w "${x}" || die
+ [[ ${x} != libicudata.so.* ]] || continue
patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done