summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-01-25 13:14:28 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:21 +0200
commitb4526de042879697630edd06e030be8e1a055632 (patch)
tree322cb99edd0b5a791eb6567e0c4a668564901cdf
parentBump kernel (diff)
downloadmv-b4526de042879697630edd06e030be8e1a055632.tar.gz
mv-b4526de042879697630edd06e030be8e1a055632.tar.bz2
mv-b4526de042879697630edd06e030be8e1a055632.zip
Add reduce. Remove autodeps of mv_mozextension. Bump classic-theme-restorer
-rw-r--r--eclass/mv_mozextension.eclass188
-rw-r--r--profiles/use.desc6
-rw-r--r--sci-mathematics/reduce/ChangeLog10
-rw-r--r--sci-mathematics/reduce/Manifest1
-rw-r--r--sci-mathematics/reduce/files/64reduce-gentoo.el4
-rwxr-xr-xsci-mathematics/reduce/files/csl2
-rwxr-xr-xsci-mathematics/reduce/files/redcsl2
-rw-r--r--sci-mathematics/reduce/metadata.xml13
-rw-r--r--sci-mathematics/reduce/reduce-20141130.ebuild103
-rw-r--r--www-plugins/classic-theme-restorer/ChangeLog12
-rw-r--r--www-plugins/classic-theme-restorer/Manifest2
-rw-r--r--www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.9.ebuild (renamed from www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.8.2.ebuild)0
12 files changed, 187 insertions, 156 deletions
diff --git a/eclass/mv_mozextension.eclass b/eclass/mv_mozextension.eclass
index 2c1405ee..45a7a359 100644
--- a/eclass/mv_mozextension.eclass
+++ b/eclass/mv_mozextension.eclass
@@ -23,18 +23,6 @@
# set corresponding dependencies and print corresponding messages.
: ${MV_MOZ_MOZILLAS=firefox seamonkey}
-# @ECLASS-VARIABLE: MV_MOZ_EXTDIR
-# @DESCRIPTION:
-# If this variable has the special value "*", the extension is copied directly
-# into the extension directory of the installed MOZILLA's.
-# Otherwise, only symlinks are made in that directory, and the extension is
-# installed only once into MV_MOZ_EXTDIR (a default directory is
-# chosen if MV_MOZ_EXTDIR is empty).
-# If this variable has the special value "?" (default), it acts like "*" or
-# "" depending on whether MV_MOZ_MOZILLAS applies to more than 1 installed
-# mozilla or not.
-: ${MV_MOZ_EXTDIR=?}
-
inherit eutils multilib
case ${EAPI:-0} in
@@ -42,28 +30,29 @@ case ${EAPI:-0} in
die "EAPI ${EAPI} no longer supported by ${ECLASS}";;
esac
-
+IUSE=
RDEPEND='|| ('
+REQUIRED_USE='|| ('
case ${MV_MOZ_MOZILLAS} in
*fire*)
+ IUSE="${IUSE}${IUSE:+ }firefox firefox-bin"
RDEPEND="${RDEPEND}
- >=www-client/firefox-21
- >=www-client/firefox-bin-21";;
+ firefox? ( >=www-client/firefox-21 )
+ firefox-bin? ( >=www-client/firefox-bin-21 )"
+ REQUIRED_USE="${REQUIRED_USE} firefox firefox-bin";;
esac
case ${MV_MOZ_MOZILLAS} in
*sea*)
+ IUSE="${IUSE}${IUSE:+ }seamonkey seamonkey-bin"
RDEPEND="${RDEPEND}
- www-client/seamonkey
- www-client/seamonkey-bin";;
+ seamonkey? ( www-client/seamonkey )
+ seamonkey-bin? ( www-client/seamonkey-bin )"
+ REQUIRED_USE="${REQUIRED_USE} seamonkey seamonkey-bin";;
esac
-RDEPEND=${RDEPEND}'
-)'
+RDEPEND="${RDEPEND} )"
+REQUIRED_USE="${REQUIRED_USE} )"
DEPEND='app-arch/unzip'
-[ -n "${RDEPEND}" ] && DEPEND="${DEPEND}
-${RDEPEND}"
-
-[ "${MV_MOZ_EXTDIR}" = '*' ] || IUSE='copy-extensions symlink-extensions'
mv_mozextension_src_unpack() {
local i
@@ -81,131 +70,27 @@ mv_mozextension_src_prepare() {
EXPORT_FUNCTIONS src_unpack src_prepare
-declare -a MV_MOZ_INS MV_MOZ_PKG MV_MOZ_CPY MV_MOZ_DIR
-
-mv_mozextension_install() {
- local MOZILLA_EXTENSIONS_DIRECTORY
- MOZILLA_EXTENSIONS_DIRECTORY=${1}
- MV_MOZ_INS=()
- xpi_install_dirs
-}
-
-mv_mozextension_calc() {
- local v
- case ${MV_MOZ_MOZILLAS} in
- ${1})
- false;;
- esac && return
- v=`best_version "${2}"` && [ -n "${v}" ] || return
- MV_MOZ_PKG+=("${v}")
- MV_MOZ_DIR+=("${3}")
-}
-
mv_mozextension_src_install() {
- local b d e i j k l s
- MV_MOZ_PKG=()
- MV_MOZ_DIR=()
- b="${EPREFIX}/usr/`get_libdir`/"
- e="${EPREFIX}/opt/"
- mv_mozextension_calc '*fire*' 'www-client/firefox' "${b}firefox/browser"
- mv_mozextension_calc '*fire*' 'www-client/firefox-bin' "${e}firefox/browser"
- mv_mozextension_calc '*sea*' 'www-client/seamonkey' "${b}seamonkey"
- mv_mozextension_calc '*sea*' 'www-client/seamonkey-bin' "${e}seamonkey"
- [ ${#MV_MOZ_DIR[@]} -ne 0 ] || die 'no supported mozilla is installed'
- d=${MV_MOZ_EXTDIR}
- if [ "${d}" = '?' ]
- then if [ ${#MV_MOZ_PKG[@]} -gt 1 ]
- then d=''
- else d='*'
- fi
- fi
- MV_MOZ_SYM=()
- MV_MOZ_LNK=false
- if [ "${d}" = '*' ] || ! use symlink-extensions
- then MV_MOZ_CPY=:
- else MV_MOZ_CPY=false
- if [ -n "${d}" ]
- then mv_mozextension_install "${d}"
- else mv_mozextension_install "${b}mozilla/extensions"
- fi
- fi
- use copy-extensions || MV_MOZ_LNK=:
- for i in "${MV_MOZ_DIR[@]}"
- do j="${i}/extensions"
- ${MV_MOZ_CPY} && mv_mozextension_install "${j}"
- for k in "${MV_MOZ_INS[@]}"
- do l="${j}/${k##*/}"
- MV_MOZ_SYM+=("${l}")
- ${MV_MOZ_CPY} || dosym "${ROOT%/}${k}" "${l}"
- done
- done
-}
-
-mv_mozextension_pkg_preinst() {
- local i j
- einfo 'checking for switching between dirs and symlinks'
- for i in "${MV_MOZ_SYM[@]}"
- do j=${ROOT%/}${i}
-# There are two forms of installation:
-# (1) symlink mozilla-dir/extensions/X -> $MOZILLA_EXTENSIONS_DIRECTORY/X
-# (2) data in mozilla-dir/extensions/X
-# Since we might switch between (1) and (2), we must take caution, since
-# in general portage cannot merge into the live directory properly:
- if ${MV_MOZ_CPY}
- then test -L "${j}" && {
-# We switched from (1) to (2). If this happened, portage would
-# actually merge the data of (2) into $MOZILLA_EXTENSIONS_DIRECTORY/X,
-# since this is where the symlink from (1) points to.
-# Hence, we have to remove this symlink in advance, in this case.
- rm -v -- "${j}"
- }
- else test -d "${j}" && ! test -L "${j}" && {
-# We switched from (2) to (1). If this happened, portage cannot
-# merge the symlink to the live system, since this can only happen once
-# the directory mozilla-dir/extensions/X is removed.
-# We could remove this directory here.
-# However, removing a directory is a dangerous thing, and so
-# we prefer to tell the user only that he has to reemerge the package.
- eerror
- eerror "It is necessary to reemerge again ${CATEGORY}/${PN}"
- eerror '(a directory should be removed in the cleanup after the first emerge'
- eerror 'in order to install a symlink of the same name in the second emerge.)'
- eerror
- break
- }
- fi
- done
-}
-
-mv_mozextension_pkg_postinst() {
- local i
- [ "${#MV_MOZ_PKG[@]}" -ge 1 ] || die 'no supported mozilla is installed'
- elog "${CATEGORY}/${PN} has been installed for the following packages:"
- for i in ${MV_MOZ_PKG[@]}
- do elog " ${i}"
- done
- elog "When you install/uninstall/reemerge some of: ${MV_MOZ_MOZILLAS}"
- elog "you might need to reemerge ${CATEGORY}/${PN}"
- ${MV_MOZ_CPY} || {
- elog
- elog 'The extension was installed using symlinks. This saves space but may require'
- elog 'to remove ~/.mozilla/*/*/extensions.ini for each browser restart.'
- }
+ local b e
+ b="${EPREFIX}/usr/$(get_libdir)"
+ e="${EPREFIX}/opt"
+ mv_mozextension_install firefox "${b}/firefox/browser/extensions"
+ mv_mozextension_install firefox-bin "${e}/firefox/browser/extensions"
+ mv_mozextension_install seamonkey "${b}/seamonkey/extensions"
+ mv_mozextension_install seamonkey-bin "${e}/seamonkey/extensions"
}
-if [ -n "${MV_MOZ_MOZILLAS}" ]
-then EXPORT_FUNCTIONS src_install pkg_preinst pkg_postinst
-fi
+[ -z "${MV_MOZ_MOZILLAS}" ] || EXPORT_FUNCTIONS src_install
xpi_unpack() {
- local xpi srcdir
+ local xpi srcdir u
# Not gonna use ${A} as we are looking for a specific option being passed to function
# You must specify which xpi to use
[ ${#} -eq 0 ] && die \
"Nothing passed to the ${FUNCNAME} command. Please pass which xpi to unpack"
- test -d "${S}" || mkdir "${S}"
+ test -d "${S}" || mkdir "${S}" || die
for xpi
do einfo "Unpacking ${xpi} to ${S}"
xpiname=${xpi%.*}
@@ -237,28 +122,20 @@ xpi_install() {
local d x
# You must tell xpi_install which dir to use
- [ ${#} -ne 1 ] && die "${FUNCNAME} takes exactly one argument. Please specify the directory"
+ [ ${#} -eq 1 ] || die "${FUNCNAME} takes exactly one argument. Please specify the directory"
x=${1}
# determine id for extension
d='{ /\<\(em:\)*id\>/!d; s/.*[\">]\([^\"<>]*\)[\"<].*/\1/; p; q }'
- d=`sed -n -e '/install-manifest/,$ '"${d}" "${x}"/install.rdf` \
+ d=$(sed -n -e '/install-manifest/,$ '"${d}" "${x}"/install.rdf) \
&& [ -n "${d}" ] || die 'failed to determine extension id'
- if [ -n "${MOZILLA_EXTENSIONS_DIRECTORY}" ]
- then d="${MOZILLA_EXTENSIONS_DIRECTORY}/${d}"
- MV_MOZ_INS+=("${d}")
- else d="${MOZILLA_FIVE_HOME}/extensions/${d}"
- fi
+ : ${MOZILLA_EXTENSIONS_DIRECTORY:="${MOZILLA_FIVE_HOME}/extensions"}
+ d="${MOZILLA_EXTENSIONS_DIRECTORY}/${d}"
test -d "${D}${d}" || dodir "${d}" || die "failed to create ${d}"
- ${MV_MOZ_LNK} && cp -RPl -- "${x}"/* "${D}${d}" || {
- ${MV_MOZ_LNK} && \
- ewarn 'Failed to hardlink extension. Falling back to USE=copy-extensions'
+ cp -RPl -- "${x}"/* "${D}${d}" || {
+ ewarn 'Failed to hardlink extension. Falling back to USE=copy-extensions'
insinto "${d}" && doins -r "${x}"/*
- } || {
- ${MV_MOZ_LNK} && \
- die 'failed to copy extension. Please retry emerging with USE=copy-extensions'
- die 'failed to copy extension'
- }
+ } || die 'failed to copy extension'
}
# This function is called by mv_mozextension_src_install
@@ -270,3 +147,10 @@ xpi_install_dirs() {
do [ -n "${d}" ] && test -d "${d}" && xpi_install "${d}"
done
}
+
+mv_mozextension_install() {
+ local MOZILLA_EXTENSIONS_DIRECTORY
+ use_if_iuse "${1}" || return 0
+ MOZILLA_EXTENSIONS_DIRECTORY=${2}
+ xpi_install_dirs
+}
diff --git a/profiles/use.desc b/profiles/use.desc
index b0df0279..337f6fe5 100644
--- a/profiles/use.desc
+++ b/profiles/use.desc
@@ -1,2 +1,4 @@
-copy-extensions - Copy extensions for each firefox/seamonkey separately instead of using hardlinks. This may be necessary if you have e.g. /opt and /usr on different partitions or if cp -RPl is not supported by your system.
-symlink-extensions - Use symlinks for extensions of firefox/seamonkey instead of hardlinks or copies. This may require to remove ~/.mozilla/*/*/extensions.ini at each restart of the browser.
+firefox - Install extension for www-client/firefox
+firefox-bin - Install extension for the www-client/firefox-bin
+seamonkey - Install extension for the www-client/seamonkey
+seamonkey-bin - Install extension for the www-client/seamonkey-bin
diff --git a/sci-mathematics/reduce/ChangeLog b/sci-mathematics/reduce/ChangeLog
new file mode 100644
index 00000000..419d2f06
--- /dev/null
+++ b/sci-mathematics/reduce/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/reduce
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*reduce-20141130.ebuild (24 Jan 2015)
+
+ 24 Jan 2015; Martin Väth <martin@mvath.de>:
+ Copy from gentoo tree to version bump to a snapshot which at least compiles.
+ Adapt URL and $S to snapshot version numbering. Bump EAPI, add epatch_user.
+ Clear previous ChangeLog
diff --git a/sci-mathematics/reduce/Manifest b/sci-mathematics/reduce/Manifest
new file mode 100644
index 00000000..77447adb
--- /dev/null
+++ b/sci-mathematics/reduce/Manifest
@@ -0,0 +1 @@
+DIST reduce-src-2014-11-30.tar.bz2 253343100 SHA256 b15debc944475d4daee1bcbdbaff415693522306785507f2d3110d75df6e7006 SHA512 46dfead80b2778b37ac723343d2922d00a48f4bd5ca7d92c14039abd880cd1b0b3276c660e9ee443cdc6383e42448479893411360bfdbe2a239e11a780d6672b WHIRLPOOL ef020a09dd23794d7363062d96ae18b35d622b27549790b19addc84292fa78fbcb687312dcc7449c9f6844d041a6d5e14430ecf33ce9696495c7d0c0219860c6
diff --git a/sci-mathematics/reduce/files/64reduce-gentoo.el b/sci-mathematics/reduce/files/64reduce-gentoo.el
new file mode 100644
index 00000000..2c20bff9
--- /dev/null
+++ b/sci-mathematics/reduce/files/64reduce-gentoo.el
@@ -0,0 +1,4 @@
+;; site-init for sci-mathematics/reduce
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'reduce-mode "reduce-mode" "Major mode for REDUCE code editing" t)
+(add-to-list 'auto-mode-alist '("\\.red\\'" . reduce-mode))
diff --git a/sci-mathematics/reduce/files/csl b/sci-mathematics/reduce/files/csl
new file mode 100755
index 00000000..895b6bd8
--- /dev/null
+++ b/sci-mathematics/reduce/files/csl
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/lib/reduce/csl $*
diff --git a/sci-mathematics/reduce/files/redcsl b/sci-mathematics/reduce/files/redcsl
new file mode 100755
index 00000000..ff40e3e0
--- /dev/null
+++ b/sci-mathematics/reduce/files/redcsl
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/lib/reduce/reduce $*
diff --git a/sci-mathematics/reduce/metadata.xml b/sci-mathematics/reduce/metadata.xml
new file mode 100644
index 00000000..523cb94a
--- /dev/null
+++ b/sci-mathematics/reduce/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription lang="en">
+A general-purpose computer algebra system.
+Powerful, mature and efficient.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/reduce/reduce-20141130.ebuild b/sci-mathematics/reduce/reduce-20141130.ebuild
new file mode 100644
index 00000000..b20f8863
--- /dev/null
+++ b/sci-mathematics/reduce/reduce-20141130.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit elisp-common eutils multilib
+
+DESCRIPTION="A general-purpose computer algebra system"
+HOMEPAGE="http://reduce-algebra.sourceforge.net/
+ http://reduce-algebra.com/"
+IUSE="doc emacs gnuplot X"
+PVyear=${PV%????}
+PVday=${PV#??????}
+PVmonth=${PV#????}
+PVmonth=${PVmonth%??}
+mPV="${PVyear}-${PVmonth}-${PVday}"
+TARBALL="${PN}-src-${mPV}"
+SRC_URI="mirror://sourceforge/${PN}-algebra/Snapshot_${mPV}/${TARBALL}.tar.bz2"
+LICENSE="BSD-2 X? ( LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${TARBALL}"
+
+RDEPEND="X? ( x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXft )
+ gnuplot? ( sci-visualization/gnuplot )
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # If you pass --prefix to this damn configure,
+ # make (not make install!) will try to install stuff
+ # into the live file system => sandbox violation
+ # Therefore, I cannot use econf here
+ # Also, make calls configure in maintainer mode in subdirs *by design*
+ # The trunk sucks less => WONTFIX until the next release
+ ./configure --with-csl $(use_with X gui)
+ # psl build requires Internet connection at build time
+ # we cannot support it
+}
+
+src_compile() {
+ emake -j1 STRIP=true
+
+ pushd cslbuild/*/csl/reduce.doc > /dev/null
+ rm -f *.txt *.tex
+ popd > /dev/null
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile generic/emacs/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake -j1 testall || die "emake testall failed"
+}
+
+src_install() {
+ local lib="$(get_libdir)"
+ dodoc README BUILDING DEPENDENCY_TRACKING
+ pushd bin > /dev/null
+ cp "${FILESDIR}"/redcsl "${FILESDIR}"/csl .
+ sed -e "s/lib/${lib}/" -i redcsl
+ sed -e "s/lib/${lib}/" -i csl
+ exeinto /usr/bin
+ doexe redcsl csl
+ popd > /dev/null
+
+ pushd cslbuild/*/csl > /dev/null
+ exeinto /usr/${lib}/${PN}
+ doexe reduce csl
+ insinto /usr/$(get_libdir)/${PN}
+ doins reduce.img csl.img
+ insinto /usr/share/${PN}
+ doins -r ${PN}.doc
+ mv "${D}"usr/share/${PN}/${PN}.doc "${D}"usr/share/${PN}/doc
+ dosym /usr/share/${PN}/doc /usr/${lib}/${PN}/${PN}.doc
+ if use X; then
+ doins -r ${PN}.fonts
+ mv "${D}"usr/share/${PN}/${PN}.fonts "${D}"usr/share/${PN}/fonts
+ dosym /usr/share/${PN}/fonts /usr/${lib}/${PN}/${PN}.fonts
+ fi
+ popd > /dev/null
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/util/r38.pdf
+ fi
+
+ if use emacs; then
+ pushd generic/emacs > /dev/null
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/64${PN}-gentoo.el"
+ popd > /dev/null
+ fi
+}
diff --git a/www-plugins/classic-theme-restorer/ChangeLog b/www-plugins/classic-theme-restorer/ChangeLog
index 989d93ad..693f1bc5 100644
--- a/www-plugins/classic-theme-restorer/ChangeLog
+++ b/www-plugins/classic-theme-restorer/ChangeLog
@@ -1,7 +1,17 @@
-# ChangeLog for www-plugins/duckduckgo
+# ChangeLog for www-plugins/classic-theme-restorer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*classic-theme-restorer-1.2.9 (25 Jan 2015)
+
+ 25 Jan 2015; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
+*classic-theme-restorer-1.2.8.2 (02 Jan 2015)
+
+ 02 Jan 2015; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
*classic-theme-restorer-1.2.6.1 (28 Nov 2014)
28 Nov 2014; Martin Väth <martin@mvath.de>:
diff --git a/www-plugins/classic-theme-restorer/Manifest b/www-plugins/classic-theme-restorer/Manifest
index 8fece205..bbc67948 100644
--- a/www-plugins/classic-theme-restorer/Manifest
+++ b/www-plugins/classic-theme-restorer/Manifest
@@ -1 +1 @@
-DIST classic_theme_restorer_customize_ui-1.2.8.2-fx.xpi 433727 SHA256 b0f2f78279c243df9446a505ecd14be66add58eb161168d9567c788b37a5894e SHA512 39dd51b56942693dadbd79ba821a761948ea01a31f4ad2f84d6b4c94eeabb4e8a0c3a60c960466329681f2eb4e9dbf7fb4344f34613744f19a2b115244aa10e3 WHIRLPOOL 7003220a7afa9be1f8ee3726c57e6a21154f60f2d48e98a1fb241ef61cd2c49da053da760ca645a9cca7e11f9aaf4a60e2a45435c3fe1d129071819444fcb43e
+DIST classic_theme_restorer_customize_ui-1.2.9-fx.xpi 447488 SHA256 7bef63a23ea09ec2f66f888b2ceff55779cb31b5d1edd5ce4c8ec95f7cdfce18 SHA512 3a0511503d90d1b4149a3e4b0c2dbf48dd220d3cb7437f67b0c2861949cc30af56e7671280dcaa07f4ee655c41bdd327fa926e2ad7fa0abb3bfd67639c6547e3 WHIRLPOOL 316489a379da7f33fb517b7b93349cd5b5d3868eba59ce6138f56bb3b64ebe35f26a50232b3f5fcc6434f41d463832029b5915000dec0e58098dc7dd625c0c48
diff --git a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.8.2.ebuild b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.9.ebuild
index 6bb4d8de..6bb4d8de 100644
--- a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.8.2.ebuild
+++ b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.9.ebuild