aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-02-23 22:17:26 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2018-02-23 22:17:26 -0800
commit733906ecdaaf034bf01f3d5f08c43dc18260fe38 (patch)
tree9365f704b2bfea0b6d9ab441bfe2c33877032f74 /Makefile
parentgitignore: root ignores to checkout root (diff)
downloadtyrian-theme-733906ecdaaf034bf01f3d5f08c43dc18260fe38.tar.gz
tyrian-theme-733906ecdaaf034bf01f3d5f08c43dc18260fe38.tar.bz2
tyrian-theme-733906ecdaaf034bf01f3d5f08c43dc18260fe38.zip
Docker: add way to build without polluting local system.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..074e3ee
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,35 @@
+all: assets
+
+.PHONY: all assets docker-build docker-run
+
+TS = $(shell date -u +%Y%m%d-%H%M%S)
+TAG_TS = $(REPO):$(TS)
+TAG_LATEST = $(REPO):latest
+
+REPO = git.gentoo.org/sites/tyrian-theme
+PWD = $(shell pwd)
+CACHEDIR_EXT = $(PWD)/npm-cacache
+CACHEDIR_VOL = /root/.npm/_cacache/
+
+REPO_EXT = $(PWD)
+REPO_VOL = /repo
+
+assets: docker-run
+
+docker-build:
+ docker build \
+ -t $(TAG_LATEST) \
+ -t $(TAG_TS) \
+ docker/
+
+docker-run: docker-build
+ @mkdir -p $(CACHEDIR_EXT)
+ docker run \
+ --volume $(REPO_EXT):$(REPO_VOL) \
+ --volume $(CACHEDIR_EXT):$(CACHEDIR_VOL) \
+ $(REPO):latest
+
+docker-clean-images:
+ docker rmi $(shell docker images "git.gentoo.org/sites/tyrian-theme" --filter before=git.gentoo.org/sites/tyrian-theme:latest --format '{{.Repository}}:{{.Tag}}')
+docker-clean-container:
+ docker rm $(shell docker ps --filter "ancestor=git.gentoo.org/sites/tyrian-theme" -a -q --no-trunc)