aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/mixxx/Manifest3
-rw-r--r--media-sound/mixxx/files/drop-mixxx-test.patch194
-rw-r--r--media-sound/mixxx/mixxx-9999.ebuild1
3 files changed, 197 insertions, 1 deletions
diff --git a/media-sound/mixxx/Manifest b/media-sound/mixxx/Manifest
index 6e2bac3..3940456 100644
--- a/media-sound/mixxx/Manifest
+++ b/media-sound/mixxx/Manifest
@@ -1,4 +1,5 @@
+AUX drop-mixxx-test.patch 6540 BLAKE2B 63de950b2555c58ed5c70c8cf6c0c50c97a98c3f7aac0873f9d12b131bef29836d70650c2cc5154b1d890e3c20d89d5d70d0dc7ddfc7977d084e24b3c5d163d9 SHA512 c5790b626c43573d23c524d9280031f157e0a0e3fa9ff6e4bd0c480a25c0a0b95e0598a4a137ee7361ca09df0144ae0d7c41b80aab8ccaaa1bd149e8d745e71f
AUX mixxx-9999-docs.patch 1043 BLAKE2B bfdb51de701e279f841de83cce6bccd613feaaeb7ffe2e209f357837d52d6cbf2ab452916752f8e6f8cec635a39e0efa5d1f7a921d76d8d093876584151fc35b SHA512 8be44f7d286c5fe6cabbd64d9294f72aada7fb3bfdeb8d0787772e131e48642698bdf0fd1975f8a385a5e76508889464e4c4f0f377b0c60f61fc967ee647e661
AUX mixxx-9999-gentoo-build.patch 651 BLAKE2B 7f20c41fa4bf89be5e1e8dff28daf9d72e5ef20f2e71fcde97504cad4de50dd40af83fa5542bba6a1e156d9fe31e3c39486f9b2494c4855e890f3aa43d606768 SHA512 490309a7d49f385d75b54acbc155ec0e011e7f7753a7b876c123d521dc32659172c5e3354ceff47251746807b8182792ba3ee1e26bbe907dc7c99f7ab6d7c99f
-EBUILD mixxx-9999.ebuild 2764 BLAKE2B 376e42b36aa436d8dbf54cf31894b69c23c0154c6608d080a088028dfe3adc8285d1723fc5d5707bfeee44238b4b84f6a39bcd229004e983e27a7e19911c569b SHA512 b51bbe7d43b2e44d83f10179995341cf41569f57157e085cf0c8baec999bd9998a8d359918e8ddee14cc96bf403e79bb04cda32dcd3c7710403157cf4fbf7c27
+EBUILD mixxx-9999.ebuild 2801 BLAKE2B 8e171b776bc7e9beae0fd3d817519c3a53c7c153d8156b3382aee5e5993b4319c8529aaf6718c28310c7c4dc6555cf3b0b610f958bbb2d6bc815130822529728 SHA512 6185bc920410d00f67e5eb0d6790209b482b8e0d46f27532d41a1341b0ee18ee4d3728e7320eb7f440ca2574f7bcfaf89ef51f98e319be16a6896b690626c1f4
MISC metadata.xml 849 BLAKE2B 68fcb8b3e3353ad0c99ff9532c5b098738addbe5f3965bc931d5555f0110ee3b4a39514ae471881d8a4b0270d4257e502bd82d9010b235394ae3d0daf2ba4089 SHA512 eb222405a3de8c013d44b2fb114d42f32d54651309ec66176433ad055937a45d4dc7cc2cf3075a413ba508348100f74bd4c06ac77fc7960fbcf915d86bb02336
diff --git a/media-sound/mixxx/files/drop-mixxx-test.patch b/media-sound/mixxx/files/drop-mixxx-test.patch
new file mode 100644
index 0000000..4cce055
--- /dev/null
+++ b/media-sound/mixxx/files/drop-mixxx-test.patch
@@ -0,0 +1,194 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 278fca7b27..dbc451862c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1567,172 +1567,6 @@ add_subdirectory(
+ "${CMAKE_CURRENT_BINARY_DIR}/lib/googletest"
+ )
+
+-add_executable(mixxx-test
+- src/test/analyserwaveformtest.cpp
+- src/test/analyzersilence_test.cpp
+- src/test/audiotaperpot_test.cpp
+- src/test/autodjprocessor_test.cpp
+- src/test/beatgridtest.cpp
+- src/test/beatmaptest.cpp
+- src/test/beatstest.cpp
+- src/test/beatstranslatetest.cpp
+- src/test/bpmtest.cpp
+- src/test/bpmcontrol_test.cpp
+- src/test/broadcastprofile_test.cpp
+- src/test/broadcastsettings_test.cpp
+- src/test/cache_test.cpp
+- src/test/channelhandle_test.cpp
+- src/test/colorconfig_test.cpp
+- src/test/colormapperjsproxy_test.cpp
+- src/test/colorpalette_test.cpp
+- src/test/configobject_test.cpp
+- src/test/controller_mapping_validation_test.cpp
+- src/test/controllerscriptenginelegacy_test.cpp
+- src/test/controlobjecttest.cpp
+- src/test/coreservicestest.cpp
+- src/test/coverartcache_test.cpp
+- src/test/coverartutils_test.cpp
+- src/test/cratestorage_test.cpp
+- src/test/cue_test.cpp
+- src/test/cuecontrol_test.cpp
+- src/test/dbconnectionpool_test.cpp
+- src/test/dbidtest.cpp
+- src/test/directorydaotest.cpp
+- src/test/duration_test.cpp
+- src/test/durationutiltest.cpp
+- #TODO: write useful tests for refactored effects system
+- #src/test/effectchainslottest.cpp
+- src/test/enginebufferscalelineartest.cpp
+- src/test/enginebuffertest.cpp
+- src/test/enginefilterbiquadtest.cpp
+- src/test/enginemastertest.cpp
+- src/test/enginemicrophonetest.cpp
+- src/test/enginesynctest.cpp
+- src/test/fileinfo_test.cpp
+- src/test/frametest.cpp
+- src/test/globaltrackcache_test.cpp
+- src/test/hotcuecontrol_test.cpp
+- src/test/imageutils_test.cpp
+- src/test/indexrange_test.cpp
+- src/test/keyutilstest.cpp
+- src/test/lcstest.cpp
+- src/test/learningutilstest.cpp
+- src/test/libraryscannertest.cpp
+- src/test/librarytest.cpp
+- src/test/looping_control_test.cpp
+- src/test/main.cpp
+- src/test/mathutiltest.cpp
+- src/test/metadatatest.cpp
+- #TODO: make this build again
+- #src/test/metaknob_link_test.cpp
+- src/test/midicontrollertest.cpp
+- src/test/mixxxtest.cpp
+- src/test/movinginterquartilemean_test.cpp
+- src/test/nativeeffects_test.cpp
+- src/test/performancetimer_test.cpp
+- src/test/playcountertest.cpp
+- src/test/playlisttest.cpp
+- src/test/portmidicontroller_test.cpp
+- src/test/portmidienumeratortest.cpp
+- src/test/queryutiltest.cpp
+- src/test/rangelist_test.cpp
+- src/test/readaheadmanager_test.cpp
+- src/test/replaygaintest.cpp
+- src/test/rescalertest.cpp
+- src/test/rgbcolor_test.cpp
+- src/test/samplebuffertest.cpp
+- src/test/sampleutiltest.cpp
+- src/test/schemamanager_test.cpp
+- src/test/searchqueryparsertest.cpp
+- src/test/seratobeatgridtest.cpp
+- src/test/seratomarkerstest.cpp
+- src/test/seratomarkers2test.cpp
+- src/test/seratotagstest.cpp
+- src/test/signalpathtest.cpp
+- src/test/skincontext_test.cpp
+- src/test/softtakeover_test.cpp
+- src/test/soundproxy_test.cpp
+- src/test/soundsourceproviderregistrytest.cpp
+- src/test/sqliteliketest.cpp
+- src/test/synccontroltest.cpp
+- src/test/tableview_test.cpp
+- src/test/taglibtest.cpp
+- src/test/trackdao_test.cpp
+- src/test/trackexport_test.cpp
+- src/test/trackmetadata_test.cpp
+- src/test/tracknumberstest.cpp
+- src/test/trackreftest.cpp
+- src/test/trackupdate_test.cpp
+- src/test/uuid_test.cpp
+- src/test/wbatterytest.cpp
+- src/test/wpushbutton_test.cpp
+- src/test/wwidgetstack_test.cpp
+-)
+-set_target_properties(mixxx-test PROPERTIES AUTOMOC ON)
+-target_link_libraries(mixxx-test PRIVATE mixxx-lib mixxx-gitinfostore gtest gmock)
+-
+-#
+-# Benchmark tests
+-#
+-
+-# Disable testing of google/benchmark
+-set(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
+-
+-# Prevent installation of google/benchmark artifacts
+-set(BENCHMARK_ENABLE_INSTALL OFF CACHE BOOL "Disable installation of google/benchmark" FORCE)
+-
+-add_subdirectory(
+- "${CMAKE_CURRENT_SOURCE_DIR}/lib/benchmark"
+- "${CMAKE_CURRENT_BINARY_DIR}/lib/benchmark"
+-)
+-target_link_libraries(mixxx-test PRIVATE benchmark)
+-
+-# Test Suite
+-include(CTest)
+-include(GoogleTest)
+-enable_testing()
+-gtest_add_tests(
+- TARGET mixxx-test
+- EXTRA_ARGS --logLevel info
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+- TEST_LIST testsuite
+-)
+-if (NOT WIN32)
+- # Default to offscreen rendering during tests.
+- # This is required if the build system like Fedora koji/mock does not
+- # allow to pass environment variables into the ctest macro expansion.
+- set_tests_properties(${testsuite} PROPERTIES ENVIRONMENT "QT_QPA_PLATFORM=offscreen")
+-endif()
+-
+-# Benchmarking
+-add_custom_target(mixxx-benchmark
+- COMMAND $<TARGET_FILE:mixxx-test> --benchmark
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+- COMMENT "Mixxx Benchmarks"
+- VERBATIM
+-)
+-add_dependencies(mixxx-benchmark mixxx-test)
+-
+-if(UNIX AND USE_SYMLINKS)
+- add_custom_target(mixxx-testdata
+- COMMAND ${CMAKE_COMMAND} -E create_symlink "${CMAKE_CURRENT_SOURCE_DIR}/src/test" "${CMAKE_CURRENT_BINARY_DIR}/src/test"
+- COMMENT "Symlinking test data to build directory..."
+- )
+-elseif(WIN32)
+- file(TO_NATIVE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/src/test" CMAKE_CURRENT_SOURCE_TESTDATA_DIR_NATIVE)
+- file(TO_NATIVE_PATH "${CMAKE_CURRENT_BINARY_DIR}/src/test/" CMAKE_CURRENT_BINARY_TESTDATA_DIR_NATIVE)
+- add_custom_target(mixxx-testdata
+- COMMAND xcopy ${CMAKE_CURRENT_SOURCE_TESTDATA_DIR_NATIVE} ${CMAKE_CURRENT_BINARY_TESTDATA_DIR_NATIVE} /s /d /q /y
+- COMMENT "Copying missing or modified test data files to build directory..."
+- )
+-else()
+- add_custom_target(mixxx-testdata
+- COMMAND ${CMAKE_COMMAND} -E copy_directory "${CMAKE_CURRENT_SOURCE_DIR}/src/test" "${CMAKE_CURRENT_BINARY_DIR}/src/test"
+- COMMENT "Copying all test data files to build directory..."
+- )
+-endif()
+-add_dependencies(mixxx-test mixxx-testdata)
+-
+ #
+ # Resources
+ #
+@@ -1762,8 +1596,6 @@ endif()
+
+ target_sources(mixxx PRIVATE res/mixxx.qrc)
+ set_target_properties(mixxx PROPERTIES AUTORCC ON)
+-target_sources(mixxx-test PRIVATE res/mixxx.qrc)
+-set_target_properties(mixxx-test PROPERTIES AUTORCC ON)
+
+ if (MIXXX_VERSION_PRERELEASE STREQUAL "")
+ set(MIXXX_VERSION "${CMAKE_PROJECT_VERSION}")
+@@ -2604,7 +2436,6 @@ if(LILV)
+ )
+ target_compile_definitions(mixxx-lib PUBLIC __LILV__)
+ target_link_libraries(mixxx-lib PRIVATE lilv::lilv)
+- target_link_libraries(mixxx-test PRIVATE lilv::lilv)
+ endif()
+
+ # Live Broadcasting (Shoutcast)
diff --git a/media-sound/mixxx/mixxx-9999.ebuild b/media-sound/mixxx/mixxx-9999.ebuild
index 322c7b6..5ae2f1d 100644
--- a/media-sound/mixxx/mixxx-9999.ebuild
+++ b/media-sound/mixxx/mixxx-9999.ebuild
@@ -84,6 +84,7 @@ BDEPEND="virtual/pkgconfig
PATCHES=(
"${FILESDIR}"/mixxx-9999-docs.patch
"${FILESDIR}"/mixxx-9999-gentoo-build.patch
+ "${FILESDIR}"/drop-mixxx-test.patch
)
src_prepare() {