From 45c94b1f058575827bef6696f93ec8d6bdc33404 Mon Sep 17 00:00:00 2001
From: Matthew Thode <prometheanfire@gentoo.org>
Date: Mon, 11 Oct 2021 09:27:29 -0500
Subject: www-apps/icingaweb2: 2.8.3 / 2.8.4 clean up

Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
---
 www-apps/icingaweb2/Manifest                |  2 -
 www-apps/icingaweb2/icingaweb2-2.8.3.ebuild | 77 -----------------------------
 www-apps/icingaweb2/icingaweb2-2.8.4.ebuild | 77 -----------------------------
 3 files changed, 156 deletions(-)
 delete mode 100644 www-apps/icingaweb2/icingaweb2-2.8.3.ebuild
 delete mode 100644 www-apps/icingaweb2/icingaweb2-2.8.4.ebuild

(limited to 'www-apps')

diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index a53777cd1d59..321c373425f5 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,3 +1 @@
-DIST icingaweb2-2.8.3.tar.gz 8514052 BLAKE2B 507753833ed8a0de816651f3fdb06f3fdf04b3fa9c43fad5046c28924c93f3c3e491d9a4e1532f08ac0d6abe97c1343b85cdb23de9ece9f16858b91886283e9c SHA512 236385dc54dbd11d8e100059bb7e29b3a4efc23888f187e13e563510dfb1f3d20e5c4107e2dadfa6842e6689aaa21d4e9465abd0a234c52229354f43ec44cfb4
-DIST icingaweb2-2.8.4.tar.gz 8514585 BLAKE2B 1c331d45152a94dcaf21509e36ecd9c90c840f41bf14d102910e65fce28994bb7db3319c39e5d5740638a673c74b84b54d803b97d91cb8968260174b2437a7ca SHA512 7f136f7901db8398fab85fef079d4e5af1662c13c5c107d3c1c10e022186bdca29d3b144f937e40e470975b97bd98215ec3e0c7f2b6127a6a74143fbe0e1882c
 DIST icingaweb2-2.9.3.tar.gz 12307606 BLAKE2B fddd72823674ae64191bf55f0dc378ef50cd7849a18199310fbe25446aff3e0c325b20aa0244c751b07852d3cca81ecdaba02c3250eb77b36645829d7da61377 SHA512 46ae2790743fb5e0a80861da522cfa2783d181ec056135e97949fffbc3ca821f778033db9e276e824430a6b7a1dd842f387b599fa70072e63fb6ebd74dd2bfc0
diff --git a/www-apps/icingaweb2/icingaweb2-2.8.3.ebuild b/www-apps/icingaweb2/icingaweb2-2.8.3.ebuild
deleted file mode 100644
index 8ce454622665..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.8.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache multilib
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
-	EGIT_BRANCH="master"
-else
-	SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
-	KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
-		dev-php/pecl-imagick
-		pdf? ( media-gfx/imagemagick[png] )
-		apache2-server? ( >=www-servers/apache-2.4.0 )
-		nginx? ( >=www-servers/nginx-1.7.0:* )
-		|| (
-			dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-			dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-		)
-		acct-group/icingacmd
-		acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
-	depend.apache_pkg_setup
-
-	use nginx && usermod -a -G icingacmd,icingaweb2 nginx
-	use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
-	if [[ -d /etc/icingaweb2 ]] ; then
-		einfo "Updating existing installation ..."
-	else
-		einfo "Running first time setup ..."
-		einfo "Creating configuration directory ..."
-		/usr/share/${PN}/bin/icingacli setup config directory
-		einfo "Creating authentication token for web setup ..."
-		/usr/share/${PN}/bin/icingacli setup token create
-		if use apache2 ; then
-			einfo "The following might be useful for your Apache2 configuration:"
-			/usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
-		fi
-		if use nginx ; then
-			einfo "The following might be useful for your NGinx configuration:"
-			/usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
-		fi
-	fi
-	einfo "All done."
-}
-
-src_install() {
-	insinto "/usr/share/${PN}"
-	doins -r "${S}"/*
-	fperms -R a+rX "/usr/share/${PN}/public/"
-	fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
-	einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}
diff --git a/www-apps/icingaweb2/icingaweb2-2.8.4.ebuild b/www-apps/icingaweb2/icingaweb2-2.8.4.ebuild
deleted file mode 100644
index c5f119e375d9..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.8.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache multilib
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
-	EGIT_BRANCH="master"
-else
-	SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
-	KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
-		dev-php/pecl-imagick
-		pdf? ( media-gfx/imagemagick[png] )
-		apache2-server? ( >=www-servers/apache-2.4.0 )
-		nginx? ( >=www-servers/nginx-1.7.0:* )
-		|| (
-			dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-			dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-		)
-		acct-group/icingacmd
-		acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
-	depend.apache_pkg_setup
-
-	use nginx && usermod -a -G icingacmd,icingaweb2 nginx
-	use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
-	if [[ -d /etc/icingaweb2 ]] ; then
-		einfo "Updating existing installation ..."
-	else
-		einfo "Running first time setup ..."
-		einfo "Creating configuration directory ..."
-		/usr/share/${PN}/bin/icingacli setup config directory
-		einfo "Creating authentication token for web setup ..."
-		/usr/share/${PN}/bin/icingacli setup token create
-		if use apache2 ; then
-			einfo "The following might be useful for your Apache2 configuration:"
-			/usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
-		fi
-		if use nginx ; then
-			einfo "The following might be useful for your NGinx configuration:"
-			/usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
-		fi
-	fi
-	einfo "All done."
-}
-
-src_install() {
-	insinto "/usr/share/${PN}"
-	doins -r "${S}"/*
-	fperms -R a+rX "/usr/share/${PN}/public/"
-	fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
-	einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}
-- 
cgit v1.2.3-65-gdbad