From 9eea406c026857180757867c4caeef387e5f87a5 Mon Sep 17 00:00:00 2001
From: Ionen Wolkens <ionen@gentoo.org>
Date: Tue, 10 Oct 2023 14:54:12 -0400
Subject: games-emulation/fceux: drop 2.6.5

Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
---
 games-emulation/fceux/Manifest                     |  1 -
 games-emulation/fceux/fceux-2.6.5.ebuild           | 67 ----------------------
 .../fceux/files/fceux-2.4.0-gcc13.patch            | 31 ----------
 3 files changed, 99 deletions(-)
 delete mode 100644 games-emulation/fceux/fceux-2.6.5.ebuild
 delete mode 100644 games-emulation/fceux/files/fceux-2.4.0-gcc13.patch

(limited to 'games-emulation')

diff --git a/games-emulation/fceux/Manifest b/games-emulation/fceux/Manifest
index 9a97745ee2a1..c93865135f62 100644
--- a/games-emulation/fceux/Manifest
+++ b/games-emulation/fceux/Manifest
@@ -1,2 +1 @@
-DIST fceux-2.6.5.tar.gz 23299626 BLAKE2B 167fbe401635b96ad0c1c07826b1e7b032fa66806a2c395aebcae9d2b4295a327d2abad960a883751da43baf49f91276dd6521692406ce610df7c1ce167006ca SHA512 3d37583d1917783513f05bd215437401aacda3bd1930238212cbbdd6ba105236028066d7198bfd8182e6d55ded7ce293f1e5d23295d2b730ec800dc5e5652598
 DIST fceux-2.6.6.tar.gz 23330274 BLAKE2B 4d7779af0afc5fa12d3734d282f92b105757d204c69091b4e3574e4ced6179c5e202b752225f412d68331c9866c63b626703b014835d398ca1262deeb0d32654 SHA512 0a6cff4c6b900569978003675812d92d893281c2bdf3b0b58c07e257251648ee325f9bb29b01253ab1a5e9354631d91a6e67a1e6bb36ebe89d5067509cabfa64
diff --git a/games-emulation/fceux/fceux-2.6.5.ebuild b/games-emulation/fceux/fceux-2.6.5.ebuild
deleted file mode 100644
index 16ff86085b5c..000000000000
--- a/games-emulation/fceux/fceux-2.6.5.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-1 )
-inherit cmake lua-single xdg
-
-DESCRIPTION="Portable Famicom/NES emulator, an evolution of the original FCE Ultra"
-HOMEPAGE="https://fceux.com/"
-SRC_URI="https://github.com/TASEmulators/fceux/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ffmpeg qt6 x264 x265"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
-	${LUA_DEPS}
-	qt6? ( dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only] )
-	!qt6? (
-		dev-qt/qtcore:5
-		dev-qt/qtgui:5
-		dev-qt/qtopengl:5[-gles2-only]
-		dev-qt/qtwidgets:5
-	)
-	media-libs/libglvnd
-	media-libs/libsdl2[joystick,sound,threads,video]
-	sys-libs/zlib:=[minizip]
-	ffmpeg? ( media-video/ffmpeg:= )
-	x264? ( media-libs/x264:= )
-	x265? ( media-libs/x265:= )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-	"${FILESDIR}"/${PN}-2.4.0-desktop.patch
-	"${FILESDIR}"/${PN}-2.4.0-no-git.patch
-	"${FILESDIR}"/${PN}-2.4.0-gcc13.patch
-)
-
-src_prepare() {
-	cmake_src_prepare
-
-	use x264 || sed -i '/pkg_check_modules.*X264/d' src/CMakeLists.txt || die
-	use x265 || sed -i '/pkg_check_modules.*X265/d' src/CMakeLists.txt || die
-	use ffmpeg || sed -i '/pkg_check_modules.*LIBAV/d' src/CMakeLists.txt || die
-}
-
-src_configure() {
-	local mycmakeargs=(
-		-DPUBLIC_RELEASE=yes
-		-DQT6=$(usex qt6)
-	)
-
-	cmake_src_configure
-}
-
-src_install() {
-	local DOCS=( README TODO-SDL changelog.txt documentation/. readme.md )
-	cmake_src_install
-
-	# remove unused/duplicate files
-	rm "${ED}"/usr/share/fceux/{lua5{1,.1}.dll,{fceux,taseditor}.chm} \
-		"${ED}"/usr/share/doc/${PF}/fceux{,-net-server}.6 \
-		"${ED}"/usr/share/man/man6/fceux-net-server.6 || die
-}
diff --git a/games-emulation/fceux/files/fceux-2.4.0-gcc13.patch b/games-emulation/fceux/files/fceux-2.4.0-gcc13.patch
deleted file mode 100644
index 5e6348281654..000000000000
--- a/games-emulation/fceux/files/fceux-2.4.0-gcc13.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://github.com/TASEmulators/fceux/pull/629
-
-From 6ad3837eebdab597da693a39068b2c05716282be Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 10 Apr 2023 05:18:41 +0100
-Subject: [PATCH] Fix build with GCC 13
-
-GCC 13 (as usual for new compiler releases) shuffles around some internal includes and so etc is no longer transitively included:
-```
-In file included from /var/tmp/portage/games-emulation/fceux-2.6.5/work/fceux-2.6.5/src/drivers/Qt/AboutWindow.cpp:33:
-/usr/include/x264.h:40:4: warning: #warning You must include stdint.h or inttypes.h before x264.h [-Wcpp]
-   40 | #  warning You must include stdint.h or inttypes.h before x264.h
-      |    ^~~~~~~
-/usr/include/x264.h:127:5: error: uint8_t does not name a type
-  127 |     uint8_t *p_payload;
-      |     ^~~~~~~
-```
-
-See https://gnu.org/software/gcc/gcc-13/porting_to.html.
-
-Bug: https://bugs.gentoo.org/900611
---- a/src/drivers/Qt/AboutWindow.cpp
-+++ b/src/drivers/Qt/AboutWindow.cpp
-@@ -30,6 +30,7 @@
- #endif
- 
- #ifdef _USE_X264
-+#include <cstdint>
- #include "x264.h"
- #endif
- 
-- 
cgit v1.2.3-65-gdbad