From 5008365b8661b5e456609b0ac414a3f7b3f0fbd8 Mon Sep 17 00:00:00 2001
From: Nick Sarnie <sarnex@gentoo.org>
Date: Sat, 25 Sep 2021 20:31:46 -0400
Subject: app-emulation/wine-mono: Sync with ::wine

Package-Manager: Portage-3.0.23, Repoman-3.0.3
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
---
 app-emulation/wine-mono/Manifest               |  2 ++
 app-emulation/wine-mono/wine-mono-6.4.0.ebuild | 29 ++++++++++++++++++++++++++
 2 files changed, 31 insertions(+)
 create mode 100644 app-emulation/wine-mono/wine-mono-6.4.0.ebuild

(limited to 'app-emulation')

diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index 6894124848d7..6f3b8ee20da6 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -4,3 +4,5 @@ DIST wine-mono-6.2.0-x86.msi 87498240 BLAKE2B f7e20876732cbdfc472d5f850b167feceb
 DIST wine-mono-6.2.0-x86.tar.xz 43071332 BLAKE2B f334600697375757c734ff22274665b3bc1cb7495d465e1d209b240b9b2aafdd93f9f246f5415e9f36526bceee6066a13fe01a81d93779dac35687fe0d44f7df SHA512 7e5ed7e4abf88d915d59715b107722135af08bb43e6356f9ae95fdafc539332150a82f85b67d15710ae4ece6c883733bab142f59894f70acd893cac85f6ca905
 DIST wine-mono-6.3.0-x86.msi 86689280 BLAKE2B 5c3cbe92dc055e97fa6dc894659cbd2666bd6a2ae0ee08c998c5326379a205596d89127d22aeabdf73c99aa8e4ade4d5e05663d0a1e1f9f1d322c7c18a4cd4ea SHA512 e71accf7d649c576728a41e9dda5dc9c21e3ebc0330e01be30c1f196bdb2925c5fefb6e9337cc8043f4b42721702dda4dc9224cb7a31e322410f4002d1f84f42
 DIST wine-mono-6.3.0-x86.tar.xz 44392520 BLAKE2B bdaa64005564a134605f924f256a709e40cb713bd1f24f2ac5e82a095e353a81487c74813c88e74ed02905cc23a3bf50e99e908a3536a9671f4920d9093cbe75 SHA512 d39bcbaa65e4299711351516e74d559887b152caa3731cc72bbb23412ed76f5b8cf124c2f46241b677b074277c680120a645f738cdcd840ff60465b20deda3b7
+DIST wine-mono-6.4.0-x86.msi 86398976 BLAKE2B d1d553f6115618744bea65d7e88fdf19bfdf677ad5c948d9d598fe461ad668f778e5a8ae2084c584c9d6dae9bee68b85f9837c20016ab82c2401644dcfa06c1a SHA512 5e0eda47bd73b4f1d2d4017c1e6f1d14c9801067e085e9c991532c50454dd22b6594bd05733b4aae8a1010e8b443ff2bdbe70398880ea569142b33e253892f12
+DIST wine-mono-6.4.0-x86.tar.xz 44177712 BLAKE2B de08e829ade18be0d0896742aa66f3dd9ab96eb0c994ae164f0fc64fb6306dd278714bbea3cd20d9a04625bc502764a875d57fa530489a22d4f69cbe20696cfb SHA512 4e793ab755e3a4b5ff1dd0354756a9635482db6fd98fc90cb710edfd5e1f553e124913e323681bc82827655a5b1056d33c1f9632b5ea1e3e72d547cd780f2d2e
diff --git a/app-emulation/wine-mono/wine-mono-6.4.0.ebuild b/app-emulation/wine-mono/wine-mono-6.4.0.ebuild
new file mode 100644
index 000000000000..b396802d99cc
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-6.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+	!shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+	shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+	insinto /usr/share/wine/mono
+	if use shared; then
+		doins -r "${P}"
+	else
+		doins "${DISTDIR}/${P}-x86.msi"
+	fi
+}
-- 
cgit v1.2.3-65-gdbad