summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth')
-rw-r--r--sys-boot/plymouth/plymouth-0.9.3-r1.ebuild39
-rw-r--r--sys-boot/plymouth/plymouth-0.9.3.ebuild37
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild37
3 files changed, 64 insertions, 49 deletions
diff --git a/sys-boot/plymouth/plymouth-0.9.3-r1.ebuild b/sys-boot/plymouth/plymouth-0.9.3-r1.ebuild
index d73c2b13a9f5..07707fbd471b 100644
--- a/sys-boot/plymouth/plymouth-0.9.3-r1.ebuild
+++ b/sys-boot/plymouth/plymouth-0.9.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -52,23 +52,28 @@ PATCHES=(
"${FILESDIR}"/0.9.3-glibc-sysmacros.patch
)
-src_configure() {
- local myconf
- myconf="--with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-documentation
- --enable-systemd-integration
- --with-systemdunitdir="$(systemd_get_systemunitdir)"
- $(use_enable !static-libs shared)
- $(use_enable static-libs static)
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)"
+src_prepare() {
+ default
eautoreconf
- econf ${myconf}
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-documentation
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ )
+ econf "${myconf[@]}"
}
src_install() {
diff --git a/sys-boot/plymouth/plymouth-0.9.3.ebuild b/sys-boot/plymouth/plymouth-0.9.3.ebuild
index ea9aa1bd7d6b..75326f75a379 100644
--- a/sys-boot/plymouth/plymouth-0.9.3.ebuild
+++ b/sys-boot/plymouth/plymouth-0.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -49,22 +49,27 @@ DOC_CONTENTS="
PATCHES=(
)
-src_configure() {
- local myconf
- myconf="--with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-systemd-integration
- --with-systemdunitdir="$(systemd_get_systemunitdir)"
- $(use_enable !static-libs shared)
- $(use_enable static-libs static)
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)"
+src_prepare() {
+ default
eautoreconf
- econf ${myconf}
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ )
+ econf "${myconf[@]}"
}
src_install() {
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 49ce1012fe83..375f98aabb34 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,22 +50,27 @@ PATCHES=(
"${FILESDIR}"/0.9.3-glibc-sysmacros.patch
)
-src_configure() {
- local myconf
- myconf="--with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-systemd-integration
- --with-systemdunitdir="$(systemd_get_systemunitdir)"
- $(use_enable !static-libs shared)
- $(use_enable static-libs static)
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)"
+src_prepare() {
+ default
eautoreconf
- econf ${myconf}
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ )
+ econf "${myconf[@]}"
}
src_install() {