summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/tensorflow/tensorflow-1.15.0_rc0.ebuild')
-rw-r--r--sci-libs/tensorflow/tensorflow-1.15.0_rc0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/sci-libs/tensorflow/tensorflow-1.15.0_rc0.ebuild b/sci-libs/tensorflow/tensorflow-1.15.0_rc0.ebuild
index e41b07049ea6..0c9fba045c52 100644
--- a/sci-libs/tensorflow/tensorflow-1.15.0_rc0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-1.15.0_rc0.ebuild
@@ -56,8 +56,9 @@ RDEPEND="
app-arch/snappy
dev-db/lmdb
dev-db/sqlite
+ dev-libs/double-conversion
dev-libs/icu
- >=dev-libs/jsoncpp-1.9
+ ~dev-libs/jsoncpp-1.9.1
dev-libs/libpcre
dev-libs/nsync
dev-libs/openssl:0=
@@ -108,7 +109,6 @@ BDEPEND="
dev-python/cython
|| (
=dev-util/bazel-0.24*
- =dev-util/bazel-0.26*
=dev-util/bazel-0.27*
)
cuda? (
@@ -205,6 +205,18 @@ src_configure() {
export TF_CUDNN_VERSION="$(cuda_cudnn_version)"
einfo "Setting CUDA version: $TF_CUDA_VERSION"
einfo "Setting CUDNN version: $TF_CUDNN_VERSION"
+
+ if [[ -z "$TF_CUDA_COMPUTE_CAPABILITIES" ]]; then
+ ewarn "WARNING: Tensorflow is being built with its default CUDA compute capabilities: 3.5 and 7.0."
+ ewarn "These may not be optimal for your GPU."
+ ewarn ""
+ ewarn "To configure Tensorflow with the CUDA compute capability that is optimal for your GPU,"
+ ewarn "set TF_CUDA_COMPUTE_CAPABILITIES in your make.conf, and re-emerge tensorflow."
+ ewarn "For example, to use CUDA capability 7.5 & 3.5, add: TF_CUDA_COMPUTE_CAPABILITIES=7.5,3.5"
+ ewarn ""
+ ewarn "You can look up your GPU's CUDA compute capability at https://developer.nvidia.com/cuda-gpus"
+ ewarn "or by running /opt/cuda/extras/demo_suite/deviceQuery | grep 'CUDA Capability'"
+ fi
fi
local SYSLIBS=(