summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libghemical/libghemical-2.00.ebuild')
-rw-r--r--sci-libs/libghemical/libghemical-2.00.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/libghemical/libghemical-2.00.ebuild b/sci-libs/libghemical/libghemical-2.00.ebuild
new file mode 100644
index 000000000000..7e7c489336e4
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-2.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="mopac7 mpqc"
+RDEPEND="mopac7? ( sci-chemistry/mopac7 )
+ mpqc? ( >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PV}-really-find-blas-and-lapack.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}