summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch')
-rw-r--r--sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch b/sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch
new file mode 100644
index 000000000000..a042d4c2f72b
--- /dev/null
+++ b/sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch
@@ -0,0 +1,15 @@
+ CMakeLists.txt | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 57394af..5a46a75 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -56,6 +56,7 @@ set (cminpack_hdrs
+ cminpack.h minpack.h)
+
+ add_library (cminpack ${LIB_TYPE} ${cminpack_srcs})
++target_link_libraries (cminpack m)
+
+ install (TARGETS cminpack
+ LIBRARY DESTINATION ${CMINPACK_LIB_INSTALL_DIR} COMPONENT library