summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/cd-hit/Manifest1
-rw-r--r--sci-biology/cd-hit/cd-hit-4.6.6.ebuild48
-rw-r--r--sci-biology/cd-hit/files/cd-hit-4.6.6-fix-build-system.patch122
-rw-r--r--sci-biology/cd-hit/files/cd-hit-4.6.6-fix-perl-shebangs.patch219
4 files changed, 390 insertions, 0 deletions
diff --git a/sci-biology/cd-hit/Manifest b/sci-biology/cd-hit/Manifest
index 5d2ddfeed244..b671c47b321f 100644
--- a/sci-biology/cd-hit/Manifest
+++ b/sci-biology/cd-hit/Manifest
@@ -1,3 +1,4 @@
+DIST cd-hit-4.6.6.tar.gz 1152570 SHA256 97946f8ae62c3efa20ad4c527b8ea22200cf1b75c9941fb14de2bdaf1d6910f1 SHA512 8241d6674fb041559792dbbb58c12b41302d2275d3bacb1362946094b48a0b8e1236e71b5dc77d13405220b60f8253e6f996753a8b051995a72c8353d4333c51 WHIRLPOOL 4ee404e34a9c22aef0b809568aa1a7cefcd8d08e4a8c97d1c65b7692ae14b0567e5cc446054083219b56e89895117f69f786e6183f6c67d03d1f8404f7ba9632
DIST cd-hit-v4.5.1-2011-01-31.tgz 368740 SHA256 c1c3a3a772fc683fec3ff1763fdeec62a0a2a3925124f7a723fe3b271da35281 SHA512 84beba384eb6e9bcf94c7e2ca63f862493fc0d058ad186752524a09016e01274229ca9b7a5275cd5454f54488235a6949e17090ffbf68ff441a613dbe5cf05a8 WHIRLPOOL 698d72f347b92091ade411bdbf540f4b4eeea6c742d3766e891bede7f1aa03024bd2f611a4235a6dec0ed9b9b5e06b3d69a7b8e6a7ab7d8139297b5a8b0da9d2
DIST cd-hit-v4.5.4-2011-03-07.tgz 370264 SHA256 6de9074fada3c5f8109b670b8bdf96679dab45b841d36270d6c5e61a34284f6a SHA512 a093d15e26d6e226e5b37e43ed36affe58c0ee265bd43fd2098a39eafb54c7154ee1a7585da785324dc57532abe3401d48ad5a4a2de080fa6e1422091083683a WHIRLPOOL 3e2ea2db07ecc553d5f03f13a1092e85211257fb4a681629be0350d9cc3f3cc384d24bdb8b3e31d3f469fbc93070363afee608904b9ce3956ca24a8fa6d4d8e5
DIST cd-hit-v4.6-2012-04-25.tgz 652228 SHA256 aa91e57bba61f04db39e83cdd6c8cdf082a006ea8c4c818b956b7531e4bcc2e9 SHA512 1004a4190643b6f5f1da067a4b911abc068d0bf7d909edd84f45d5fe9a1b17eb3276c0ddde391cbc5053a9ab979d09cbbe832615b7cce4fc2aeefce1d1bec52c WHIRLPOOL 1c7a50e40e9753c035a2920af09b024e9403f4a7cf1a801b998afd5b64189256857a236439f5b2935603fd4a691a722a9d74c3a373ab66c79faee9d8335834b4
diff --git a/sci-biology/cd-hit/cd-hit-4.6.6.ebuild b/sci-biology/cd-hit/cd-hit-4.6.6.ebuild
new file mode 100644
index 000000000000..49bea9689980
--- /dev/null
+++ b/sci-biology/cd-hit/cd-hit-4.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+RELDATE="2016-0711"
+RELEASE="${PN}-v${PV}-${RELDATE}"
+
+DESCRIPTION="Clustering Database at High Identity with Tolerance"
+HOMEPAGE="http://weizhong-lab.ucsd.edu/cd-hit/"
+SRC_URI="https://github.com/weizhongli/cdhit/releases/download/V${PV}/${RELEASE}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="openmp"
+
+RDEPEND="dev-lang/perl"
+
+S="${WORKDIR}"/${RELEASE}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.6-fix-perl-shebangs.patch
+ "${FILESDIR}"/${PN}-4.6.6-fix-build-system.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_compile() {
+ tc-export CXX
+ emake openmp=$(usex openmp)
+}
+
+src_install() {
+ dodir /usr/bin
+ PREFIX="${EPREFIX}"/usr/bin default
+
+ dodoc doc/*.pdf
+}
diff --git a/sci-biology/cd-hit/files/cd-hit-4.6.6-fix-build-system.patch b/sci-biology/cd-hit/files/cd-hit-4.6.6-fix-build-system.patch
new file mode 100644
index 000000000000..c668d5c6154e
--- /dev/null
+++ b/sci-biology/cd-hit/files/cd-hit-4.6.6-fix-build-system.patch
@@ -0,0 +1,122 @@
+Fix build system, in order to honour user variables
+
+--- a/makefile
++++ b/makefile
+@@ -1,7 +1,4 @@
+-
+-CC = g++ -Wall -ggdb
+-CC = g++ -pg
+-CC = g++
++CXX ?= g++
+
+ # without OpenMP
+
+@@ -9,35 +6,19 @@
+ # in command line:
+ # make openmp=yes
+ ifeq ($(openmp),no)
+- CCFLAGS = -DNO_OPENMP
+-else
+- CCFLAGS = -fopenmp
+-endif
+-
+-# support debugging
+-# in command line:
+-# make debug=yes
+-# make openmp=yes debug=yes
+-ifeq ($(debug),yes)
+-CCFLAGS += -ggdb
++ my_CPPFLAGS = -DNO_OPENMP
+ else
+-CCFLAGS += -O2
++ my_CXXFLAGS = -fopenmp
+ endif
+
+ ifdef MAX_SEQ
+-CCFLAGS += -DMAX_SEQ=$(MAX_SEQ)
++my_CPPFLAGS += -DMAX_SEQ=$(MAX_SEQ)
+ endif
+
+-#LDFLAGS = -static -o
+-LDFLAGS += -o
+-
+ PROGS = cd-hit cd-hit-est cd-hit-2d cd-hit-est-2d cd-hit-div cd-hit-454
+
+-# Propagate hardening flags
+-CCFLAGS := $(CPPFLAGS) $(CCFLAGS) $(CXXFLAGS)
+-
+ .c++.o:
+- $(CC) $(CCFLAGS) -c $<
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) -c $<
+
+ all: $(PROGS)
+
+@@ -47,52 +28,52 @@
+ # programs
+
+ cd-hit: cdhit-common.o cdhit-utility.o cdhit.o
+- $(CC) $(CCFLAGS) cdhit.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) cdhit.o cdhit-common.o cdhit-utility.o -o cd-hit
+
+ cd-hit-2d: cdhit-common.o cdhit-utility.o cdhit-2d.o
+- $(CC) $(CCFLAGS) cdhit-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-2d
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) cdhit-2d.o cdhit-common.o cdhit-utility.o -o cd-hit-2d
+
+ cd-hit-est: cdhit-common.o cdhit-utility.o cdhit-est.o
+- $(CC) $(CCFLAGS) cdhit-est.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) cdhit-est.o cdhit-common.o cdhit-utility.o -o cd-hit-est
+
+ cd-hit-est-2d: cdhit-common.o cdhit-utility.o cdhit-est-2d.o
+- $(CC) $(CCFLAGS) cdhit-est-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est-2d
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) cdhit-est-2d.o cdhit-common.o cdhit-utility.o -o cd-hit-est-2d
+
+ cd-hit-div: cdhit-common.o cdhit-utility.o cdhit-div.o
+- $(CC) $(CCFLAGS) cdhit-div.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-div
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) cdhit-div.o cdhit-common.o cdhit-utility.o -o cd-hit-div
+
+ cd-hit-454: cdhit-common.o cdhit-utility.o cdhit-454.o
+- $(CC) $(CCFLAGS) cdhit-454.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-454
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) cdhit-454.o cdhit-common.o cdhit-utility.o -o cd-hit-454
+
+ # objects
+ cdhit-common.o: cdhit-common.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-common.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-common.c++ -c
+
+ cdhit-utility.o: cdhit-utility.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-utility.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-utility.c++ -c
+
+ cdhit.o: cdhit.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit.c++ -c
+
+ cdhit-2d.o: cdhit-2d.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-2d.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-2d.c++ -c
+
+ cdhit-est.o: cdhit-est.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-est.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-est.c++ -c
+
+ cdhit-est-2d.o: cdhit-est-2d.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-est-2d.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-est-2d.c++ -c
+
+ cdhit-div.o: cdhit-div.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-div.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-div.c++ -c
+
+ cdhit-454.o: cdhit-454.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-454.c++ -c
++ $(CXX) $(my_CXXFLAGS) $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) cdhit-454.c++ -c
+
+ PREFIX ?= /usr/local/bin
+
+ install:
+ for prog in $(PROGS); do \
+- install -m 0755 $$prog $(PREFIX); \
++ install -m 0755 $$prog $(DESTDIR)$(PREFIX); \
+ done
+- install -m 0755 *.pl $(PREFIX);
++ install -m 0755 *.pl $(DESTDIR)$(PREFIX);
diff --git a/sci-biology/cd-hit/files/cd-hit-4.6.6-fix-perl-shebangs.patch b/sci-biology/cd-hit/files/cd-hit-4.6.6-fix-perl-shebangs.patch
new file mode 100644
index 000000000000..3784296f2e94
--- /dev/null
+++ b/sci-biology/cd-hit/files/cd-hit-4.6.6-fix-perl-shebangs.patch
@@ -0,0 +1,219 @@
+Make perl shebangs more Prefix friendly
+See also: https://blogs.gentoo.org/mgorny/2016/02/08/a-quick-note-on-portable-shebangs/
+
+--- a/cd-hit-2d-para.pl
++++ b/cd-hit-2d-para.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!/usr/bin/env perl
+ # =============================================================================
+ # CD-HIT
+ # http://cd-hit.org/
+--- a/cd-hit-div.pl
++++ b/cd-hit-div.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #not like cd-hit-div, this script do not sort input
+ #or throw away seq
+--- a/cd-hit-para.pl
++++ b/cd-hit-para.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!/usr/bin/env perl
+ # =============================================================================
+ # CD-HIT
+ # http://cd-hit.org/
+--- a/clstr2tree.pl
++++ b/clstr2tree.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ $clstr = shift;
+ $fr = shift; # for nr80.clstr $fr = 0.8
+--- a/clstr2txt.pl
++++ b/clstr2txt.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ my $no = 0;
+ my $clstr_no = "";
+--- a/clstr2xml.pl
++++ b/clstr2xml.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #usage: clstr_xml.pl [-len|-size] level1.clstr [level2.clstr level3.clstr ...]
+ #purpose: to create xml file from cd-hit or hierarchical cd-hit(h-cd-hit) results
+--- a/clstr_cut.pl
++++ b/clstr_cut.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #keep only top $no proteins in cluster
+
+--- a/clstr_merge_noorder.pl
++++ b/clstr_merge_noorder.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ # order of clusters don't need to be the same
+ # but then I have to read everything into memory
+--- a/clstr_merge.pl
++++ b/clstr_merge.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ # the order of clusters need to be identical
+ my ($master_clstr, @clstr) = @ARGV;
+--- a/clstr_quality_eval_by_link.pl
++++ b/clstr_quality_eval_by_link.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ ## calculate the sensitivity and specificity of clusters
+ ## if the input fasta file has pre-defined classification term
+--- a/clstr_quality_eval.pl
++++ b/clstr_quality_eval.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ ## calculate the sensitivity and specificity of clusters
+ ## if the input fasta file has pre-defined classification term
+--- a/clstr_reduce.pl
++++ b/clstr_reduce.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+
+ $file90 = shift;
+--- a/clstr_renumber.pl
++++ b/clstr_renumber.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+ $no = 0;
+ while($ll=<>){
+ if ($ll =~ /^>Cluster (\d+)/) {
+--- a/clstr_rep.pl
++++ b/clstr_rep.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ $rep = "";
+ $no = 0;
+--- a/clstr_reps_faa_rev.pl
++++ b/clstr_reps_faa_rev.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+ # output single fasta file
+ # for each cluster output at least $cutoff seqs
+
+--- a/clstr_rev.pl
++++ b/clstr_rev.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+ # if nr90 from nr100 and
+ # nr80 from nr90, so I have nr90.clstr and nr80.clstr
+ # but, in nr80.clstr, some gi numbers whose from nr100 are there
+--- a/clstr_select.pl
++++ b/clstr_select.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #my $by = shift;
+ my $min;
+--- a/clstr_select_rep.pl
++++ b/clstr_select_rep.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #my $by = shift;
+ my $min;
+--- a/clstr_size_histogram.pl
++++ b/clstr_size_histogram.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ if(@ARGV==0){
+ print "Usage:\n\tclstr_size_histogram.pl [-bin N] clstr_file\n";
+--- a/clstr_size_stat.pl
++++ b/clstr_size_stat.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ if(@ARGV==0){
+ print "Usage:\n\tclstr_size_stat.pl clstr_file\n";
+--- a/clstr_sort_by.pl
++++ b/clstr_sort_by.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ my $sort_by_what = shift;
+ $sort_by_what = "no" unless $sort_by_what;
+--- a/clstr_sort_prot_by.pl
++++ b/clstr_sort_prot_by.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ my $sort_by = shift;
+ $sort_by = "len" unless ($sort_by);
+--- a/clstr_sql_tbl.pl
++++ b/clstr_sql_tbl.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ if(@ARGV==0){
+ print "Usage:\n\tclstr_sql_tbl.pl clstr_file tbl_file\n";
+--- a/clstr_sql_tbl_sort.pl
++++ b/clstr_sql_tbl_sort.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ if(@ARGV==0){
+ print "Usage:\n\tclstr_sql_tbl_sort.pl table_file level\n";
+--- a/make_multi_seq.pl
++++ b/make_multi_seq.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #note you have to use "-d 0" in the cd-hit run
+ #note you better to use "-g 1" in the cd-hit run
+--- a/plot_2d.pl
++++ b/plot_2d.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ use Image::Magick;
+
+--- a/plot_len1.pl
++++ b/plot_len1.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ $file90 = shift;
+ $segs = shift;