summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild')
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index e5093420d6a8..b5e8e3931220 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
@@ -17,10 +19,15 @@ DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-impl-dec.patch
+ "${FILESDIR}"/${P}-C99-decls.patch
"${FILESDIR}"/${P}-MPI-3.0.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
default