summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.9-r1.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.9.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-5.9.ebuild b/net-analyzer/net-snmp/net-snmp-5.9-r1.ebuild
index 5f50c7d5aff0..09e90cd56245 100644
--- a/net-analyzer/net-snmp/net-snmp-5.9.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.9-r1.ebuild
@@ -85,6 +85,9 @@ pkg_setup() {
}
src_prepare() {
+ find -type d -name .libs -depth -exec rm -r {} \; || die
+ find -type f -name '*.o' -o -name '*.lo' -exec rm {} \; || die
+
# snmpconf generates config files with proper selinux context
use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
@@ -138,6 +141,8 @@ src_configure() {
}
src_compile() {
+ emake sedscript
+
local subdir
for subdir in snmplib agent/mibgroup agent apps .; do
emake OTHERLDFLAGS="${LDFLAGS}" -C ${subdir} all