summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wtfis')
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/wtfis-0.6.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
index a4df51163fbf..5ee88c55fe0d 100644
--- a/net-analyzer/wtfis/Manifest
+++ b/net-analyzer/wtfis/Manifest
@@ -1,2 +1,3 @@
DIST wtfis-0.5.0.gh.tar.gz 461913 BLAKE2B 57be019cda4d67943b0c1b2f99013b34351d2ded036f76939f94221218554b5c3fe8711da85f40fcd0fdfbb57df5713b4a72cd09a6b665b5893ffdb8efca493f SHA512 5717ea43d63843f2b6d1e70afac12a70790284a1ed9bdae31c0ee062f77b718e19e913cfefb30cb3bdebf2f925da153354aa906349de97707ac739f736fc94ad
DIST wtfis-0.5.1.gh.tar.gz 462958 BLAKE2B 68d8c89e8e08ba925d5b6847656a0261aa9bfd9e998b7572a8d783c11d99ff06d27870346c8e31d2b8554a5a51b07bf6e08151c87b0a740bccc94a25259dfcb4 SHA512 32091d00d62a78f84e01735b9f9af2b38465c5f2258743b512616b3b43fac7389fa7ef62430e205a004b58a224b154a79fb2e860729925fc7df6a58252fa0093
+DIST wtfis-0.6.1.gh.tar.gz 472803 BLAKE2B 9764d54d88bc8709b67673200a295bc0520438733b45c98d779e088bbcf57778007caf7fa0dcafed881d94bb6b7216f8f00b30b0b0bd528252c18e449865c382 SHA512 75f44416979f7196879a5a3f528caed7154c29f6a79b9ba116bba98f609b5d4bf9f2f78c2eba1e1629fa9f50c60b5678adac98150843fc1ffbedff8bcae3f0f3
diff --git a/net-analyzer/wtfis/wtfis-0.6.1.ebuild b/net-analyzer/wtfis/wtfis-0.6.1.ebuild
new file mode 100644
index 000000000000..bc0d8ff31d44
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~loong ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest