summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild')
-rw-r--r--media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild b/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
new file mode 100644
index 000000000000..a7bca1511b74
--- /dev/null
+++ b/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: (Un)Mount removable media via osd"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Mount-plugin"
+SRC_URI="http://homepages.physik.uni-muenchen.de/~Felix.Rauscher/${P}.tgz"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.6"
+
+PATCHES=("${FILESDIR}/${P}-makefile-fix.diff")
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-2.1.2"; then
+ sed -e "s#VideoDirectory#cVideoDirectory::Name\(\)#" \
+ -i MediumItem.C
+ fi
+}