summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-x')
-rw-r--r--media-plugins/gst-plugins-x/Manifest1
-rw-r--r--media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild32
-rw-r--r--media-plugins/gst-plugins-x/gst-plugins-x-0.10.36.ebuild31
-rw-r--r--media-plugins/gst-plugins-x/metadata.xml5
4 files changed, 69 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-x/Manifest b/media-plugins/gst-plugins-x/Manifest
new file mode 100644
index 000000000000..d213e8b3ff2a
--- /dev/null
+++ b/media-plugins/gst-plugins-x/Manifest
@@ -0,0 +1 @@
+DIST gst-plugins-base-0.10.36.tar.xz 2364108 SHA256 1fe45c3894903001d4d008b0713dab089f53726dcb5842d5b40c2595a984e64a SHA512 ea77778e073515df58229a641b4363df31f0b80204a5a43a8feb31f0b03a5a4b9b79d6e07e1615c773a59927a9b649f1b1d782def1120d581d09a090be8363b8 WHIRLPOOL e455f2a1aafd60078080735108e4ac336bc4764ed92b9579d83a453f75491331d16b48e5983f3c9712b6edb28ec379e696f06f6910c93168b019d6077c28fb6d
diff --git a/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild
new file mode 100644
index 000000000000..d429da391536
--- /dev/null
+++ b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-base
+inherit gstreamer
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+
+# xshm is a compile time option of ximage, which is in libXext
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+
+ gstreamer_system_link \
+ gst-libs/gst/video:gstreamer-video \
+ gst-libs/gst/interfaces:gstreamer-interfaces
+}
diff --git a/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36.ebuild b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36.ebuild
new file mode 100644
index 000000000000..07e31232b40a
--- /dev/null
+++ b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gst-plugins-base gst-plugins10
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+# xshm is a compile time option of ximage, which is in libXext
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+
+ gst-plugins10_system_link \
+ gst-libs/gst/video:gstreamer-video \
+ gst-libs/gst/interfaces:gstreamer-interfaces
+}
diff --git a/media-plugins/gst-plugins-x/metadata.xml b/media-plugins/gst-plugins-x/metadata.xml
new file mode 100644
index 000000000000..9e260ceca3e3
--- /dev/null
+++ b/media-plugins/gst-plugins-x/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+</pkgmetadata>