summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsfml/libsfml-2.3.2-r1.ebuild6
-rw-r--r--media-libs/libsfml/libsfml-2.4.1.ebuild4
-rw-r--r--media-libs/libsfml/libsfml-2.4.2.ebuild2
3 files changed, 7 insertions, 5 deletions
diff --git a/media-libs/libsfml/libsfml-2.3.2-r1.ebuild b/media-libs/libsfml/libsfml-2.3.2-r1.ebuild
index 3a3d39abe39b..ab1db567cd3c 100644
--- a/media-libs/libsfml/libsfml-2.3.2-r1.ebuild
+++ b/media-libs/libsfml/libsfml-2.3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -38,8 +38,10 @@ DOCS="changelog.txt readme.txt"
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${PN}-2.2-no-docs.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2-no-docs.patch
+ cmake-utils_src_prepare
sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \
doc/CMakeLists.txt || die
diff --git a/media-libs/libsfml/libsfml-2.4.1.ebuild b/media-libs/libsfml/libsfml-2.4.1.ebuild
index fe2e6ac0c094..01bb090a4a65 100644
--- a/media-libs/libsfml/libsfml-2.4.1.ebuild
+++ b/media-libs/libsfml/libsfml-2.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -44,7 +44,7 @@ src_prepare() {
sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \
doc/CMakeLists.txt || die
- default
+ cmake-utils_src_prepare
}
src_configure() {
diff --git a/media-libs/libsfml/libsfml-2.4.2.ebuild b/media-libs/libsfml/libsfml-2.4.2.ebuild
index 20adbafd423f..b27433df7bd9 100644
--- a/media-libs/libsfml/libsfml-2.4.2.ebuild
+++ b/media-libs/libsfml/libsfml-2.4.2.ebuild
@@ -48,7 +48,7 @@ src_prepare() {
sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \
doc/CMakeLists.txt || die
- default
+ cmake-utils_src_prepare
}
src_configure() {