summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/shotwell/shotwell-0.29.3.ebuild')
-rw-r--r--media-gfx/shotwell/shotwell-0.29.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/shotwell/shotwell-0.29.3.ebuild b/media-gfx/shotwell/shotwell-0.29.3.ebuild
new file mode 100644
index 000000000000..907f0fe8c500
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.29.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 meson vala
+
+DESCRIPTION="Shotwell is a photo manager for GNOME 3"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-crypt/gcr:=[gtk,vala]
+ dev-libs/libgdata:=[vala]
+ dev-libs/libgee:=
+ media-libs/gexiv2:=[introspection,vala]
+ media-libs/libexif:=
+ media-libs/libgphoto2:=
+ media-libs/libraw:=
+ net-libs/webkit-gtk:=
+ x11-libs/gtk+:=[X]
+"
+DEPEND="
+ ${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+"
+
+src_prepare() {
+ vala_src_prepare
+ eapply_user
+}