summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/baloo')
-rw-r--r--kde-frameworks/baloo/Manifest1
-rw-r--r--kde-frameworks/baloo/baloo-5.104.0-r1.ebuild37
-rw-r--r--kde-frameworks/baloo/files/baloo-5.104.0-skip-all-unprintable-chars.patch70
3 files changed, 0 insertions, 108 deletions
diff --git a/kde-frameworks/baloo/Manifest b/kde-frameworks/baloo/Manifest
index 84784cd9b290..f1aa1ab918c2 100644
--- a/kde-frameworks/baloo/Manifest
+++ b/kde-frameworks/baloo/Manifest
@@ -1,3 +1,2 @@
-DIST baloo-5.104.0.tar.xz 305536 BLAKE2B ea76fa769acfb79b4af1c5c5338ef15c39943828e9ce68078ded7ea4abf77110d15aa629a40ed9d1fa666ad546ad896d1b9e51ea43a66b0a992efae089d46d3c SHA512 80ecea86735606798f8500eafcceee5b5dda13c33c2707791baf88d6961d843d239264aea27c1d97c131d8558b4421a251e1c9aed823e3d9214f633488f860fa
DIST baloo-5.106.0.tar.xz 307056 BLAKE2B 6531e3fa999c5f6a006a22515fb624cb413a78eabb146d44b51d83c84d391530021e3b3734c1602087fa066de6c810af058c06396eaf6e27cd1c8ceae6c7f11d SHA512 4270bca2bb7a0a82383b195d87689df4a868dc6ba510d2aee2d26aeb853451c437ac9340bcb6954acba5a1c8c92fb36b8702dfabb4c5f5ab61bc17f7def61318
DIST baloo-5.107.0.tar.xz 307888 BLAKE2B e6d51d4f2520c04ea3a65dc1c8481ef73ca6ce8f85d57badf02527650893d23d6c13e3f079329f2d3dcea81b9bdeea4596469a3d246d4d718c85e29698a9c545 SHA512 f264e0061b375b8afde4f9167d5e08533dac53aef34517476bfe06b9d93d16af459df4394b25b2f1af5f55cf545773d7281ec047ee81d8980ba41cc6a50302c0
diff --git a/kde-frameworks/baloo/baloo-5.104.0-r1.ebuild b/kde-frameworks/baloo/baloo-5.104.0-r1.ebuild
deleted file mode 100644
index e50fc19b8339..000000000000
--- a/kde-frameworks/baloo/baloo-5.104.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.5
-VIRTUALX_REQUIRED="test"
-inherit ecm frameworks.kde.org
-
-DESCRIPTION="Framework for searching and managing metadata"
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE=""
-
-RESTRICT="test" # bug 624250
-
-DEPEND="
- >=dev-db/lmdb-0.9.17
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/kcrash-${PVCUT}*:5
- =kde-frameworks/kdbusaddons-${PVCUT}*:5
- =kde-frameworks/kfilemetadata-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kidletime-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/solid-${PVCUT}*:5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-skip-all-unprintable-chars.patch" )
diff --git a/kde-frameworks/baloo/files/baloo-5.104.0-skip-all-unprintable-chars.patch b/kde-frameworks/baloo/files/baloo-5.104.0-skip-all-unprintable-chars.patch
deleted file mode 100644
index 7e9eb0d74c42..000000000000
--- a/kde-frameworks/baloo/files/baloo-5.104.0-skip-all-unprintable-chars.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 886aba423f3659ef591903f1f3dea87f8b4c6016 Mon Sep 17 00:00:00 2001
-From: Igor Poboiko <igor.poboiko@gmail.com>
-Date: Mon, 20 Mar 2023 13:20:33 +0000
-Subject: [PATCH] [TermGenerator] Skip all unprintable characters
-
-Some extractors can produce text which includes special unicode
-control characters (e.g. Poppler can give us 0x0001 from some PDFs).
-TermGenerator then generates proper (yet meaningless) terms out of those
-characters, and they end up in database. It should be safe to skip all
-unprintable characters to avoid that (although surrogates are fine, they
-are dealt with later via QString::normalize call).
-
-Character 0x0001 is the worst, as it is used internally in DocTermsCodec
-for compactification. Such collision then leads to the corrupted database
-(some terms from DocTermsDB are not present in PostingDB).
-
-The corruption is not hypothetical (although not critical), I've encountered bunch of broken DB entries for some PDF files on my machine.
-
-
-(cherry picked from commit 492321e53a41762555ba6528e15cd0d0188ed153)
----
- autotests/unit/engine/termgeneratortest.cpp | 11 +++++++++++
- src/engine/termgenerator.cpp | 2 +-
- 2 files changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/autotests/unit/engine/termgeneratortest.cpp b/autotests/unit/engine/termgeneratortest.cpp
-index 361c4934c..69885c133 100644
---- a/autotests/unit/engine/termgeneratortest.cpp
-+++ b/autotests/unit/engine/termgeneratortest.cpp
-@@ -31,6 +31,7 @@ private Q_SLOTS:
- void testWordPositions();
- void testWordPositionsCJK();
- void testNumbers();
-+ void testControlCharacter();
-
- QList<QByteArray> allWords(const QString& str)
- {
-@@ -213,6 +214,16 @@ void TermGeneratorTest::testNumbers()
- QCOMPARE(words, expectedWords);
- }
-
-+void TermGeneratorTest::testControlCharacter()
-+{
-+ QString str = QString::fromUtf8("word1\u0001word2");
-+
-+ QList<QByteArray> words = allWords(str);
-+ QList<QByteArray> expectedWords = { "word1", "word2" };
-+
-+ QCOMPARE(words, expectedWords);
-+}
-+
- QTEST_MAIN(TermGeneratorTest)
-
- #include "termgeneratortest.moc"
-diff --git a/src/engine/termgenerator.cpp b/src/engine/termgenerator.cpp
-index d98b28416..832962da1 100644
---- a/src/engine/termgenerator.cpp
-+++ b/src/engine/termgenerator.cpp
-@@ -59,7 +59,7 @@ QByteArrayList TermGenerator::termList(const QString& text_)
- int start = 0;
-
- auto isSkipChar = [] (const QChar& c) {
-- return c.isPunct() || c.isMark() || c.isSpace();
-+ return c.isPunct() || c.isMark() || c.isSpace() || (!c.isPrint() && !c.isSurrogate());
- };
-
- QByteArrayList list;
---
-GitLab
-