summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/lightyears/lightyears-1.4-r3.ebuild (renamed from games-strategy/lightyears/lightyears-1.4-r2.ebuild)28
1 files changed, 17 insertions, 11 deletions
diff --git a/games-strategy/lightyears/lightyears-1.4-r2.ebuild b/games-strategy/lightyears/lightyears-1.4-r3.ebuild
index 7e7344951fc2..4d4cfa964e45 100644
--- a/games-strategy/lightyears/lightyears-1.4-r2.ebuild
+++ b/games-strategy/lightyears/lightyears-1.4-r3.ebuild
@@ -1,34 +1,37 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
PYTHON_COMPAT=( python2_7 )
-inherit desktop python-single-r1
+inherit desktop python-single-r1 xdg-utils
DESCRIPTION="A single-player game with a science-fiction theme"
-HOMEPAGE="http://www.jwhitham.org/20kly/"
-SRC_URI="http://www.jwhitham.org/20kly/${P}.tar.bz2"
-
+HOMEPAGE="https://www.jwhitham.org/20kly/"
+SRC_URI="https://www.jwhitham.org/20kly/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
dev-python/pygame[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-gentoo.patch
+)
src_prepare() {
default
- eapply "${FILESDIR}/${P}"-gentoo.patch
+
sed -i \
-e "s:@GENTOO_LIBDIR@:/usr/$(get_libdir)/${PN}:" \
-e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
${PN} || die
+
python_fix_shebang .
}
@@ -48,3 +51,6 @@ src_install() {
newicon data/32.png ${PN}.png
make_desktop_entry ${PN} "Light Years Into Space"
}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }