diff options
Diffstat (limited to 'games-action')
-rw-r--r-- | games-action/rrootage/files/rrootage-0.23a-gcc41.patch | 8 | ||||
-rw-r--r-- | games-action/rrootage/rrootage-0.23a-r2.ebuild (renamed from games-action/rrootage/rrootage-0.23a-r1.ebuild) | 12 |
2 files changed, 11 insertions, 9 deletions
diff --git a/games-action/rrootage/files/rrootage-0.23a-gcc41.patch b/games-action/rrootage/files/rrootage-0.23a-gcc41.patch index 1e6e50e683fd..00926f9b75dc 100644 --- a/games-action/rrootage/files/rrootage-0.23a-gcc41.patch +++ b/games-action/rrootage/files/rrootage-0.23a-gcc41.patch @@ -1,5 +1,5 @@ ---- src/foecommand.h.old 2006-04-21 23:26:03.000000000 +0200 -+++ src/foecommand.h 2006-04-21 23:26:26.000000000 +0200 +--- a/foecommand.h ++++ b/foecommand.h @@ -39,10 +39,10 @@ virtual void doChangeDirection(double d);
@@ -15,8 +15,8 @@ private:
struct foe *foe;
---- src/screen.c.old 2006-04-21 23:50:01.000000000 +0200 -+++ src/screen.c 2006-04-21 23:50:30.000000000 +0200 +--- a/screen.c ++++ b/screen.c @@ -73,7 +73,7 @@ void loadGLTexture(char *fileName, GLuint *texture) {
SDL_Surface *surface;
diff --git a/games-action/rrootage/rrootage-0.23a-r1.ebuild b/games-action/rrootage/rrootage-0.23a-r2.ebuild index 7fbee7b1a767..0defc88d5323 100644 --- a/games-action/rrootage/rrootage-0.23a-r1.ebuild +++ b/games-action/rrootage/rrootage-0.23a-r2.ebuild @@ -1,7 +1,9 @@ # Copyright 1999-2021 Gentoo Authors # Distributed under the terms of the GNU General Public License v2 -EAPI=6 +EAPI=7 + +inherit toolchain-funcs MY_PN="rRootage" MY_P="${MY_PN}-${PV}" @@ -9,11 +11,11 @@ DESCRIPTION="Abstract shooter - defeat auto-created huge battleships" HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/rr_e.html http://rrootage.sourceforge.net/" SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz" +S="${WORKDIR}"/${MY_PN}/src LICENSE="BSD" SLOT="0" KEYWORDS="~amd64 ~x86" -IUSE="" DEPEND=" >=dev-libs/libbulletml-0.0.3 @@ -21,9 +23,7 @@ DEPEND=" media-libs/sdl-mixer[vorbis] virtual/glu virtual/opengl" -RDEPEND=${DEPEND} - -S=${WORKDIR}/${MY_PN}/src +RDEPEND="${DEPEND}" PATCHES=( "${FILESDIR}/${P}"-gcc41.patch @@ -50,6 +50,8 @@ src_prepare() { src_compile() { emake \ + CC=$(tc-getCC) \ + CXX=$(tc-getCXX) \ MORE_CFLAGS="-DLINUX ${CFLAGS}" \ MORE_CXXFLAGS="-DLINUX ${CXXFLAGS}" } |