summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/violetland/files/violetland-0.5-boost1.85.patch8
-rw-r--r--games-action/violetland/violetland-0.5.ebuild6
2 files changed, 13 insertions, 1 deletions
diff --git a/games-action/violetland/files/violetland-0.5-boost1.85.patch b/games-action/violetland/files/violetland-0.5-boost1.85.patch
new file mode 100644
index 000000000000..8382122c0ccf
--- /dev/null
+++ b/games-action/violetland/files/violetland-0.5-boost1.85.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/932778
+--- a/src/game/Highscores.cpp
++++ b/src/game/Highscores.cpp
+@@ -107,3 +107,3 @@
+ boost::filesystem::copy_file(hsTempFile, hsFile,
+- boost::filesystem::copy_option::overwrite_if_exists);
++ boost::filesystem::copy_options::overwrite_existing);
+ boost::filesystem::remove(hsTempFile);
diff --git a/games-action/violetland/violetland-0.5.ebuild b/games-action/violetland/violetland-0.5.ebuild
index 21c08d426767..2db7c5ac14cf 100644
--- a/games-action/violetland/violetland-0.5.ebuild
+++ b/games-action/violetland/violetland-0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,10 @@ BDEPEND="
sys-devel/gettext
"
+PATCHES=(
+ "${FILESDIR}"/${P}-boost1.85.patch
+)
+
src_prepare() {
cmake_src_prepare