summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/elfkickers/elfkickers-3.1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-util/elfkickers/elfkickers-3.1.ebuild b/dev-util/elfkickers/elfkickers-3.1.ebuild
index 57d7594f539c..0fd4830cc4eb 100644
--- a/dev-util/elfkickers/elfkickers-3.1.ebuild
+++ b/dev-util/elfkickers/elfkickers-3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PN=${PN/elf/ELF}-${PV}
S=${WORKDIR}/${MY_PN}
@@ -20,13 +20,16 @@ IUSE="doc"
DEPEND="app-misc/pax-utils"
RDEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-CFLAGS-LDFLAGS.patch
+ "${FILESDIR}"/${P}-create-destdir-path.patch
+ "${FILESDIR}"/add-freebsd-elf-defs.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-respect-CFLAGS-LDFLAGS.patch
- epatch "${FILESDIR}"/${P}-create-destdir-path.patch
- epatch "${FILESDIR}"/add-freebsd-elf-defs.patch
+ default
sed -i -e "s:^prefix = /usr/local:prefix = ${D}:" Makefile \
|| die "sed failed"
- eapply_user
}
src_compile() {