summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
index e0569a0e7981..5347cee7ffdc 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
@@ -203,8 +203,8 @@ src_compile() {
# mostly unused here, so use configure directly
eval '
local conf=( "${WORKDIR}/${1}"/configure "${conf[@]}" )
- [[ ${conf_'${id}'@a} ]] && conf+=( "${conf_'${id}'[@]}" )
- [[ ${2} && ${conf_'${id}_${2}'@a} ]] && conf+=( "${conf_'${id}_${2}'[@]}" )
+ [[ ${conf_'${id}'@a} =~ a ]] && conf+=( "${conf_'${id}'[@]}" )
+ [[ ${2} && ${conf_'${id}_${2}'@a} =~ a ]] && conf+=( "${conf_'${id}_${2}'[@]}" )
conf+=( ${EXTRA_ECONF} ${MWT_'${id^^}'_CONF} )
[[ ${2} ]] && conf+=( ${MWT_'${1^^}_${2^^}'_CONF} )'