summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-3.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-3.6-r1.ebuild b/dev-util/include-what-you-use/include-what-you-use-3.6-r1.ebuild
new file mode 100644
index 000000000000..a959f45c54cb
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-3.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils flag-o-matic
+
+WEIRD_UPSREAM_VERSION=0.4
+
+DESCRIPTION="find unused include directives in C/C++ programs"
+HOMEPAGE="http://include-what-you-use.org/"
+SRC_URI="http://include-what-you-use.org/downloads/${PN}-${WEIRD_UPSREAM_VERSION}.src.tar.gz -> ${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sys-devel/llvm-3.6
+ >=sys-devel/clang-3.6
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ append-ldflags -L$(llvm-config --libdir)
+
+ local mycmakeargs=(
+ -DLLVM_PATH=$(llvm-config --libdir)
+ )
+ cmake-utils_src_configure
+}