summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch9
-rw-r--r--dev-util/patchelf/patchelf-0.18.0.ebuild6
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch b/dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch
new file mode 100644
index 000000000000..fd92c803ac7c
--- /dev/null
+++ b/dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch
@@ -0,0 +1,9 @@
+Add define for DT_MIPS_XHASH (MIPS gnu hash support) using system elf.h header.
+Bug: https://bugs.gentoo.org/860888
+--- /dev/null
++++ b/src/elf.h
+@@ -0,0 +1,4 @@
++#include_next <elf.h>
++#ifndef DT_MIPS_XHASH
++#define DT_MIPS_XHASH 0x70000036
++#endif
diff --git a/dev-util/patchelf/patchelf-0.18.0.ebuild b/dev-util/patchelf/patchelf-0.18.0.ebuild
index cbc25bb40a74..b0778e8b721b 100644
--- a/dev-util/patchelf/patchelf-0.18.0.ebuild
+++ b/dev-util/patchelf/patchelf-0.18.0.ebuild
@@ -12,9 +12,13 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
LICENSE="GPL-3"
+PATCHES=(
+ "${FILESDIR}"/${PN}-glibc-dt-mips-xhash.patch
+)
+
src_prepare() {
- default
rm src/elf.h || die
+ default
sed -i \
-e 's:-Werror::g' \