summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.5.ebuild')
-rw-r--r--dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.5.ebuild b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.5.ebuild
new file mode 100644
index 000000000000..34f782594b61
--- /dev/null
+++ b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# no tests present
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe plugins providing tasks used by seattle.rb"
+HOMEPAGE="https://github.com/seattlerb/hoe-seattlerb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Not a real fix, but otherwise USE="doc" breaks and defaulte license is MIT
+ sed -i -e "/license/d" Rakefile || die
+}