summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dalli')
-rw-r--r--dev-ruby/dalli/Manifest1
-rw-r--r--dev-ruby/dalli/dalli-3.2.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/dalli/Manifest b/dev-ruby/dalli/Manifest
index 77085b067f49..d4a061f40996 100644
--- a/dev-ruby/dalli/Manifest
+++ b/dev-ruby/dalli/Manifest
@@ -1 +1,2 @@
DIST dalli-3.2.3.tar.gz 71163 BLAKE2B cdb205f39dce8e7c64da808a5da8b0c295ca938b21d1a42f16a7fda06d47b11c9d357240d633b17ec140e90a1838d4e28da6333971eaad043ffd04508ffb7537 SHA512 43729fa6f7ee92d886e113c6c04f1334c74bcb189e5c75205cc955a94fe1e0d834f94b69d1e9408609f4039018417da74f9b80fc8851ed33ee3fd60fb77df224
+DIST dalli-3.2.4.tar.gz 71999 BLAKE2B bb4ea91328e60740d8be0664b2a359007230efcc87611e620b08cc18292e85384780afcc09de575314f3bd39d261b8d26c558f4329ba55f13f1306681ce0ec71 SHA512 5f5f802a76b1d611b42251c8eb70538cb1da6b43bb681fb7e0b4a7124bf46ab4d89be4ab31bb071d7205c897ba940ef523384efa18b5723d57d8edaea2198350
diff --git a/dev-ruby/dalli/dalli-3.2.4.ebuild b/dev-ruby/dalli/dalli-3.2.4.ebuild
new file mode 100644
index 000000000000..204696f2dc97
--- /dev/null
+++ b/dev-ruby/dalli/dalli-3.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4[ssl(-)] )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/rack
+)"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; require "dalli"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ sed -i -e "s:/tmp:${T}:" test/utils/certificate_generator.rb || die
+}