summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-core')
-rw-r--r--dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-15.1.0.ebuild2
-rw-r--r--dev-python/twisted-core/twisted-core-15.2.1.ebuild2
4 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild b/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
index 9ad0618b6f8d..bca82a6434c3 100644
--- a/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
@@ -14,12 +14,13 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="crypt gtk serial"
DEPEND="
- !dev-python/twisted
dev-python/zope-interface[${PYTHON_USEDEP}]
crypt? ( >=dev-python/pyopenssl-0.10[${PYTHON_USEDEP}] )
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-13.2.0.ebuild b/dev-python/twisted-core/twisted-core-13.2.0.ebuild
index a76b78a81c55..f6679b00a8ee 100644
--- a/dev-python/twisted-core/twisted-core-13.2.0.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.2.0.ebuild
@@ -14,12 +14,13 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86
IUSE="crypt gtk serial"
DEPEND="
- !dev-python/twisted
>=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
crypt? ( >=dev-python/pyopenssl-0.10[${PYTHON_USEDEP}] )
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-15.1.0.ebuild b/dev-python/twisted-core/twisted-core-15.1.0.ebuild
index 93f7667a2cb3..78aad2ec8b17 100644
--- a/dev-python/twisted-core/twisted-core-15.1.0.ebuild
+++ b/dev-python/twisted-core/twisted-core-15.1.0.ebuild
@@ -19,9 +19,9 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
DEPEND="
- !dev-python/twisted
test? ( ${RDEPEND} )
"
+RDEPEND+=" !dev-python/twisted"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-15.2.1.ebuild b/dev-python/twisted-core/twisted-core-15.2.1.ebuild
index 4e7645a7af97..1ee03465cba4 100644
--- a/dev-python/twisted-core/twisted-core-15.2.1.ebuild
+++ b/dev-python/twisted-core/twisted-core-15.2.1.ebuild
@@ -19,9 +19,9 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
DEPEND="
- !dev-python/twisted
test? ( ${RDEPEND} )
"
+RDEPEND+=" !dev-python/twisted"
PATCHES=(
# Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.