summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.17.0.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index c8b48a0ca6d5..504d2642adc0 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,3 +1,2 @@
DIST openapi-core-0.16.6.gh.tar.gz 104008 BLAKE2B bb1bdac98dfc5aef0961624488074363568f53a6c44cb0730be0d103d891d24bed86659f640e0d07da4072edc233c904c0ddcfd9e8b3960ace1af078c0d745e5 SHA512 556636a4698dcd7db6c656333849077abacdac1a440fe58210ad8f02c1f0220e46dea29962346dfb3f89d164ebc986ec750c184840be9a34a5e1dd98fbf8ef98
-DIST openapi-core-0.17.0.gh.tar.gz 129743 BLAKE2B 34b64f2c956218377d37c5f9e382aa503d50556d2a9ff292355831a39ff9632942b3dd6074cf91ba6cdb2fd93e12e4b3700232e720c71e814fde27f08052bb5a SHA512 6c284cbc8656b319291d81b73c3b714e1b9d8f85bbdf4b4636f8adcd0e47e59147f96a9cf117a6fcd49b7eeea4bbdbee28e3b60019add652e527c6af554d1cb7
DIST openapi_core-0.17.1.tar.gz 85686 BLAKE2B f18b42fc496eaf4d6b82c15f66dd9c2eb9240402590b5a8e1f0e7b1e804c90aeef2db96d19683e9fea5846e776e95981ac52a38c47e2b56e6b5fd63d072b61f7 SHA512 0e2c673dbbfcce87ae7fbca6ec6c283d94c36376b1e17191d0bfa6c7001c62913381169b4614b5cd6131eaa67b729365036be3f1eb7641f634c0f3228de54897
diff --git a/dev-python/openapi-core/openapi-core-0.17.0.ebuild b/dev-python/openapi-core/openapi-core-0.17.0.ebuild
deleted file mode 100644
index 71bba2ce0c30..000000000000
--- a/dev-python/openapi-core/openapi-core-0.17.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/python-openapi/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-SRC_URI="
- https://github.com/python-openapi/openapi-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.4.2[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/asgiref[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/starlette-0.21.0[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # falcon is not packaged
- tests/integration/contrib/falcon
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/django/test_django_project.py
- tests/unit/contrib/django/test_django.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}